PartDesign Mirrored crash

About the development of the Part Design module/workbench. PLEASE DO NOT POST HELP REQUESTS HERE!
tempr
Posts: 24
Joined: Wed Apr 23, 2014 12:03 am

Re: PartDesign Mirrored crash

Postby tempr » Fri Apr 25, 2014 4:34 pm

Yes i agree it is s bit strange you are able to create both horizontal/vertical mirror for Groove feature this way. Maybe that does indicate i is not just the OCC/OCE fault but i guess what ever is the cause got fixed in newer version of FreeCAD or OCC/OCE. At least for the crashing part.


Yea, it seems that whatever was causing the hang is fixed in this new build normandc suggested I should try. Maybe it should be revisited later if someone discovers other weird things happening which could be related to this issue.

My new build info:

OS: Windows 7
Platform: 32-bit
Version: 0.14.3343 (Git)
Branch: libpack
Hash: 8dcb8f68cf17ef152d34d226d7699c98c5bb59fb
Python version: 2.7.6
Qt version: 4.8.5
Coin version: 3.1.3
SoQt version: 1.5.0
OCC version: 6.7.0

I guess it failed because you used snap mode again and when entering that corner case scenario as seen on image that causes the issue with refreshing the groove feature. Try on newer version as it was suggested and if it will be still there maybe this is something for bug tracker. But i guess that crashing part should be gone.


Yep it seems to be a problem related to snap. I could reproduce it even in this new version but only if snap was active. It is still a bug, right? I suspect that it could happen to other cases not just groove on my model since it is caused by snap.
triplus
Posts: 4833
Joined: Mon Dec 12, 2011 4:45 pm

Re: PartDesign Mirrored crash

Postby triplus » Fri Apr 25, 2014 5:12 pm

I mentioned snap because when snap is used it gets you precisely in that corner case scenario easily. The culprit is therefore probably not snap itself.

You can try and constraint the sketch and instead of using the snap you could change one of the constraints that will move that line at that exact same position back and forward few times. I am guessing you will be able to reproduce the issue you are seeing.

It is still a bug, right?


Yes but i am not sure if it is FreeCAD or OCC/OCE related.
tempr
Posts: 24
Joined: Wed Apr 23, 2014 12:03 am

Re: PartDesign Mirrored crash

Postby tempr » Fri Apr 25, 2014 7:05 pm

I mentioned snap because when snap is used it gets you precisely in that corner case scenario easily. The culprit is therefore probably not snap itself.


Well it only happens if snap is on I tried to reproduce it without snap and couldn't. If you were (by corner case scenario) referencing the overlapping geometry problem (caused by using snap to construct both sketches I was using to make my models) that was causing the first problem I encountered (hang), idk if that is what is behind this problem as it appears even if I move the sketch used to make the groove outside the "trouble" zone. On further testing, I have also found that I can move the affected point if it is selected first, just trying to move it fails like already mentioned.

I have resized the middle hole and tried to reproduce the bug and sure it happened again:

Image

While experimenting with that scene I encountered two more bugs, check the next two pictures. :)

New bug 1: I tried to reproduce the previous bug using constraints as you suggested but couldn't. I did get this though after I tried to move the menu out of the way so I can see the scene behind it (it is a bit exaggerated on the picture as I moved it around a bit more so it is clear what is it about):

Image

New bug 2: And when I tried to change the dimensions of the shape used for the Revolution object in the scene (eliminating the hole feature completely) I got this error message in the report view: "No planar face in Part2DObject::positionBySupport()!" and the object Groove would stop responding to changes in the sketch used to make it, sketch would get a red exclamation mark on it and the view would display the Groove object before the change in Revolution object. I could refresh the view to display the change in Groove object made with new revolution if I tried to edit the Groove sketch (hole in the middle dissapeared) but the actual Groove feature would become totaly unresponsive (no changes on the screen).

Image

I suspect that the problem here is that the revolution creates an object with erroneous faces (setting one dimension of the rectangle to the same value as the rotation axis seems to produce invalid - non planar faces and as planar faces are required for the Groove feature it stops working.
triplus
Posts: 4833
Joined: Mon Dec 12, 2011 4:45 pm

Re: PartDesign Mirrored crash

Postby triplus » Fri Apr 25, 2014 8:38 pm

And when I tried to change the dimensions of the shape used for the Revolution object in the scene (eliminating the hole feature completely) I got this error message in the report view: "No planar face in Part2DObject::positionBySupport()!" and the object Groove would stop responding to changes in the sketch used to make it, sketch would get a red exclamation mark on it and the view would display the Groove object before the change in Revolution object.


Yes this is normal behaviour. After you made Revolution you added new Sketch on one of the faces of Revolution. If you want to remove the hole from original sketch Revolution is based on you have to add that as feature at the end of the tree view otherwise you brake stuff. You can change (constraints values) sketches but can not add/delete stuff once you used it as a basis for a feature like Revolution or Pad and you used face of that feature as support for new sketch. This is something you will have to learn trough practice. You need to re-attach the Groove sketch to the face of Revolution first. You can do that in Part Design workbench under Part Design -> Map sketch to face...

If you want to learn more about this and how this will improve in the future find more info on the forum (topological naming) or ask.

I have resized the middle hole and tried to reproduce the bug and sure it happened again:


I tried to reproduce the previous bug using constraints as you suggested but couldn't.


Yes that could indicate FreeCAD bug.
tempr
Posts: 24
Joined: Wed Apr 23, 2014 12:03 am

Re: PartDesign Mirrored crash

Postby tempr » Fri Apr 25, 2014 9:50 pm

Yes this is normal behaviour.

Normal? I was sure I found another bug. At least there is a workaround available and if it gets fixed in the future, great.

Yes that could indicate FreeCAD bug.

OK I will report it tomorrow.
triplus
Posts: 4833
Joined: Mon Dec 12, 2011 4:45 pm

Re: PartDesign Mirrored crash

Postby triplus » Fri Apr 25, 2014 10:08 pm

Normal? I was sure I found another bug. At least there is a workaround available and if it gets fixed in the future, great.


Yes up to a point this will improve in the future but as you will learn with time you will have to do your part in the end to prevent it in the first place.

OK I will report it tomorrow.


Great. Supplying .fcstd file with description how to reproduce the behaviour is always welcomed and makes devs job easier and faster.
tempr
Posts: 24
Joined: Wed Apr 23, 2014 12:03 am

Re: PartDesign Mirrored crash

Postby tempr » Sat Apr 26, 2014 4:38 pm

Refreshing Groove geometry reported here: issue #0001516

Menu display problem reported here: issue #0001517
User avatar
Kunda1
Posts: 611
Joined: Thu Jan 05, 2017 9:03 pm

Re: PartDesign Mirrored crash

Postby Kunda1 » Thu Jan 12, 2017 11:58 pm

tempr wrote:Refreshing Groove geometry reported here: issue #0001516

Menu display problem reported here: issue #0001517


FYI issue #0001517 was closed.
Is issue #0001516 still valid? According to @wmayer it's not reproducible.
User avatar
NormandC
Posts: 12022
Joined: Sat Feb 06, 2010 9:52 pm
Location: Québec, Canada

Re: PartDesign Mirrored crash

Postby NormandC » Sat Jan 14, 2017 7:31 pm

Kunda1 wrote:Is issue #0001516 still valid? According to @wmayer it's not reproducible.

I couldn't reproduce it either, so I would close it. (Left a comment on the bug)

Besides, with the externally hosted images all disappeared, this topic has lost much of its usefulness...
User avatar
Kunda1
Posts: 611
Joined: Thu Jan 05, 2017 9:03 pm

Re: PartDesign Mirrored crash

Postby Kunda1 » Sat Jan 14, 2017 8:24 pm

NormandC wrote:
Kunda1 wrote:Is issue #0001516 still valid? According to @wmayer it's not reproducible.

I couldn't reproduce it either, so I would close it. (Left a comment on the bug)

Besides, with the externally hosted images all disappeared, this topic has lost much of its usefulness...

Agreed. I will resolve and let the devs close it. Thanks!