Now we have
- Menu Edit -> Toggle Edit mode, and
- Right-click on object -> Transform
Since they do the same thing, they should have the same name. Or you want to keep two different names?
In addition, the page that describes the command has a third name: Std_Edit.
What is the right name? Also for the "What's This" documentation.