Anchor links are masked by the header

Discussions about the wiki documentation of FreeCAD and its translation.
User avatar
NormandC
Posts: 12271
Joined: Sat Feb 06, 2010 9:52 pm
Location: Québec, Canada

Anchor links are masked by the header

Postby NormandC » Sun Mar 05, 2017 8:14 am

This is something that has bugged me for a long time.

When you click on an anchor link in the page's TOC, or from an external link, the anchor is masked by the black header.

Here's an example, the PPA entry to the Glossary that I just created:

https://www.freecadweb.org/wiki/Glossary#PPA

Here's what it looks like:

FC_wiki_anchor_masked_by_header_01.png
FC_wiki_anchor_masked_by_header_01.png (34.16 KiB) Viewed 147 times

The anchor and the first line are masked.

Tested in Firefox 51.0.1 and Chromium 56.0.

It would really be great if you guys could fix this.

Thanks!
User avatar
yorik
Site Admin
Posts: 8672
Joined: Tue Feb 17, 2009 9:16 pm
Location: São Paulo, Brazil
Contact:

Re: Anchor links are masked by the header

Postby yorik » Sun Mar 05, 2017 6:16 pm

I found a couple of possible solutions here: https://github.com/twbs/bootstrap/issues/1768
I just added the javascript solution proposed there, but it doesn't seem to have much effect... Will look for something else
User avatar
NormandC
Posts: 12271
Joined: Sat Feb 06, 2010 9:52 pm
Location: Québec, Canada

Re: Anchor links are masked by the header

Postby NormandC » Sun Mar 05, 2017 7:29 pm

Thanks for looking into this Yorik! :)
User avatar
NormandC
Posts: 12271
Joined: Sat Feb 06, 2010 9:52 pm
Location: Québec, Canada

Re: Anchor links are masked by the header

Postby NormandC » Sun Mar 05, 2017 8:05 pm

I just realized the forum has the same issue.

See the following link to a forum reply: https://forum.freecadweb.org/viewtopic.php?f=4&t=17501&start=130#p163358
User avatar
yorik
Site Admin
Posts: 8672
Joined: Tue Feb 17, 2009 9:16 pm
Location: São Paulo, Brazil
Contact:

Re: Anchor links are masked by the header

Postby yorik » Sun Mar 05, 2017 11:34 pm

Yes on the forum I kind of hacked it by giving an extra space on top of the #unread anchor. So when you click a "go to first unread post" link you'll notice that it has an extra spacing on top, which stays behind the top bar.

If we find a solution for the wiki, probably we can apply it here as well.
User avatar
kkremitzki
Posts: 360
Joined: Thu Mar 03, 2016 9:52 pm
Location: Texas

Re: Anchor links are masked by the header

Postby kkremitzki » Mon Mar 06, 2017 8:11 am

I spent some time trying to get this working and wasn't able to. The header/footer are implemented via a skin and I know that the Mediawiki 1.26->1.28 upgrade has some breaking changes with our skin, so I'm hesitant to keep looking at it until I get that upgrade tested and done. I doubt the upgrade itself will fix it but it is also a good time to experiment with moving the header/footer out of a skin and into a dedicated extension that supports it, such as https://github.com/enterprisemediawiki/HeaderFooter.

I was aware of this bug previously since it's basically the same thing occurring here: https://forum.freecadweb.org/viewtopic.php?f=34&t=20978. File it under "position: fixed;" CSS issues. So I'd definitely like to get it resolved for both before too long.