Loading image produces grey rectangle

Post here for help on using FreeCAD's graphical user interface (GUI).
User avatar
Posts: 12294
Joined: Sat Feb 06, 2010 9:52 pm
Location: Québec, Canada

Re: Loading image produces grey rectangle

Postby NormandC » Sat Mar 18, 2017 7:14 pm

Just a thought: can you give the AppImage a try and see if you have the same problem?


An AppImage is a self-contained build which uses some of the host system base libraries but packages the most specific ones (OCC for example). You only need to make it executable then double-click it to launch it. It should be distro-agnostic.

EDIT: on second thought this might very well be due to your rather old AMD Radeon HD 4000 series card... From what I've seen from posts here, AMD GFX cards seem to sometimes have incomplete support of OpenGL instructions sets...
Posts: 14
Joined: Sun Mar 05, 2017 6:11 pm

Re: Loading image produces grey rectangle

Postby DoubleHP » Sun Mar 19, 2017 2:46 am

OpenGL is so much older than my cards, how could my chipset not support all of it ? I really rather think it's an Xorg issue; acceleration works only on one monitor, while it should work on two (out of 6: 3 cards with 2 monitors each, Xinerama accepts acceleration only on first card).

I have sys-libs/glibc, but got this error:

Code: Select all

$ /tmp/FreeCAD-0.16.6707.glibc2.17-x86_64.AppImage
/tmp/.mount_je5NBY/usr/bin/freecad: /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.4/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by ././/lib/freecad/lib/libFreeCADGui.so)
/tmp/.mount_je5NBY/usr/bin/freecad: /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.4/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by ././/lib/freecad/lib/libFreeCADApp.so)
/tmp/.mount_je5NBY/usr/bin/freecad: /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.4/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by ././/lib/freecad/lib/libFreeCADBase.so)
/tmp/.mount_je5NBY/usr/bin/freecad: /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.4/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by ./lib/x86_64-linux-gnu/libCoin.so.80)
/tmp/.mount_je5NBY/usr/bin/freecad: /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.4/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by ./lib/x86_64-linux-gnu/libboost_regex.so.1.55.0)
/tmp/.mount_je5NBY/usr/bin/freecad: /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.4/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by ./lib/x86_64-linux-gnu/libboost_signals.so.1.55.0)
/tmp/.mount_je5NBY/usr/bin/freecad: /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.4/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by ./lib/x86_64-linux-gnu/libshiboken-python2.7.so.1.2)
/tmp/.mount_je5NBY/usr/bin/freecad: /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.4/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by ./lib/libzipios.so.0)

Error occurs after the two pop-ups about integration.

Could it work better if I debootstrap and chroot in debian ? I would use the recent debian glibc, with my Gentoo Xorg ...


Man ... this is so amazing:
- NIX FreeCAD on Gentoo workstation can produce window decoration and app menu on all monitors, but on ly monitor #0 will produce image for the 3D part (main working zone)
- as just said ... AppImage fails on my local Gentoo workstation
- I also failed to install deboostrap on workstation
- if I push AppImage and home.fcstd on a Debian server, and run it via ssh -CXY, then, I can see the picture ... on all my 6 monitors.
- if I ssh my workstation, still get the same launching error for AppImage
- ssh workstation, and run NIX FreeCAD, it behaves the same way as without ssh

can get the wheels spin on all 6 monitors, but, even with
it will work only on one screen. So, it's definitly a rendering issue. Something broken between FreeCAD acceleration engine, and my video driver.


a few hours later ... debootstraped Debian inside the Gentoo workstation (3 layers of nested deboostraps to get it working), where I run AppImage, which works as desired.

In this environement:

Code: Select all

# glxgears  -info
libGL error: failed to create dri screen
libGL error: failed to load driver: r600
GL_RENDERER   = Gallium 0.4 on llvmpipe (LLVM 3.5, 128 bits)
GL_VERSION    = 3.0 Mesa 10.3.2
GL_VENDOR     = VMware, Inc.

which means, software rendering, like over SSH, no acceleration, but, obtained via local execution (only chroots, no ssh).

It's slower on some aspects (much slower to hanle the grid, but behaves fine with grid disabled, even for my 300 element 800 constraints sketch), but will be shown on any monitor, so, will allow to work on several files at the same time).