installing 3D space navigator with spacenav 0.6

Having trouble installing or compiling FreeCAD? Get help here.
spikey
Posts: 71
Joined: Tue Jan 19, 2016 12:14 pm

installing 3D space navigator with spacenav 0.6

Postby spikey » Mon Feb 27, 2017 10:03 pm

hey guys,

been away a while but i'm back, and with abang. well for me. just purchased a (2e hand) connexion 3D space navigator.
started the install following the following page:

https://www.freecadweb.org/wiki/3Dconne ... ut_devices

downloaded: (updated files vs the files mentioned on the page above)
spacenavd-0.6.tar.gz
libspnav-0.2.3.tar.gz
spnavcfg-0.3.tar.gz

made a folder spacenav in my home director and unpacked the folders above.

and did the following cammands:

# ./configure: went oke
# make: went oke
# sudo make install.

install -d /usr/local/bin
install -m 755 spacenavd /usr/local/bin/spacenavd
install -m 755 ./spnavd_ctl /usr/local/bin/spnavd_ctl
cd . && ./setup_init --no-install

--- Spacenavd installation complete ---
To have spacenavd start automatically at bootup, you must add an appropriate
init script. Refer to your system's manual for details on how to do that.
An example init script is available in the spacenavd source directory.
If you wish to attempt and install an init script automatically, run ./setup_init

# sudo ./setup_init
cat: /etc/inittab: No such file or directory
default runlevel detection failed.
selected runlevel: 2

setting up sysv init script

# /etc/init.d/spacenavd start
Starting spacenavd daemon

# sudo tail -n100 -f /var/log/spnavd.log
tail: cannot open '/var/log/spnavd.log' for reading: No such file or directory
tail: no files remaining


# sudo apt-get install libgtkmm-2.4-dev: went oke

# sudo tail -n100 -f /var/log/spnavd.log: same responce as before

so kinda stuck here as i don't get a responce in the manor.
*Device detection, parsing /proc/bus/input/devices
*trying alternative detection, querying /dev/input/eventX device names...
*trying "/dev/input/event1" ... Power Button
*trying "/dev/input/event2" ... 3Dconnexion SpaceNavigator
*using device: /dev/input/event2
*device name: 3Dconnexion SpaceNavigator

does anyone have an idea on how to continue to setup this tool properly?

OS: Ubuntu 16.10
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.10035 (Git)
Build type: None
Branch: master
Hash: 0598af8a081f762039fa43efaf90ece4ca0b5e6f
Python version: 2.7.12+
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17

any help would be highly appreciated.

Kind regards

Matthieu
spikey
Posts: 71
Joined: Tue Jan 19, 2016 12:14 pm

Re: installing 3D space navigator with spacenav 0.6

Postby spikey » Tue Feb 28, 2017 12:21 am

oke, an update here.

problem seems to be solved at least for the mayor part.

installed spacenavd 6.1 and freecad daily from synaptic, restarted spacenavd and restarted freecad (after the first attempt)

and there it suddenly worked.

just can't assign the buttons.. left pane is empty and the right pane is all greyed out, tried to select anything but none responded.

this leaves both buttons function less,

any help on this would again be highly appreciated.