fillet keeps failing

Post here for help on using FreeCAD's graphical user interface (GUI).
flairlab
Posts: 1
Joined: Wed Sep 16, 2015 11:52 pm

fillet keeps failing

Postby flairlab » Wed Sep 16, 2015 11:58 pm

Hi all, I'm relatively new to FreeCAD.

I have a fusion of several relatively basic shapes that I wish to appy a fillet to. When I select the fusion, then fillet, and try for a radius of 1 on the top face edges by selecting the face, the fusion disappears and the fillet says "BRep_API: command not done". I've included some screenshots. Any tips on how I should fillet this combined shape? I've also tried filleting the pads first, but then doing a fusion of them is giving me buggy shapes with faces missing.

Image
Image

My version info:

OS: Mac OS X
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.4945 (Git)
Build type: Release
Branch: master
Hash: 6cd9220079a1efb1a2f33842fa614521a31bf0d5
Python version: 2.7.9
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17

Thanks for any help!
jmaustpc
Posts: 8101
Joined: Tue Jul 26, 2011 6:28 am
Location: Australia

Re: fillet keeps failing

Postby jmaustpc » Thu Sep 17, 2015 7:20 am

Your first post, welcome to FreeCAD.

Without your file we can not say specifically what is wrong. However one guess could be that the solid is invalid in some way. You could try running Part Check Geometry (with extended BOP checks enabled) and you may find a problem.
ickby
Posts: 2464
Joined: Wed Oct 05, 2011 7:36 am

Re: fillet keeps failing

Postby ickby » Thu Sep 17, 2015 7:34 am

you could also check if you have set tangency constraints between all edges in your sketch. The filleting algorithm is rather sensitive to "close, but not realy tangent" conditions.
split007
Posts: 1
Joined: Fri Apr 21, 2017 8:29 am

Re: fillet keeps failing

Postby split007 » Fri Apr 21, 2017 10:50 am

Hi,

I’m new to FreeCAD and this is my first post.
I have the same issue, I made the fillets everywhere with the exception of the ones with red arrows.
The model is symmetrical, but the edges that it accepted to do in the left side it rejected on the right side.
holder.jpg
holder.jpg (175.58 KiB) Viewed 81 times


OS: Mac OS X
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.6706 (Git)
Build type: Release
Branch: tag: 0.16.6706
Hash: f86a4e411ff7848dea98d7242f43b7774bee8fa0
Python version: 2.7.11
Qt version: 4.8.7
Coin version: 3.1.3
OCC version: 6.8.0.oce-0.17
chrisb
Posts: 1883
Joined: Tue Mar 17, 2015 9:14 am

Re: fillet keeps failing

Postby chrisb » Fri Apr 21, 2017 3:01 pm

split007 wrote:I have the same issue, I made the fillets everywhere with the exception of the ones with red arrows.
The model is symmetrical, but the edges that it accepted to do in the left side it rejected on the right side.holder.jpg
Welcome here too. From the picture it looks like the sharp corners are a problem. There are 4 edges connected at a very close distance. Fillets don't work if they have to cross an existing edge (I hope it is understandable, with my english capabilities I cannot do better).

Sometimes it is possible to build fillets from one side but not from both, so it is somewhat cumbersome but not very surprising that the fillets work differently on the symmetric sides.