Search found 9 matches

Go to advanced search

by carno
Thu Nov 12, 2020 11:16 am
Forum: FEM
Topic: FreeCAD as pre-post processor for MBDyn
Replies: 253
Views: 27560

Re: FreeCAD as pre-post processor for MBDyn

Dear All, Any idea how to constraint a point (or edge) always on an edge (or surface) in FreeCAD? I know this may not be purely related to MBDyn forum, but MBD people will know this better. This is similar to contact constraint. I am trying to figure it our but no results yet. Thanks in advance. "Th...
by carno
Mon Nov 09, 2020 5:24 am
Forum: FEM
Topic: FreeCAD as pre-post processor for MBDyn
Replies: 253
Views: 27560

Re: FreeCAD as pre-post processor for MBDyn

mfasano wrote:
Sat Nov 07, 2020 3:44 pm
I have the joints for that example. I will need the force and plugin variables.
I really appreciate the work !

Another thing, may be trivial. It gives a warning when I switch to MBDyn WB.
<string>:95: DeprecationWarning: PY_SSIZE_T_CLEAN will be required for '#' formats
by carno
Sat Nov 07, 2020 4:40 am
Forum: FEM
Topic: FreeCAD as pre-post processor for MBDyn
Replies: 253
Views: 27560

Re: FreeCAD as pre-post processor for MBDyn

I think there was one person Jose who was much ahead on this. But he is not on the forum now a days. He has lots of code on this. Hopefully he starts again. If mfasano gets his code, it will be very helpful.

I want to try following tutorial.

https://www.sky-engin.jp/en/MBDynExampl ... /ex13.html
by carno
Wed Nov 04, 2020 5:14 am
Forum: FEM
Topic: FreeCAD as pre-post processor for MBDyn
Replies: 253
Views: 27560

Re: FreeCAD as pre-post processor for MBDyn

Hello, you can find the documation here: https://www.mbdyn.org/userfiles/documents/mbdyn-input-1.7.3.pdf or directly download it from https://www.mbdyn.org/?Software_Download . As shown on the documentation, the keyword " offset " exists. The InLine joint works as follow: The node N2' (moved from N...
by carno
Tue Nov 03, 2020 2:14 pm
Forum: FEM
Topic: FreeCAD as pre-post processor for MBDyn
Replies: 253
Views: 27560

Re: FreeCAD as pre-post processor for MBDyn

Okay, I will try new commit. Another feedback is, it is putting a word 'offset' in the 'In-line Joint' script. This seems to be a syntax error. Let me know if I am wrong. joint: 3, in line, 3, position, null, orientation, , 0.0, 0.0, 0.0, 2, offset, 0.0, 0.0, -3.0;
by carno
Tue Nov 03, 2020 6:42 am
Forum: FEM
Topic: FreeCAD as pre-post processor for MBDyn
Replies: 253
Views: 27560

Re: FreeCAD as pre-post processor for MBDyn

Excellent... Very good Job. I hope it matures further. I managed to complete the simulation. When I change the gravity value to 9810 mm/s2, the run diverges. I had to play with simulation settings to converge. In the end, it converged. Run converges very well on settings mentioned on tutorial with g...
by carno
Mon Nov 02, 2020 9:10 am
Forum: FEM
Topic: FreeCAD as pre-post processor for MBDyn
Replies: 253
Views: 27560

Re: FreeCAD as pre-post processor for MBDyn

Hi, I am trying to run the pendulum tutorial. Earlier WB was not running the simulations, which seems to be solved. I am facing two problems. 1. I am not able to add gravity. It is just adding blank entry. It is giving me following error. 'Traceback (most recent call last): 14:21:41 File "E:\FreeCAD...
by carno
Fri Jun 23, 2017 2:40 pm
Forum: Install / Compile
Topic: Windows-10 installation problem
Replies: 3
Views: 1094

Re: Windows-10 installation problem

Sorry for the late. I was away. T tried both the options. Nothing worked. Then I uninstalled the FreeCAD and trying to install it. Funny part is, it is not even allowing me to install now. Whenever I try to install, it starts the installer and when I click next it simply vanishes. I tried installing...
by carno
Sun Jun 18, 2017 4:47 am
Forum: Install / Compile
Topic: Windows-10 installation problem
Replies: 3
Views: 1094

Windows-10 installation problem

Hi, I have installed the freeCAD using "FreeCAD-0.16.6706.f86a4e4-WIN-x64_Installer-1" and installation went perfectly fine. But mu GUI is not opening at all. I tried many things mentioned on the forum, as this problem is faced by many users. Before that, I would like to mention that, It was working...

Go to advanced search