Search found 29 matches

Go to advanced search

by justacec
Thu Jul 30, 2020 7:19 pm
Forum: Help on using FreeCAD
Topic: [Known BUG with Workaround] PartDesign Pad Failed to Work With Loft
Replies: 8
Views: 210

Re: [Known BUG with Workaround] PartDesign Pad Failed to Work With Loft

All is working well now.

"I've seen it work with 1um, but I typically go with .01mm or .001mm"

1um = 0.001mm

;)
by justacec
Thu Jul 30, 2020 2:58 pm
Forum: Help on using FreeCAD
Topic: [Known BUG with Workaround] PartDesign Pad Failed to Work With Loft
Replies: 8
Views: 210

Re: [BUG] PartDesign Pad Failed to Work With Loft

Ok. Cool. I will update the subject to be "[Known BUG with Workaround]". I assume the workaround is to give a slight offset like I have done now. I just shift the part 0.001mm away from the original dimension.
by justacec
Thu Jul 30, 2020 2:21 pm
Forum: Help on using FreeCAD
Topic: [Known BUG with Workaround] PartDesign Pad Failed to Work With Loft
Replies: 8
Views: 210

Re: PartDesign Pad Failed to Work With Loft

Ok, update. Apparently, if "Constraint14" in "Sketch019" is adjusted to ANYTHING other than 25mm (even 24.999 and 26), it works as expected. I am now starting to this this is a bug and needs to be reported.

Thoughts?
by justacec
Thu Jul 30, 2020 1:46 pm
Forum: Help on using FreeCAD
Topic: [Known BUG with Workaround] PartDesign Pad Failed to Work With Loft
Replies: 8
Views: 210

Re: PartDesign Pad Failed to Work With Loft

@drmacro Thanks for the response. While reading your response I realized that maybe I just do not understand what the Additive Loft does, and possibly the general use of the Part Designing WB. 1: "Why do you use a Part container?" I thought you needed a part container to use the Part Design WB. Is t...
by justacec
Thu Jul 30, 2020 10:54 am
Forum: Help on using FreeCAD
Topic: [Known BUG with Workaround] PartDesign Pad Failed to Work With Loft
Replies: 8
Views: 210

[Known BUG with Workaround] PartDesign Pad Failed to Work With Loft

I have a simple part that I have started to work on which needed a transition from a square profile to a round profile, so I used a Loft. All good. Then I needed to put a flat mounting plat extending from that Loft region. I made a sketch and then use the Pad to create the volume. Fail. Anytime my p...
by justacec
Mon May 25, 2020 3:11 am
Forum: Help on using FreeCAD
Topic: Sketch solver is running slow...
Replies: 3
Views: 122

Re: Sketch solver is running slow...

Thanks for the feedback. I did split the sketch into two sketchs, one defining the top of the left edge and then the other defining only the first two rows on the middle left. I then discovered the multi transform tool and did two multi-transforms. Seemed to work ok. Here is my final geometry: Scree...
by justacec
Mon May 25, 2020 12:08 am
Forum: Help on using FreeCAD
Topic: Sketch solver is running slow...
Replies: 3
Views: 122

Sketch solver is running slow...

So, I have a top plate for a project I am working on that I wanted to do a grate with. Basically just cut a series of semi-repeating holes. Sounded easy, and it is. But, every time I make a change the solver goes of into its own world and take several seconds (10-15) to come back. Might not be crazy...
by justacec
Mon May 11, 2020 4:33 pm
Forum: Pull Requests
Topic: PR #3456 - Adding chamfer angle field to PartDesign
Replies: 88
Views: 5218

Re: PR #3456 - Adding chamfer angle field to PartDesign

So I was reading this thread and got to to the post about what the angle is, and the ambiguity on its definition. At first pass I think this is actually pretty easy to make not ambiguous between inside and outside definitions. The angle is just that one that is always referenced to the corner that w...
by justacec
Mon Mar 09, 2020 12:59 am
Forum: Help on using FreeCAD
Topic: [SOLVED] Mapping to Face Not Doing What I Expect
Replies: 11
Views: 242

Re: Mapping to Face Not Doing What I Expect

Ahh. Usually, when I use a datum plane. I attach it to one of the axis planes and then calculate by hand where the offset should be. This way the datum plane is only dependent upon spreadsheet cars and the base axis plane.
by justacec
Sun Mar 08, 2020 10:02 pm
Forum: Help on using FreeCAD
Topic: [SOLVED] Mapping to Face Not Doing What I Expect
Replies: 11
Views: 242

Re: Mapping to Face Not Doing What I Expect

@chrisb: Humm. Ok, I will just do that then. I guess I do not understand the topo name issue as well as I thought. Wouldn't there be a concern that changes in previous operations could change the number of vertexes or possibly their names? If this happened, the attachment would then be invalid (not ...

Go to advanced search