Search found 90 matches

Go to advanced search

by waebbl
Fri Aug 30, 2019 12:02 pm
Forum: Developers corner
Topic: What is the deal with pivy?
Replies: 45
Views: 2136

Re: What is the deal with pivy?

Why aren't the full set up them included from upstream? Are included in the GitHub repo: https://github.com/FreeCAD/pivy/pull/46/commits/63a0d878b3e21b5f457ac85ab89973abb898ff86 Looked again into why the fake headers needs to be touched. I'm using the tarball from https://github.com/FreeCAD/pivy/re...
by waebbl
Tue Aug 27, 2019 5:48 am
Forum: Developers corner
Topic: What is the deal with pivy?
Replies: 45
Views: 2136

Re: What is the deal with pivy?

I'm using pivy from the FreeCAD/pivy site at github and only need to remove the NONE from the project line CMakeLists.txt to properly find SoQt and make it build and run. As far as I can remember "NONE" was necessary for windows without having a default cmake generator available. Not sure why it do...
by waebbl
Sun Aug 25, 2019 4:24 pm
Forum: Developers corner
Topic: What is the deal with pivy?
Replies: 45
Views: 2136

Re: What is the deal with pivy?

Just curious, what is your OS? Gentoo. I know there are overlays available with most (if not all) of what I am missing ,however I have a general distrust of these things and prefer to compile things myself that are not available in the official repositories. You can take a look at my overlay at htt...
by waebbl
Mon Jul 29, 2019 4:49 pm
Forum: Packaging
Topic: Gentoo overlay waebbl for freecad
Replies: 6
Views: 357

Re: Gentoo overlay waebbl for freecad

clytle374 wrote:
Fri Jul 05, 2019 9:41 pm
Uh wow :o Thanks for advertising my overlay @clytle374
by waebbl
Mon Jul 29, 2019 4:44 pm
Forum: Packaging
Topic: [WIP] FreeCAD Packagers and Package Status
Replies: 13
Views: 2084

Re: [WIP] FreeCAD Packagers and Package Status

There's also an ongoing effort for Gentoo Linux (see https://bugs.gentoo.org/622726) currently waiting for some dependant packages getting included into the tree, most notably pyside/shiboken, pivy and re-adding SoQt. While we wait there's a current and actively maintained version in the "waebbl" ov...
by waebbl
Mon Jul 29, 2019 6:13 am
Forum: Install / Compile
Topic: [SOLVED] multilib system: error adding symbols: file in wrong format
Replies: 9
Views: 485

Re: multilib system: error adding symbols: file in wrong format

Hi, I too had at first trouble with some libraries after upgrading to 17.1 (multilib) profile. I solved them by re-emerging the relevant packages, which I had identified by inspecting pkg-config and cmake files for wrong paths. What I find suspicious are those lines from your config output: -- -- Op...
by waebbl
Wed Dec 19, 2018 2:28 pm
Forum: Install / Compile
Topic: Freecad waebbl overlay on Gentoo compile problem
Replies: 3
Views: 330

Re: Freecad waebbl overlay on Gentoo compile problem

Hello Bajdi, can you please open an issue on the overlay at github?
https://github.com/waebbl/waebbl-gentoo/issues
Please state which versions of coin and SoQt you are using when filing the issue.
Thank you!
by waebbl
Fri Dec 07, 2018 9:11 am
Forum: Install / Compile
Topic: Installation location on gentoo linux
Replies: 23
Views: 1434

Re: Installation location on gentoo linux

Perlovka wrote:
Fri Dec 07, 2018 9:06 am
waebbl wrote:
Fri Dec 07, 2018 8:52 am
It's unlikely that gentoo devs would accept a package with only a live ebuild.
He's a gentoo developer :P
Then he knows that it's unlikely to get accepted ;)
by waebbl
Fri Dec 07, 2018 8:52 am
Forum: Install / Compile
Topic: Installation location on gentoo linux
Replies: 23
Views: 1434

Re: Installation location on gentoo linux

Idea is to readd back freecad (it was removed from main repo when qt4 support was dropped) My plan is to re-add it to the main tree. This doesn't make much sense IMHO as long as 0.18 isn't released. It's unlikely that gentoo devs would accept a package with only a live ebuild. And the release of 0....
by waebbl
Mon Nov 12, 2018 7:29 pm
Forum: Developers corner
Topic: libmed (med file / med fichier) python3 bindings on linux
Replies: 4
Views: 267

Re: libmed (med file / med fichier) python3 bindings on linux

I remember reporting a patch to salome some time ago. But as the external smesh doesn't support libmed yet, I didn't have a look into this library anymore. for version 3.3.1 I used this patch to make the library work with python3. We do not have an external smesh yet in Gentoo. I didn't have the ti...

Go to advanced search