Search found 7 matches

Go to advanced search

by mrvanes
Sun May 12, 2019 10:25 am
Forum: Help on using FreeCAD
Topic: [Solved] File dialog in Ubuntu PPA FreeCAD package for Disco
Replies: 4
Views: 231

Re: File dialog in Ubuntu PPA FreeCAD package for Disco

Added version information to the question. OS specific questions didn't cover my problem.
Actually, setting DontUseNativeDialog to false did resolve my problem!
by mrvanes
Sun May 12, 2019 9:43 am
Forum: Install / Compile
Topic: [Coordination] Ubuntu freecad-stable PPA update to 0.18
Replies: 85
Views: 5864

Re: [Coordination] Ubuntu freecad-stable PPA update to 0.18

Apologies if this has been raised before, I haven't read the whole thread, but has anybody seen this in Ubuntu 19.04 stable packages?
https://forum.freecadweb.org/viewtopic.php?f=34&t=36313

I'm using FreeCAD on KDE Plasma, so I might miss Gnome/Unity libs?
by mrvanes
Sun May 12, 2019 9:22 am
Forum: Help on using FreeCAD
Topic: [Solved] File dialog in Ubuntu PPA FreeCAD package for Disco
Replies: 4
Views: 231

[Solved] File dialog in Ubuntu PPA FreeCAD package for Disco

I'm using the FreeCAD 0.18.1 from stable PPA for Ubuntu Disco and have problems using the file selector dialog. The shortcut items are greyed out and disabled and all the navigation icons are missing. Anyone else seeing this? Should I file a bug instead of posting here? FreeCAD info: OS: Ubuntu 19.0...
by mrvanes
Sun Jan 13, 2019 8:46 am
Forum: Install / Compile
Topic: **FIXED***Latest freecad-community update broke *all* versions of FreeCAD on Ubuntu 18.04
Replies: 61
Views: 6511

Re: **FIXED***Latest freecad-community update broke *all* versions of FreeCAD on Ubuntu 18.04

I can confirm that FreeCAD 0.17 stable is now working again for Ubuntu 18.10, but not before I downgraded all pyside2 packages from 5.11.2-0ppa2~ubuntu18.10 to 5.11.0-3 The error was: Traceback (most recent call last): File "<string>", line 1, in <module> File "/usr/lib/freecad/Mod/Part/AttachmentEd...
by mrvanes
Thu Jan 03, 2019 3:10 pm
Forum: Install / Compile
Topic: **FIXED***Latest freecad-community update broke *all* versions of FreeCAD on Ubuntu 18.04
Replies: 61
Views: 6511

Re: Latest freecad-community update broke *all* versions of FreeCAD on Ubuntu 18.04

I too, can confirm that freecad PPA is now in a deplorable state. 0.17 is uninstallable in cosmic (my current ubuntu version), my expat was downgraded due to the svg import bug. Today, 0.17 would crash on load of certain file (Assertion (SoBase::classTypeId != SoType::badType()) and 0.18 has a broke...
by mrvanes
Tue Dec 18, 2018 7:58 am
Forum: Help on using FreeCAD
Topic: SVG import segfault
Replies: 35
Views: 5576

Re: SVG import segfault

I tried to go ahead and see if I could make a working system out of the experimental packages, but there seems to be some naming clash coming up. The only amd64 binaries for libcoin are libcoin80c, but FreeCAD package depends on libcoin80v5. libcoin80v5 only comes in an x32 (??) architecture though,...
by mrvanes
Mon Dec 17, 2018 6:37 pm
Forum: Help on using FreeCAD
Topic: SVG import segfault
Replies: 35
Views: 5576

Re: SVG import segfault

Ubuntu 18.10 (Cosmic) just received a wayland update that depends on a more recent version of libexpat1: dpkg: dependency problems prevent configuration of libwayland-bin: libwayland-bin depends on libexpat1 (>= 2.0.1); however: Package libexpat1:amd64 is not configured yet. So it officially became ...

Go to advanced search