Search found 5038 matches

Go to advanced search

by sgrogan
Sat Jun 15, 2019 7:08 pm
Forum: Announcements & Features
Topic: Addon Manager improvements
Replies: 33
Views: 1313

Re: Addon Manager improvements

I managed to get the Curves Wb Readme to display correctly by changing line 429 in src\Mod\AddonManager\addonmanager_workers.py from: Thanks for testing. Your fix helps many add-on WB's. I can confirm the behavior for Silk. It seems many other links are web links ie /furti/FreeCAD-ArchTextures/blob...
by sgrogan
Sat Jun 15, 2019 4:07 pm
Forum: Announcements & Features
Topic: Arch Texture Workbench
Replies: 58
Views: 5381

Re: Arch Texture Workbench

furti wrote:
Thu Jun 13, 2019 7:09 pm
But maybe someone knows what simage library FreeCAD uses?
For Win and the Conda based builds I believe its 1.7
by sgrogan
Fri Jun 14, 2019 8:09 pm
Forum: Install / Compile
Topic: Windows testers needed
Replies: 0
Views: 53

Windows testers needed

Can any of you great windows testers that are compiling yourselves see here: https://forum.freecadweb.org/viewtopic. ... 10#p314112
TIA
by sgrogan
Fri Jun 14, 2019 7:55 pm
Forum: Announcements & Features
Topic: Addon Manager improvements
Replies: 33
Views: 1313

Re: Addon Manager improvements

yorik wrote:
Thu Jun 13, 2019 10:42 pm
You're on windows, right? Anyone else on windows could test?
Yes Windows. Maybe this is similar to some off the missing icons/images when the start page was updated?
I'll make a post in install compile to ask for testers. I'll also upload my build to the github pre-releases page.
by sgrogan
Thu Jun 13, 2019 10:48 pm
Forum: Install / Compile
Topic: Build failure (cmake) (git master)
Replies: 9
Views: 271

Re: Build failure (cmake) (git master)

With openSUSE I installed and uninstalled pyside2 with yast2.. do not know what pip is. FreeCAD needs pyside2, so if you uninstall pyside2 and FreeCAD works, this suggests that you have 2 pyside2's installed and FreeCAD was finding the "Wrong" one until it was deleted. I don't know how this is poss...
by sgrogan
Thu Jun 13, 2019 10:33 pm
Forum: Help on using FreeCAD
Topic: FreeCAD crash when import IFC file
Replies: 13
Views: 279

Re: FreeCAD crash when import IFC file

On windows, IfcOpenShell is built by sgrogan's grace and bundled with the freecad package. Thanks to the ifcopenshell bot and bernd's hint we use this https://forum.freecadweb.org/viewtopic.php?f=39&t=36072&start=10#p306427 Which at the moment gives this https://github.com/IfcOpenBot/IfcOpenShell/c...
by sgrogan
Thu Jun 13, 2019 8:46 pm
Forum: Announcements & Features
Topic: Addon Manager improvements
Replies: 33
Views: 1313

Re: Addon Manager improvements

You can check in C:/Users/Chris/AppData/Roaming/FreeCAD/AddonManager/Images, that's where the images get downloaded. They are downloaded only once, after that all other times they will be found and reused automatically. But I noticed some images in some readme's fail to download indeed... I get thi...
by sgrogan
Wed Jun 12, 2019 11:21 pm
Forum: Install / Compile
Topic: QtXmlPatterns Available in Travis Win Build?
Replies: 15
Views: 361

Re: QtXmlPatterns Available in Travis Win Build?

Do we need to add the xml stuff by the cmake config?? See this part of the log linked here: (PPA daily build, not Win specific): https://launchpadlibrarian.net/427963542/buildlog_ubuntu-disco-amd64.freecad-daily_0.19~pre1~201906121754~ubuntu19.04.1_BUILDING.txt.gz By not providing "FindQt5XmlPatter...
by sgrogan
Wed Jun 12, 2019 10:37 pm
Forum: Announcements & Features
Topic: Addon Manager improvements
Replies: 33
Views: 1313

Re: Addon Manager improvements

Have a look and tell me what you think! Well the GUI is beautiful. Installing BIM seems to work except I don't get the screenshot at the top of the readme. For many WB's I get an error like this Traceback (most recent call last): File "C:\Users\Chris\GitHub\FreeCAD-build2\Mod\AddonManager\addonmana...
by sgrogan
Wed Jun 12, 2019 8:55 pm
Forum: Install / Compile
Topic: Build failure (cmake) (git master)
Replies: 9
Views: 271

Re: Build failure (cmake) (git master)

I wonder whether it works to use Python3.6 instead. Maybe @looo knows? I believe his conda builds are PY3.7 now. I've seen errors around the forum with PY3.7 that don't seem to exist with PY3.6. EDIT: Also maybe a problem with pip installed pyside2? pip uninstall seems to fix it so there must be a ...

Go to advanced search