Search found 53 matches

Go to advanced search

by tom
Sun Jan 06, 2019 11:46 pm
Forum: Part Design module development
Topic: Why are people posting Sketcher topics here?!?
Replies: 2
Views: 330

Re: Why are people posting Sketcher topics here?!?

Perhaps, because users and even developers are still confused with the workbench concept. In this case the users selected the Part Design workbench and they found a tool named Sketcher (which is essentially required to work in PD). When clicking on that tool a user doesn't expect to be beamed into a...
by tom
Tue Dec 04, 2018 1:20 am
Forum: Developers corner
Topic: Travis-CI, mac, clang and permanent failure.
Replies: 26
Views: 961

Re: Travis-CI, mac, clang and permanent failure.

Edit: I used time stamp - if that fails I'll got for dots or a time stamp once in a while https://travis-ci.org/FreeCAD/FreeCAD/jobs/463054982 The problem with the timestamp is that it also creates over 1 million lines of log. Thus, there will be no improvement compared to the original log. The tri...
by tom
Mon Dec 03, 2018 9:49 pm
Forum: Developers corner
Topic: Travis-CI, mac, clang and permanent failure.
Replies: 26
Views: 961

Re: Travis-CI, mac, clang and permanent failure.

Perhaps that will help: Instead of CMD >> build_output.txt try this CMD | tee -a build_output.txt | sed "s/^.*//" | tr '\n' '.' Basically, this will print a dot to stdout for each line of the build_output.txt. So, instead of getting over 1 million log lines we will see only 1 million dots on one lin...
by tom
Mon Dec 03, 2018 9:29 pm
Forum: Developers corner
Topic: Travis-CI, mac, clang and permanent failure.
Replies: 26
Views: 961

Re: Travis-CI, mac, clang and permanent failure.

IMHO now it is not an OSX specific problem, but it is Travis related. Travis does not see any output since you are redirecting all stdout into a log file. After 15 minutes of silence Travis assumes that the build process is stuck in an endless loop and thus it kills the build. I have no idea how to ...
by tom
Wed Nov 21, 2018 6:24 pm
Forum: Help on using FreeCAD
Topic: Pad to a face with simple vs complex sketch
Replies: 13
Views: 352

Re: Pad to a face with simple vs complex sketch

On OSX I can confirm the problem. Probably it is related to the older OCC version. Tom OS: macOS High Sierra (10.13) Word size of OS: 64-bit Word size of FreeCAD: 64-bit Version: 0.18.15246 (Git) Build type: Release Branch: master Hash: 0f2830609cb9d31df6f870b3653593828d00ced4 Python version: 2.7.15...
by tom
Sun Sep 23, 2018 1:09 am
Forum: Help on using FreeCAD
Topic: Can't save a picture on Mac OS
Replies: 34
Views: 2049

Re: Can't save a picture on Mac OS

Yes, I did. None of the proposed parameters or environment variables solved the problem.
by tom
Sat Sep 22, 2018 10:34 pm
Forum: Help on using FreeCAD
Topic: Can't save a picture on Mac OS
Replies: 34
Views: 2049

Re: Can't save a picture on Mac OS

I don't know, if my observation is related to the Win10 problem since I'm on OS X. But I also don't get any picture saved. Instead I get an error message on the console, where I started FreeCAD from: <unknown exception traceback><type 'exceptions.RuntimeError'>: Cannot save null image. OS: OS X El C...
by tom
Fri Jul 27, 2018 2:39 pm
Forum: Install / Compile
Topic: FreeCAD for MacOS now more than 100 commits behind
Replies: 41
Views: 2122

Re: FreeCAD for MacOS now more than 100 commits behind

Log: Cannot mix incompatible Qt library (version 0x50b00) with this library (version 0x50b01) Does this mean that it loads two Qt versions at runtime or does it only mean that a library links against Qt 5.11.1 when 5.11.0 is expected (or the other way round)? I guess that latter one. IMHO following...
by tom
Thu Jul 26, 2018 5:55 pm
Forum: Install / Compile
Topic: FreeCAD for MacOS now more than 100 commits behind
Replies: 41
Views: 2122

Re: FreeCAD for MacOS now more than 100 commits behind

But there is also an error message complaining about incompatible QT versions: Log: Cannot mix incompatible Qt library (version 0x50b00) with this library (version 0x50b01) I think this is caused by a wrong line in .travis.yml QT5_CMAKE_PREFIX=$(ls -d $(brew --cellar)/qt/*/lib/cmake) This works only...

Go to advanced search