Search found 571 matches

Go to advanced search

by dubstar-04
Tue Nov 17, 2020 7:49 pm
Forum: Path/CAM
Topic: LibLathe - Lathe Path Generation
Replies: 117
Views: 10062

Re: LibLathe - Lathe Path Generation

Gosh, no, nothing! All the other folders have lots of files and *.py files, etc, but I guess I didn't look in the LibLathe folder. What should go there? Thanks, Dan LibLathe is a submodule to the add-on. If you follow the install instructions on github it should populate the subfolder. https://gith...
by dubstar-04
Tue Nov 17, 2020 7:38 pm
Forum: Path/CAM
Topic: LibLathe - Lathe Path Generation
Replies: 117
Views: 10062

Re: LibLathe - Lathe Path Generation

grayarea56 wrote:
Tue Nov 17, 2020 7:34 pm

Does anyone know what I'm doing wrong?
Hi Dan,

Is there anything inside the liblathe folder?

Thanks,

Dan
by dubstar-04
Fri Nov 13, 2020 7:27 pm
Forum: Path/CAM
Topic: LibLathe - Lathe Path Generation
Replies: 117
Views: 10062

Re: LibLathe - Lathe Path Generation

blue0cean wrote:
Fri Nov 13, 2020 6:17 pm
Sorry, just removed it.
Really appreciated, thank you.
by dubstar-04
Fri Nov 13, 2020 5:37 pm
Forum: Path/CAM
Topic: LibLathe - Lathe Path Generation
Replies: 117
Views: 10062

Re: LibLathe - Lathe Path Generation

blue0cean wrote:
Fri Nov 13, 2020 10:43 am
Hello WsK8,
i tried it too. My Linuxcnc post processor is still outputting Y coordinates. In the attachment my files.

b0
Please don't share copies of LibLathe on the forum. It will lead to confusion.

Use a pastebin if you want to share copies.

Thanks,

Dan
by dubstar-04
Fri Nov 13, 2020 8:28 am
Forum: Path/CAM
Topic: LibLathe - Lathe Path Generation
Replies: 117
Views: 10062

Re: LibLathe - Lathe Path Generation

ok I tried to find and adapt all Y program lines. Unfortunately the Linuxcnc processor still produces Y 0,000 lines. Do those lines 260-267 think I'm just for the lead out? I don't want to be pushed, there are more important things than this adaptation. I will support you with further tests. I have...
by dubstar-04
Fri Nov 13, 2020 8:11 am
Forum: Path/CAM
Topic: LibLathe - Lathe Path Generation
Replies: 117
Views: 10062

Re: LibLathe - Lathe Path Generation

Thanks for testing the turning add-on and thank you for your feedback. I tried a simulation on Linuxcnc today and I noticed that when generating G code in my version a Y-axis is generated in the output. Can I set something else here in the processor? There currently is no post process that is inten...
by dubstar-04
Thu Nov 12, 2020 8:28 pm
Forum: Path/CAM
Topic: LibLathe - Lathe Path Generation
Replies: 117
Views: 10062

Re: LibLathe - Lathe Path Generation

Thanks for testing the turning add-on and thank you for your feedback. I tried a simulation on Linuxcnc today and I noticed that when generating G code in my version a Y-axis is generated in the output. Can I set something else here in the processor? There currently is no post process that is intend...
by dubstar-04
Tue Nov 10, 2020 8:04 am
Forum: Path/CAM
Topic: Discussion for detanglement of rotatioal code from existing ops
Replies: 25
Views: 1018

Re: Discussion for detanglement of rotatioal code from existing ops

Hi Russ, Thank you for all the effort you put in to FreeCAD, your attitude and drive is a benefit to us all and while the current 4th axis implementation might not be as good at the next one it is certainly better than what we had before. I have barely looked at how 4th axis works but from a high le...
by dubstar-04
Mon Nov 09, 2020 7:06 pm
Forum: Path/CAM
Topic: LibLathe - Lathe Path Generation
Replies: 117
Views: 10062

Re: LibLathe - Lathe Path Generation

I pulled LL just a few hours ago. There appears to be an issue with the model you attached. The start depth is below the finish depth and the max radius is set to zero. This could possibly happen when an operation in the job has become invalid e.g. the tool controller has been deleted. If it happen...
by dubstar-04
Mon Nov 09, 2020 12:25 pm
Forum: Path/CAM
Topic: LibLathe - Lathe Path Generation
Replies: 117
Views: 10062

Re: LibLathe - Lathe Path Generation

Wsk8 wrote:
Mon Nov 09, 2020 12:15 pm
I pulled LL just a few hours ago.
Maybe try less passes?

Does anything get printed to the report view?

Thanks,

Dan

Go to advanced search



cron