Search found 2655 matches

Go to advanced search

by looo
Mon Aug 12, 2019 9:28 am
Forum: Developers corner
Topic: Py2ectomy
Replies: 8
Views: 354

Re: Py2ectomy

:x At least from the Debian side, it should be easier now since the newest Pivy is packaged. At best it will be a change of dependencies in the SoQt and Pivy packages' debian/control files and a change of build flags in debian/rules, plus rebuilding them, and it may even be a matter of simply rebuil...
by looo
Sun Aug 11, 2019 7:30 pm
Forum: Developers corner
Topic: Py2ectomy
Replies: 8
Views: 354

Re: Py2ectomy

I wouldn't mind trying to get that working for the Debian family stuff, but I am curious what some of the other packagers and developers might think. Qt4 is only partially supported in conda-forge (no webkit, older deps) so some work would be necessary to create a qt4/py3 package. (Locally I have o...
by looo
Sun Aug 11, 2019 10:07 am
Forum: Packaging
Topic: [DONE] conda: update to qt5.12
Replies: 8
Views: 361

Re: [WIP] conda: update to qt5.12

Problem still not solved. I wonder why ci's are passing?
by looo
Sun Aug 11, 2019 6:46 am
Forum: Developers corner
Topic: FreeCAD.getResourceDir()
Replies: 13
Views: 383

Re: FreeCAD.getResourceDir()

For new-style workbenches you can use this: https://github.com/looooo/freecad.gears/blob/master/freecad/gears/init_gui.py#L36 But this is not possible in your case because you are using the old way to initialize your workbench. A workaround is adding an empty python module, importing this file and c...
by looo
Sat Aug 10, 2019 9:39 am
Forum: Packaging
Topic: [DONE] conda: update to qt5.12
Replies: 8
Views: 361

Re: [WIP] conda: update to qt5.12

Things went smooth until:

Code: Select all

1 invalid syntax ($PREFIX/Mod/Draft/importSVG.py, line 746)
https://github.com/FreeCAD/FreeCAD/blob ... VG.py#L746

:x :D
by looo
Sat Aug 10, 2019 7:09 am
Forum: Packaging
Topic: FreeCAD and Raspberry Pi 4
Replies: 12
Views: 703

Re: FreeCAD and Raspberry Pi 4

It seems like conda-forge is trying to package qt for aarch64. So once this is done we could also try to build freecad (and dependencies) for aarch64. But a lot of work is necessary to get it done. Could be a nice gsoc project for next year.
by looo
Thu Aug 08, 2019 8:28 pm
Forum: Install / Compile
Topic: The download for Mac users fails to work
Replies: 14
Views: 411

Re: The download for Mac users fails to work

seems like every mac is a little bit different :D

Code: Select all

0 _multiarray_umath.cpython-37m-darwin.so 0x000000011a9d5ce9 npy_cpu_supports + 121
numpy related stuff??
by looo
Thu Aug 08, 2019 3:20 pm
Forum: Packaging
Topic: [WIP] The little FreeCAD list of optional dependencies
Replies: 4
Views: 402

Re: [WIP] The little FreeCAD list of optional dependencies

BTW.: Pyflow is not the pyflow nodeeditor.
by looo
Thu Aug 08, 2019 7:07 am
Forum: Packaging
Topic: [DONE] conda: update to qt5.12
Replies: 8
Views: 361

[DONE] conda: update to qt5.12

conda-forge is preparing for qt5.12. So again this means some work has to be done to get freecad updated: https://github.com/conda-forge/qt-feedstock/pull/110 - [x] qt 5.12 https://anaconda.org/conda-forge/qt/files?version=5.12.1 - [x] simage (optional dep of pivy) https://github.com/conda-forge/sim...
by looo
Wed Aug 07, 2019 10:16 pm
Forum: Install / Compile
Topic: OpenCamLib is not working! Fixed for python 2.7
Replies: 39
Views: 1143

Re: OpenCamLib is not working!

I tried to build opencamlib several times but failed because of different reasons (python3-supports, cmake difficulties). I guess it's best to do this in an interactive way, trying to figure out what the difficulties of the cmake are. Therefor I created a PR for ocl-conda-package. Would be nice if ...

Go to advanced search