Search found 217 matches

by davecoventry
Thu Oct 15, 2020 6:48 am
Forum: Python scripting and macros
Topic: [solved]Addon manager falls over: TypeError: can only concatenate str (not "list") to str
Replies: 2
Views: 146

[solved]Addon manager falls over: TypeError: can only concatenate str (not "list") to str

I presume this is another example of the numerous errors and inconsistencies derived from python arbitrarily dicking with specifications and documented behaviour between version iterations. I have to say that this is really tiresome. The Addon manager remains greyed out and is of no practical use. F...
by davecoventry
Sun Jun 21, 2020 12:11 pm
Forum: Install / Compile
Topic: [Solved]Freecad looking for Qt_5.15 but Qt_5.12 is installed
Replies: 19
Views: 2172

Re: [Solved]Freecad looking for Qt_5.15 but Qt_5.12 is installed

Marked as solved.

Thank you, guys. You are a credit to the OS community.
by davecoventry
Sat Jun 20, 2020 4:00 pm
Forum: Install / Compile
Topic: [Solved]Freecad looking for Qt_5.15 but Qt_5.12 is installed
Replies: 19
Views: 2172

Re: Freecad looking for Qt_5.15 but Qt_5.12 is installed

Ok, got it. I've removed the ~/.local/lib/python3.8 directory and it now seems to start ok. I still seem to have python3.8, though, so it must be install in multiple locations. I have to say that the different iterations and siblings of python is a complete clusterf*. I'll put it through a number of...
by davecoventry
Sat Jun 20, 2020 3:54 pm
Forum: Install / Compile
Topic: [Solved]Freecad looking for Qt_5.15 but Qt_5.12 is installed
Replies: 19
Views: 2172

Re: Freecad looking for Qt_5.15 but Qt_5.12 is installed

Well, that's fubared. I uninstalled FreeCAD and downloaded and compiled v0.19-pre. Fired up FreeCAD-0.19 and have the same error. /lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.15' not found (required by /home/dave/.local/lib/python3.8/site-packages/PyQt5/QtCore.abi3.so) I deleted (or, rather,...
by davecoventry
Sat Jun 20, 2020 2:31 pm
Forum: Install / Compile
Topic: Cmake Errors on v0.19 and 0.18
Replies: 4
Views: 280

Re: Cmake Errors on v0.19 and 0.18

Yes, I saw that as I googled it.

Am currently compiling v0.19, which seems to be going ok.

Many thanks!
by davecoventry
Sat Jun 20, 2020 1:34 pm
Forum: Install / Compile
Topic: Cmake Errors on v0.19 and 0.18
Replies: 4
Views: 280

Re: Cmake Errors on v0.19 and 0.18

Thanks. The wiki needs to be updated. https://wiki.freecadweb.org/Compile_on_Linux cmake ../freecad-source -DBUILD_QT5=ON -DPYTHON_EXECUTABLE=/usr/bin/python3 "make" has now stopped on 7%, though. [ 7%] Building CXX object src/Base/CMakeFiles/FreeCADBase.dir/swigpyrun.cpp.o In file included from /op...
by davecoventry
Sat Jun 20, 2020 8:05 am
Forum: Install / Compile
Topic: Cmake Errors on v0.19 and 0.18
Replies: 4
Views: 280

Cmake Errors on v0.19 and 0.18

I'm trying to get an installation of FreeCAD working on a fresh install of Ubuntu 20.04, but neither the pre0.19 version nor the 0.18 version (downloaded from github) are compiling. Running "cmake ../src -DBUILD_QT5=ON -DPYTHON_EXECUTABLE=/usr/bin/python3" from within the 0.18 directory fails with t...
by davecoventry
Fri Jun 19, 2020 3:46 pm
Forum: Install / Compile
Topic: [Solved]Freecad looking for Qt_5.15 but Qt_5.12 is installed
Replies: 19
Views: 2172

Re: Freecad looking for Qt_5.15 but Qt_5.12 is installed

Ok, thanks, that seems likely.

I might try to compile from sources.
by davecoventry
Fri Jun 19, 2020 1:57 pm
Forum: Install / Compile
Topic: [Solved]Freecad looking for Qt_5.15 but Qt_5.12 is installed
Replies: 19
Views: 2172

Re: Freecad looking for Qt_5.15 but Qt_5.12 is installed

In addition i did a few quick tests (installed PyQt5 with PIP), and my self compiled FreeCAD, FreeCAD daily from PPA (Ubuntu 16.04) and the daily AppImage work just fine. Therefore i guess we need to better understand, on why "FreeCAD Ext modules support" has issues with such packages on some syste...