[Résolu]PPA cassé

Forum destiné aux questions et discussions en français
Forum rules
Règles du forum et informations utiles.

VEUILLEZ LIRE CECI AVANT DE DEMANDER DE L'AIDE
JeffWitz
Posts: 49
Joined: Fri Mar 27, 2015 9:14 am

[Résolu]PPA cassé

Postby JeffWitz » Fri Apr 19, 2019 7:27 am

Bonjour,

Juste pour signaler que le PPA stable ne fonctionne pas sur 16.04 et 18.04. Il y a des problèmes de dépendances sur freecad-python2 et libfreecad-python2-0.18.

Vous trouverez ici la commande d'installation et la tentative de résolution ci-dessous.

La seule méthode fonctionnelle pour restaurer ma base de données apt est de virer le ppa et supprimer freecad, tant que le ppas est activé, il n'est pas possible de réparer la base de données. C'est vraiment très, très génant.

Je bosse pour l'instant avec l'appimage, mais je n'ai pas accès à l'invironnement python en dehors du shell python de freecad, ce qui n'est pas commode pour moi ...

Si cela peut aider à régler le problème ...
jeff@Terra:~/Code$ sudo -E apt install freecad
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants seront installés :
calculix-ccx freecad-common freecad-python2 freecad-runtime libarmadillo6 libarpack2 libboost-python1.58.0 libdap17v5 libdapclient6v5 libepsilon1
libfreecad-python2-0.18 libfreexl1 libgdal1i libgeos-3.5.0 libgeos-c1v5 libhdf4-0-alt libkmlbase1 libkmldom1 libkmlengine1 libmedc1v5 libminizip1 libmysqlclient20
libnetcdf-c++4 libocct-data-exchange-7.3 libocct-foundation-7.3 libocct-modeling-algorithms-7.3 libocct-modeling-data-7.3 libocct-ocaf-7.3 libocct-visualization-7.3
libogdi3.2 libpq5 libproj9 libpyside1.2 libshiboken1.2v5 libsoqt4-20 libspatialite7 libspnav0 libspooles2.2 libsuperlu4 liburiparser1 libvtk6.2 libxerces-c3.1
libzipios++0v5 mysql-common proj-bin proj-data python-pivy python-pyside.qtcore python-pyside.qtgui python-pyside.qtsvg python-pyside.qtuitools python-pyside.qtxml
python-qt4-gl
Paquets suggérés :
povray python-collada libhdf4-doc libhdf4-alt-dev hdf4-tools libnetcdf4 libmed-doc libmed-tools ogdi-bin spacenavd vtk6-doc vtk6-examples
Les NOUVEAUX paquets suivants seront installés :
calculix-ccx freecad freecad-common freecad-python2 freecad-runtime libarmadillo6 libarpack2 libboost-python1.58.0 libdap17v5 libdapclient6v5 libepsilon1
libfreecad-python2-0.18 libfreexl1 libgdal1i libgeos-3.5.0 libgeos-c1v5 libhdf4-0-alt libkmlbase1 libkmldom1 libkmlengine1 libmedc1v5 libminizip1 libmysqlclient20
libnetcdf-c++4 libocct-data-exchange-7.3 libocct-foundation-7.3 libocct-modeling-algorithms-7.3 libocct-modeling-data-7.3 libocct-ocaf-7.3 libocct-visualization-7.3
libogdi3.2 libpq5 libproj9 libpyside1.2 libshiboken1.2v5 libsoqt4-20 libspatialite7 libspnav0 libspooles2.2 libsuperlu4 liburiparser1 libvtk6.2 libxerces-c3.1
libzipios++0v5 mysql-common proj-bin proj-data python-pivy python-pyside.qtcore python-pyside.qtgui python-pyside.qtsvg python-pyside.qtuitools python-pyside.qtxml
python-qt4-gl
0 mis à jour, 54 nouvellement installés, 0 à enlever et 8 non mis à jour.
Il est nécessaire de prendre 861 ko/103 Mo dans les archives.
Après cette opération, 465 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de :1 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 mysql-common all 5.7.25-0ubuntu0.16.04.2 [15,5 kB]
Réception de :2 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libmysqlclient20 amd64 5.7.25-0ubuntu0.16.04.2 [813 kB]
Réception de :3 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 libnetcdf-c++4 amd64 4.2-4 [33,2 kB]
861 ko réceptionnés en 0s (2 195 ko/s)
Extraction des modèles depuis les paquets : 100%
Sélection du paquet libsuperlu4:amd64 précédemment désélectionné.
(Lecture de la base de données... 538587 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libsuperlu4_4.3+dfsg-3_amd64.deb ...
Dépaquetage de libsuperlu4:amd64 (4.3+dfsg-3) ...
Sélection du paquet libarpack2 précédemment désélectionné.
Préparation du dépaquetage de .../libarpack2_3.3.0-1build2_amd64.deb ...
Dépaquetage de libarpack2 (3.3.0-1build2) ...
Sélection du paquet libspooles2.2:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libspooles2.2_2.2-12_amd64.deb ...
Dépaquetage de libspooles2.2:amd64 (2.2-12) ...
Sélection du paquet calculix-ccx précédemment désélectionné.
Préparation du dépaquetage de .../calculix-ccx_2.9-1_amd64.deb ...
Dépaquetage de calculix-ccx (2.9-1) ...
Sélection du paquet freecad-common précédemment désélectionné.
Préparation du dépaquetage de .../freecad-common_2%3a0.18.1+dfsg1~201904061907~ubuntu16.04.1_all.deb ...
Dépaquetage de freecad-common (2:0.18.1+dfsg1~201904061907~ubuntu16.04.1) ...
Sélection du paquet freecad-runtime précédemment désélectionné.
Préparation du dépaquetage de .../freecad-runtime_2%3a0.18.1+dfsg1~201904061907~ubuntu16.04.1_all.deb ...
Dépaquetage de freecad-runtime (2:0.18.1+dfsg1~201904061907~ubuntu16.04.1) ...
Sélection du paquet libsoqt4-20 précédemment désélectionné.
Préparation du dépaquetage de .../libsoqt4-20_1.6.0~e8310f-2build1_amd64.deb ...
Dépaquetage de libsoqt4-20 (1.6.0~e8310f-2build1) ...
Sélection du paquet python-qt4-gl précédemment désélectionné.
Préparation du dépaquetage de .../python-qt4-gl_4.11.4+dfsg-1build4_amd64.deb ...
Dépaquetage de python-qt4-gl (4.11.4+dfsg-1build4) ...
Sélection du paquet python-pivy précédemment désélectionné.
Préparation du dépaquetage de .../python-pivy_0.5.0~v609hg-3.1_amd64.deb ...
Dépaquetage de python-pivy (0.5.0~v609hg-3.1) ...
Sélection du paquet libshiboken1.2v5:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libshiboken1.2v5_1.2.2-2build2_amd64.deb ...
Dépaquetage de libshiboken1.2v5:amd64 (1.2.2-2build2) ...
Sélection du paquet libpyside1.2:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libpyside1.2_1.2.2-2build2_amd64.deb ...
Dépaquetage de libpyside1.2:amd64 (1.2.2-2build2) ...
Sélection du paquet python-pyside.qtcore précédemment désélectionné.
Préparation du dépaquetage de .../python-pyside.qtcore_1.2.2-2build2_amd64.deb ...
Dépaquetage de python-pyside.qtcore (1.2.2-2build2) ...
Sélection du paquet python-pyside.qtgui précédemment désélectionné.
Préparation du dépaquetage de .../python-pyside.qtgui_1.2.2-2build2_amd64.deb ...
Dépaquetage de python-pyside.qtgui (1.2.2-2build2) ...
Sélection du paquet python-pyside.qtsvg précédemment désélectionné.
Préparation du dépaquetage de .../python-pyside.qtsvg_1.2.2-2build2_amd64.deb ...
Dépaquetage de python-pyside.qtsvg (1.2.2-2build2) ...
Sélection du paquet python-pyside.qtxml précédemment désélectionné.
Préparation du dépaquetage de .../python-pyside.qtxml_1.2.2-2build2_amd64.deb ...
Dépaquetage de python-pyside.qtxml (1.2.2-2build2) ...
Sélection du paquet python-pyside.qtuitools précédemment désélectionné.
Préparation du dépaquetage de .../python-pyside.qtuitools_1.2.2-2build2_amd64.deb ...
Dépaquetage de python-pyside.qtuitools (1.2.2-2build2) ...
Sélection du paquet libboost-python1.58.0 précédemment désélectionné.
Préparation du dépaquetage de .../libboost-python1.58.0_1.58.0+dfsg-5ubuntu3.1_amd64.deb ...
Dépaquetage de libboost-python1.58.0 (1.58.0+dfsg-5ubuntu3.1) ...
Sélection du paquet libmedc1v5:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libmedc1v5_3.0.6-9build1_amd64.deb ...
Dépaquetage de libmedc1v5:amd64 (3.0.6-9build1) ...
Préparation du dépaquetage de .../libocct-foundation-7.3_7.3.0-0ppa4~ubuntu16.04.1_amd64.deb ...
Dépaquetage de libocct-foundation-7.3:amd64 (7.3.0-0ppa4~ubuntu16.04.1) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/libocct-foundation-7.3_7.3.0-0ppa4~ubuntu16.04.1_amd64.deb (--unpack) :
tentative de remplacement de « /usr/lib/x86_64-linux-gnu/libTKMath.so.7 », qui appartient aussi au paquet libopencascade-foundation-7.1.0:amd64 7.1.0-0ppa1~ubuntu16.04.1
Préparation du dépaquetage de .../libocct-modeling-data-7.3_7.3.0-0ppa4~ubuntu16.04.1_amd64.deb ...
Dépaquetage de libocct-modeling-data-7.3:amd64 (7.3.0-0ppa4~ubuntu16.04.1) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/libocct-modeling-data-7.3_7.3.0-0ppa4~ubuntu16.04.1_amd64.deb (--unpack) :
tentative de remplacement de « /usr/lib/x86_64-linux-gnu/libTKGeomBase.so.7 », qui appartient aussi au paquet libopencascade-modeling-data-7.1.0:amd64 7.1.0-0ppa1~ubuntu16.04.1
Préparation du dépaquetage de .../libocct-modeling-algorithms-7.3_7.3.0-0ppa4~ubuntu16.04.1_amd64.deb ...
Dépaquetage de libocct-modeling-algorithms-7.3:amd64 (7.3.0-0ppa4~ubuntu16.04.1) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/libocct-modeling-algorithms-7.3_7.3.0-0ppa4~ubuntu16.04.1_amd64.deb (--unpack) :
tentative de remplacement de « /usr/lib/x86_64-linux-gnu/libTKPrim.so.7 », qui appartient aussi au paquet libopencascade-modeling-algorithms-7.1.0:amd64 7.1.0-0ppa1~ubuntu16.04.1
Préparation du dépaquetage de .../libocct-visualization-7.3_7.3.0-0ppa4~ubuntu16.04.1_amd64.deb ...
Dépaquetage de libocct-visualization-7.3:amd64 (7.3.0-0ppa4~ubuntu16.04.1) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/libocct-visualization-7.3_7.3.0-0ppa4~ubuntu16.04.1_amd64.deb (--unpack) :
tentative de remplacement de « /usr/lib/x86_64-linux-gnu/libTKOpenGl.so.7 », qui appartient aussi au paquet libopencascade-visualization-7.1.0:amd64 7.1.0-0ppa1~ubuntu16.04.1
Aucun rapport « apport » écrit car MaxReports a déjà été atteint
Préparation du dépaquetage de .../libocct-ocaf-7.3_7.3.0-0ppa4~ubuntu16.04.1_amd64.deb ...
Dépaquetage de libocct-ocaf-7.3:amd64 (7.3.0-0ppa4~ubuntu16.04.1) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/libocct-ocaf-7.3_7.3.0-0ppa4~ubuntu16.04.1_amd64.deb (--unpack) :
tentative de remplacement de « /usr/lib/x86_64-linux-gnu/libTKCAF.so.7 », qui appartient aussi au paquet libopencascade-ocaf-7.1.0:amd64 7.1.0-0ppa1~ubuntu16.04.1
Aucun rapport « apport » écrit car MaxReports a déjà été atteint
Préparation du dépaquetage de .../libocct-data-exchange-7.3_7.3.0-0ppa4~ubuntu16.04.1_amd64.deb ...
Dépaquetage de libocct-data-exchange-7.3:amd64 (7.3.0-0ppa4~ubuntu16.04.1) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/libocct-data-exchange-7.3_7.3.0-0ppa4~ubuntu16.04.1_amd64.deb (--unpack) :
tentative de remplacement de « /usr/lib/x86_64-linux-gnu/libTKXmlXCAF.so.7 », qui appartient aussi au paquet libopencascade-data-exchange-7.1.0:amd64 7.1.0-0ppa1~ubuntu16.04.1
Aucun rapport « apport » écrit car MaxReports a déjà été atteint
Sélection du paquet libspnav0 précédemment désélectionné.
Préparation du dépaquetage de .../libspnav0_0.2.3-1_amd64.deb ...
Dépaquetage de libspnav0 (0.2.3-1) ...
Sélection du paquet libarmadillo6 précédemment désélectionné.
Préparation du dépaquetage de .../libarmadillo6_1%3a6.500.5+dfsg-1_amd64.deb ...
Dépaquetage de libarmadillo6 (1:6.500.5+dfsg-1) ...
Sélection du paquet libdap17v5:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libdap17v5_3.15.1-7_amd64.deb ...
Dépaquetage de libdap17v5:amd64 (3.15.1-7) ...
Sélection du paquet libdapclient6v5:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libdapclient6v5_3.15.1-7_amd64.deb ...
Dépaquetage de libdapclient6v5:amd64 (3.15.1-7) ...
Sélection du paquet libepsilon1:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libepsilon1_0.9.2-3ubuntu1_amd64.deb ...
Dépaquetage de libepsilon1:amd64 (0.9.2-3ubuntu1) ...
Sélection du paquet libfreexl1:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libfreexl1_1.0.2-1ubuntu0.1_amd64.deb ...
Dépaquetage de libfreexl1:amd64 (1.0.2-1ubuntu0.1) ...
Sélection du paquet libgeos-3.5.0 précédemment désélectionné.
Préparation du dépaquetage de .../libgeos-3.5.0_3.5.0-1ubuntu2_amd64.deb ...
Dépaquetage de libgeos-3.5.0 (3.5.0-1ubuntu2) ...
Sélection du paquet libgeos-c1v5 précédemment désélectionné.
Préparation du dépaquetage de .../libgeos-c1v5_3.5.0-1ubuntu2_amd64.deb ...
Dépaquetage de libgeos-c1v5 (3.5.0-1ubuntu2) ...
Sélection du paquet libhdf4-0-alt précédemment désélectionné.
Préparation du dépaquetage de .../libhdf4-0-alt_4.2.10-3.2_amd64.deb ...
Dépaquetage de libhdf4-0-alt (4.2.10-3.2) ...
Sélection du paquet libminizip1:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libminizip1_1.1-8_amd64.deb ...
Dépaquetage de libminizip1:amd64 (1.1-8) ...
Sélection du paquet liburiparser1:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../liburiparser1_0.8.4-1_amd64.deb ...
Dépaquetage de liburiparser1:amd64 (0.8.4-1) ...
Sélection du paquet libkmlbase1:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libkmlbase1_1.3.0-1_amd64.deb ...
Dépaquetage de libkmlbase1:amd64 (1.3.0-1) ...
Sélection du paquet libkmldom1:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libkmldom1_1.3.0-1_amd64.deb ...
Dépaquetage de libkmldom1:amd64 (1.3.0-1) ...
Sélection du paquet libkmlengine1:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libkmlengine1_1.3.0-1_amd64.deb ...
Dépaquetage de libkmlengine1:amd64 (1.3.0-1) ...
Sélection du paquet mysql-common précédemment désélectionné.
Préparation du dépaquetage de .../mysql-common_5.7.25-0ubuntu0.16.04.2_all.deb ...
Dépaquetage de mysql-common (5.7.25-0ubuntu0.16.04.2) ...
Sélection du paquet libmysqlclient20:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libmysqlclient20_5.7.25-0ubuntu0.16.04.2_amd64.deb ...
Dépaquetage de libmysqlclient20:amd64 (5.7.25-0ubuntu0.16.04.2) ...
Sélection du paquet proj-data précédemment désélectionné.
Préparation du dépaquetage de .../proj-data_4.9.2-2_all.deb ...
Dépaquetage de proj-data (4.9.2-2) ...
Sélection du paquet libproj9 précédemment désélectionné.
Préparation du dépaquetage de .../libproj9_4.9.2-2_amd64.deb ...
Dépaquetage de libproj9 (4.9.2-2) ...
Sélection du paquet libogdi3.2 précédemment désélectionné.
Préparation du dépaquetage de .../libogdi3.2_3.2.0~beta2-7.1build1_amd64.deb ...
Dépaquetage de libogdi3.2 (3.2.0~beta2-7.1build1) ...
Sélection du paquet libpq5:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libpq5_9.5.16-0ubuntu0.16.04.1_amd64.deb ...
Dépaquetage de libpq5:amd64 (9.5.16-0ubuntu0.16.04.1) ...
Sélection du paquet libspatialite7:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libspatialite7_4.3.0a-5_amd64.deb ...
Dépaquetage de libspatialite7:amd64 (4.3.0a-5) ...
Sélection du paquet libxerces-c3.1:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libxerces-c3.1_3.1.3+debian-1_amd64.deb ...
Dépaquetage de libxerces-c3.1:amd64 (3.1.3+debian-1) ...
Sélection du paquet libgdal1i précédemment désélectionné.
Préparation du dépaquetage de .../libgdal1i_1.11.3+dfsg-3build2_amd64.deb ...
Dépaquetage de libgdal1i (1.11.3+dfsg-3build2) ...
Sélection du paquet libnetcdf-c++4 précédemment désélectionné.
Préparation du dépaquetage de .../libnetcdf-c++4_4.2-4_amd64.deb ...
Dépaquetage de libnetcdf-c++4 (4.2-4) ...
Sélection du paquet libvtk6.2 précédemment désélectionné.
Préparation du dépaquetage de .../libvtk6.2_6.2.0+dfsg1-10build1_amd64.deb ...
Dépaquetage de libvtk6.2 (6.2.0+dfsg1-10build1) ...
Sélection du paquet libzipios++0v5 précédemment désélectionné.
Préparation du dépaquetage de .../libzipios++0v5_0.1.5.9+cvs.2007.04.28-5.2_amd64.deb ...
Dépaquetage de libzipios++0v5 (0.1.5.9+cvs.2007.04.28-5.2) ...
Sélection du paquet libfreecad-python2-0.18 précédemment désélectionné.
Préparation du dépaquetage de .../libfreecad-python2-0.18_2%3a0.18.1+dfsg1~201904061907~ubuntu16.04.1_amd64.deb ...
Dépaquetage de libfreecad-python2-0.18 (2:0.18.1+dfsg1~201904061907~ubuntu16.04.1) ...
Sélection du paquet freecad-python2 précédemment désélectionné.
Préparation du dépaquetage de .../freecad-python2_2%3a0.18.1+dfsg1~201904061907~ubuntu16.04.1_amd64.deb ...
Dépaquetage de freecad-python2 (2:0.18.1+dfsg1~201904061907~ubuntu16.04.1) ...
Sélection du paquet freecad précédemment désélectionné.
Préparation du dépaquetage de .../freecad_2%3a0.18.1+dfsg1~201904061907~ubuntu16.04.1_all.deb ...
Dépaquetage de freecad (2:0.18.1+dfsg1~201904061907~ubuntu16.04.1) ...
Sélection du paquet proj-bin précédemment désélectionné.
Préparation du dépaquetage de .../proj-bin_4.9.2-2_amd64.deb ...
Dépaquetage de proj-bin (4.9.2-2) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.23-0ubuntu11) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.5-1) ...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.15-0ubuntu1.1) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.22-1ubuntu5.2) ...
Traitement des actions différées (« triggers ») pour bamfdaemon (0.5.3~bzr0+16.04.20180209-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-6ubuntu3.1) ...
Traitement des actions différées (« triggers ») pour mime-support (3.59ubuntu1) ...
Traitement des actions différées (« triggers ») pour shared-mime-info (1.5-2ubuntu0.2) ...
Unknown media type in type 'chemical/x-alchemy'
Unknown media type in type 'chemical/x-cache'
Unknown media type in type 'chemical/x-cactvs-ascii'
Unknown media type in type 'chemical/x-cactvs-binary'
Unknown media type in type 'chemical/x-cactvs-table'
Unknown media type in type 'chemical/x-cdx'
Unknown media type in type 'chemical/x-cdxml'
Unknown media type in type 'chemical/x-chem3d'
Unknown media type in type 'chemical/x-cif'
Unknown media type in type 'chemical/x-cml'
Unknown media type in type 'chemical/x-daylight-smiles'
Unknown media type in type 'chemical/x-dmol'
Unknown media type in type 'chemical/x-gamess-input'
Unknown media type in type 'chemical/x-gamess-output'
Unknown media type in type 'chemical/x-gaussian-input'
Unknown media type in type 'chemical/x-gaussian-log'
Unknown media type in type 'chemical/x-genbank'
Unknown media type in type 'chemical/x-gulp'
Unknown media type in type 'chemical/x-hin'
Unknown media type in type 'chemical/x-inchi'
Unknown media type in type 'chemical/x-inchi-xml'
Unknown media type in type 'chemical/x-jcamp-dx'
Unknown media type in type 'chemical/x-macromodel-input'
Unknown media type in type 'chemical/x-mdl-molfile'
Unknown media type in type 'chemical/x-mdl-rdfile'
Unknown media type in type 'chemical/x-mdl-rxnfile'
Unknown media type in type 'chemical/x-mdl-sdfile'
Unknown media type in type 'chemical/x-mdl-tgf'
Unknown media type in type 'chemical/x-mmcif'
Unknown media type in type 'chemical/x-mol2'
Unknown media type in type 'chemical/x-mopac-graph'
Unknown media type in type 'chemical/x-mopac-input'
Unknown media type in type 'chemical/x-mopac-out'
Unknown media type in type 'chemical/x-msi-car'
Unknown media type in type 'chemical/x-msi-hessian'
Unknown media type in type 'chemical/x-msi-mdf'
Unknown media type in type 'chemical/x-msi-msi'
Unknown media type in type 'chemical/x-ncbi-asn1'
Unknown media type in type 'chemical/x-ncbi-asn1-binary'
Unknown media type in type 'chemical/x-ncbi-asn1-xml'
Unknown media type in type 'chemical/x-pdb'
Unknown media type in type 'chemical/x-shelx'
Unknown media type in type 'chemical/x-vmd'
Unknown media type in type 'chemical/x-xyz'
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/libocct-foundation-7.3_7.3.0-0ppa4~ubuntu16.04.1_amd64.deb
/var/cache/apt/archives/libocct-modeling-data-7.3_7.3.0-0ppa4~ubuntu16.04.1_amd64.deb
/var/cache/apt/archives/libocct-modeling-algorithms-7.3_7.3.0-0ppa4~ubuntu16.04.1_amd64.deb
/var/cache/apt/archives/libocct-visualization-7.3_7.3.0-0ppa4~ubuntu16.04.1_amd64.deb
/var/cache/apt/archives/libocct-ocaf-7.3_7.3.0-0ppa4~ubuntu16.04.1_amd64.deb
/var/cache/apt/archives/libocct-data-exchange-7.3_7.3.0-0ppa4~ubuntu16.04.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
et le résultat de

sudo dpkg -r libfreecad-python2-0.18 freecad-python2
dpkg: un problème de dépendance empêche la suppression de freecad-python2 :
freecad dépend de freecad-python2.

dpkg: erreur de traitement du paquet freecad-python2 (--remove) :
problème de dépendance - suppression ignorée
dpkg: un problème de dépendance empêche la suppression de libfreecad-python2-0.18 :
freecad-python2 dépend de libfreecad-python2-0.18 (<< 2:0.18.1+dfsg1~201904061907~ubuntu16.04.1+1~) ; cependant :
Le paquet libfreecad-python2-0.18 doit être supprimé.
freecad-python2 dépend de libfreecad-python2-0.18 (>= 2:0.18.1+dfsg1~201904061907~ubuntu16.04.1) ; cependant :
Le paquet libfreecad-python2-0.18 doit être supprimé.
freecad-python2 dépend de libfreecad-python2-0.18 (<< 2:0.18.1+dfsg1~201904061907~ubuntu16.04.1+1~) ; cependant :
Le paquet libfreecad-python2-0.18 doit être supprimé.
freecad-python2 dépend de libfreecad-python2-0.18 (>= 2:0.18.1+dfsg1~201904061907~ubuntu16.04.1) ; cependant :
Le paquet libfreecad-python2-0.18 doit être supprimé.

dpkg: erreur de traitement du paquet libfreecad-python2-0.18 (--remove) :
problème de dépendance - suppression ignorée
Des erreurs ont été rencontrées pendant l'exécution :
freecad-python2
libfreecad-python2-0.18
Last edited by JeffWitz on Fri May 10, 2019 6:26 am, edited 1 time in total.
openBrain
Posts: 2183
Joined: Fri Nov 09, 2018 5:38 pm

Re: PPA cassé

Postby openBrain » Fri Apr 19, 2019 7:52 am

Aucun problème ici. ;)

Code: Select all

OS: Ubuntu 18.04.2 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.1.
Build type: Release
Python version: 2.7.15rc1
Qt version: 5.9.5
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: French/France (fr_FR)
JeffWitz
Posts: 49
Joined: Fri Mar 27, 2015 9:14 am

Re: PPA cassé

Postby JeffWitz » Fri Apr 19, 2019 8:48 am

Je ne sais pas trop quoi faire pour aider à un diagnostic plus précis, mais je serais ravi de le faire, si quelqu'un me guide.
openBrain
Posts: 2183
Joined: Fri Nov 09, 2018 5:38 pm

Re: PPA cassé

Postby openBrain » Fri Apr 19, 2019 2:28 pm

Peux-tu déjà essayer de réinstaller proprement ?

Code: Select all

sudo apt-get purge freecad
sudo apt-get autoremove
sudo apt-get clean
sudo apt-get install --reinstall freecad
On y verra peut-être plus clair après. :)
User avatar
meme2704
Posts: 2926
Joined: Sat Apr 01, 2017 2:47 pm
Location: Vosges

Re: PPA cassé

Postby meme2704 » Fri Apr 19, 2019 2:39 pm

Salut
La version 18 et18.1 est notoirement pourrie plusieur post en font état (tant frenchie que anglo)
j'ai "installer" (façon de parler) plutôt décompresser V19pre, semble tenir le coup, hormis des sousis avec sketcher :
quand je veu contraindre "tangent" 2 rayons contigus ya pas de tangence et plus de sommet commun , idem si je veu modifier 2 segments qui ont 1 sommet commun, et en placer 1 vertical par ex , les 2 sont désolidarises , ils faut recommencer , recommencer , persévérer, ... et ça fini par le faire
mais qu'elle misère :!:
User avatar
NormandC
Posts: 18534
Joined: Sat Feb 06, 2010 9:52 pm
Location: Québec, Canada

Re: PPA cassé

Postby NormandC » Sat Apr 20, 2019 5:10 am

Bonjour,

La balise Code (le bouton </>) aurait été plus appropriée que la balise de citation (quote).

JeffWitz wrote:
Fri Apr 19, 2019 7:27 am
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/libocct-foundation-7.3_7.3.0-0ppa4~ubuntu16.04.1_amd64.deb (--unpack) :
tentative de remplacement de « /usr/lib/x86_64-linux-gnu/libTKMath.so.7 », qui appartient aussi au paquet libopencascade-foundation-7.1.0:amd64 7.1.0-0ppa1~ubuntu16.04.1
Combien de temps s'est-il déroulé depuis la dernière fois que tu as mis à jour le PPA sur ton système? Cela fait plusieurs mois qu'il n'a pas été basé sur cette vieille version d'Open Cascade. Il a été mis à jour à la 7.3 en juillet 2018 alors que FreeCAD 0.17 était la version proposée.

openBrain a raison, tu devrais tout désinstaller, y compris tout paquet du PPA FreeCAD Community, soit les paquets nommés freecad-extras-*.

Et je te conseille d'ignorer les ignares qui se complaisent dans les bêtes généralités parce qu'ils n'y comprennent rien. La 0.18 fonctionne très bien depuis très longtemps (avant même sa sortie plus ou moins officielle), les problèmes actuels (qui n'affectent pas le PPA) en sont d'empaquetage ou de préparation de logiciels d'installation, causés par la migration aux bibliothèques logicielles Qt 5 et Python 3. Bien sûr elle a son lot de nouveaux petits problèmes, comme toutes les versions de FreeCAD avant elle.

Chez moi sous Ubuntu 18.04, je n'ai aucun problème avec FreeCAD 0.18.1. En plus, depuis le PPA sous Bionic et supérieur, on peut aisément passer de Python 2 à Python 3 et l'inverse à l'aide d'une commande terminal, ce qu'aucune autre version toutes plateformes confondues ne permet.
joel
Posts: 175
Joined: Thu Jan 26, 2017 8:17 pm
Location: Thonon les Bains

Re: PPA cassé

Postby joel » Sat Apr 20, 2019 8:41 am

NormandC wrote:
Sat Apr 20, 2019 5:10 am
Chez moi sous Ubuntu 18.04, je n'ai aucun problème avec FreeCAD 0.18.1. En plus, depuis le PPA sous Bionic et supérieur, on peut aisément passer de Python 2 à Python 3 et l'inverse à l'aide d'une commande terminal, ce qu'aucune autre version toutes plateformes confondues ne permet.
Bonjour.
Peux-tu préciser la commande terminale. Merci

OS: Ubuntu 18.04.2 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.16093 (Git)
Build type: Release
Branch: releases/FreeCAD-0-18
Hash: 690774c0effe4fd7b8d2b5e2fb2b8c8d145e21ce
Python version: 2.7.15rc1
Qt version: 5.9.5
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: French/France (fr_FR)
User avatar
NormandC
Posts: 18534
Joined: Sat Feb 06, 2010 9:52 pm
Location: Québec, Canada

Re: PPA cassé

Postby NormandC » Sat Apr 20, 2019 5:05 pm

Salut Joel,

joel wrote:
Sat Apr 20, 2019 8:41 am
OS: Ubuntu 18.04.2 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.16093 (Git)
Ça, c'est l'info du paquet freecad-daily du PPA du même nom, qui est "gelé" depuis quelques semaines. Je parle de la version du PPA freecad-stable, et dont le nom du paquet est freecad, qui est construit depuis le "tag" 0.18.1, et correspond à la version 0.18.16110, comprenant déjà un lot de correctifs. Le PPA stable est donc pour l'instant plus à jour que le PPA Daily.

Le PPA stable propose désormais un métapaquet freecad plutôt qu'un paquet unique. Le paquet freecad dépend donc de plusieurs autres paquets :
  • freecad-common (contient les fichiers communs)
  • freecad-python2 (contient les fichiers binaires Python 2)
  • freecad-python3 (contient les fichiers binaires Python 3) (Ubuntu 18.04 et + seulement)
  • freecad-runtime (contient les fichiers exécutables)
  • libfreecad-python2-0.18 (contient les bibliothèques Python 2)
  • libfreecad-python3-0.18 (contient les bibliothèques Python 3) (Ubuntu 18.04 et + seulement)
Les raisons de ces changements :
  • Une meilleure conformité aux règles d'empaquetage définies par Debian
  • Éviter la duplication des paquets pour les différentes architectures (i386, x86_64, arm64...): puisque de nombreux fichiers dont FreeCAD dépend ne requièrent aucune compilation, ils sont regroupés dans un paquet compatible avec toutes les architectures. Il ne sera donc construit qu'une seule fois, plutôt que chaque fois pour i386, pour x86_64, pour arm64, etc. L'infrastructure de construction de paquets (celles de Debian, d'Ubuntu et de Launchpad) s'en trouvera donc moins sollicitée autant pour le temps serveur que pour l'espace de stockage.
  • À l'aide du mécanisme "Debian alternatives", permet de passer aisément de Python 2 à Python 3. Cela peut être particulièrement utile, car la migration à Python 3 créé encore quelques soucis pour des macros, des modules externes, et même des fonctions internes à FreeCAD. Ubuntu 16.04 est la seule version limitée à Python 2, parce que les dépôts contiennent des versions de bibliothèques trop anciennes pour faire fonctionner FreeCAD avec Python 3.
Pour changer la version de Python utilisée par FreeCAD du PPA freecad-stable
  1. D'abord fermer l'application.
  2. S'assurer que le paquet freecad-python2 est installé; celui-ci a pour dépendance libfreecad-python2-0.18.
  3. Ouvrir un terminal et lancer la commande suivante :

    Code: Select all

    sudo update-alternatives --config freecad
    Saisir le mot de passe puis faire Entrée.
  4. Les instructions suivantes apparaîtront dans le terminal :

    Code: Select all

    Il existe 2 choix pour l'alternative freecad (qui fournit /usr/bin/freecad).
    
      Sélection   Chemin                                Priorité  État
    ------------------------------------------------------------
      0            /usr/lib/freecad/bin/freecad-python2   30        mode automatique
    * 1            /usr/lib/freecad/bin/freecad-python2   30        mode manuel
      2            /usr/lib/freecad/bin/freecad-python3   30        mode manuel
    
    Appuyez sur <Entrée> pour conserver la valeur par défaut[*] ou choisissez le numéro sélectionné :
    
    Il suffit de saisir l'option désirée et appuyer sur Entrée.
  5. Relancer FreeCAD; la version Python utilisée sera affichée dans la console Python.
À noter que le paquet freecad-doc pour la documentation n'est pas encore disponible, le responsable de la création des paquets manque de temps, et perso tout le processus dépasse désormais mes compétences pour que je puisse donner un coup de main. Quand il sera disponible, une version française sera publiée, la version préliminaire de ce paquet a d'ailleurs été d'abord proposée sur le PPA freecad-community en août 2018.
User avatar
meme2704
Posts: 2926
Joined: Sat Apr 01, 2017 2:47 pm
Location: Vosges

Re: PPA cassé

Postby meme2704 » Sun Apr 21, 2019 7:07 am

l'annonce officielle n'a pas encore été faite parce qu'il y a eu quelques pépins de préparation
et c'est pas un ignare malveillant qui le dit
joel
Posts: 175
Joined: Thu Jan 26, 2017 8:17 pm
Location: Thonon les Bains

Re: PPA cassé

Postby joel » Sun Apr 21, 2019 5:03 pm

Merci à NormandC pour les renseignements. J'ai également la version dont tu parles.

OS: Ubuntu 18.04.2 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.1.
Build type: Release
Python version: 2.7.15rc1
Qt version: 5.9.5
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: French/France (fr_FR)