Compatibilidad con proyectos de versiones anteriores

Este foro es para preguntas y debates en Español
Forum rules
reglas del foro e información útil

IMPORTANTE: Por favor leer antes de solicitar ayuda
toque22
Posts: 4
Joined: Thu Jan 17, 2019 7:53 am

Compatibilidad con proyectos de versiones anteriores

Postby toque22 » Thu Jan 17, 2019 8:43 am

Hola a todos. Me estreno en el foro con este mensaje.
Uso Freecad desde hace algún tiempo(enero de 2017 y versión de Freecad creo que 0,16) y estoy encantado con él. Mi problema es que he tenido que retomar algunos dibujos de hace tiempo y no me reconoce los ficheros como originales de Freecad. son archivos fcstd normales y sin grandes complicaciones. El caso es que el fallo me lo dió hace una semana y cada vez que intentaba abrir uno de estos ficheros, el programa se colgaba y se cerraba. Más extraño es que solo fallaban algunos ficheros. Desde entonces Freecad se me ha actualizado dos veces, y hoy he intentado abrir un par de ficheros y aunque sigue sin reconocerlos como ficheros originales del programa si que los ha abierto.
Mi duda es si tengo que guardar todos los ficheros de alguna manera especial para no volver a tener este problema.

Mi versión actual es esta:

OS: Ubuntu 18.04.1 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.13541 (Git)
Build type: Release
Branch: releases/FreeCAD-0-17
Hash: 9948ee4f1570df9216862a79705afb367b2c6ffb
Python version: 2.7.15rc1
Qt version: 5.9.5
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: Spanish/Spain (es_ES)


Gracias a todos por estar ahí.
Un saludo.
dpozber952
Posts: 10
Joined: Thu Oct 04, 2018 5:48 pm

Re: Compatibilidad con proyectos de versiones anteriores

Postby dpozber952 » Fri Jan 18, 2019 10:07 pm

Ami me da también problemas al abrir archivos fcstd en freecad 0.17
User avatar
bitacovir
Posts: 1156
Joined: Sat Apr 19, 2014 6:23 am
Contact:

Re: Compatibilidad con proyectos de versiones anteriores

Postby bitacovir » Sat Jan 19, 2019 12:20 am

Se ha advertido que la version 0.17 no es ya muy compatible con trabajos hechos con versiones previas.

A word of caution to users of v0.16: there has been tremendous changes to the PartDesign workbench, with the introduction of the Part and Body containers. A Body is now mandatory to create PartDesign features. When trying to edit a document made in v0.16, you will be prompted to migrate it automatically. If your model was done with a mix of PartDesign features and Part objects, the migration process will most certainly leave your model in a broken state! So if you are not willing to migrate it manually (expect having to delete some stuff and recreate it), it would be best to keep a working version of v0.16 on the side to edit your old documents.
::bitacovir::
===================================
One must be absolutely modern.
Arthur Rimbaud (A Season in Hell -1873)

My personal web site
My GitHub repository
My old Blog
Mini Airflow Tunnel Project
toque22
Posts: 4
Joined: Thu Jan 17, 2019 7:53 am

Re: Compatibilidad con proyectos de versiones anteriores

Postby toque22 » Sat Jan 19, 2019 5:14 pm

bitacovir wrote:
Sat Jan 19, 2019 12:20 am
Se ha advertido que la version 0.17 no es ya muy compatible con trabajos hechos con versiones previas.

Hola bitacovir. gracias por la información. volveré a crear los ficheros que no pueda abrir.
Un saludo.
toque22
Posts: 4
Joined: Thu Jan 17, 2019 7:53 am

Re: Compatibilidad con proyectos de versiones anteriores

Postby toque22 » Thu Jan 24, 2019 11:09 am

Hola de nuevo. creía que ya lo tenía todo solucionado y resulta que la cosa va a peor.
resulta que ahora puedo ver y ejecutar los ficheros antiguos (Aunque algunos sigue sin reconocerlos como originales de Freecad) pero los de nueva creación los guarda pero luego no los reconoce como ficheros ni de Freecad ni como compatibles. No aparecen en el explorador de abrir archivo de Freecad de ninguna manera. En el explorador del sistema operativo aparecen como archivos comprimidos tipo zip.
he desinstalado el programa y vuelto a instalar 2 veces, una desde el enlace de freecadweb.org y otro desde el instalador del sistema operativo.



Instalación actual:

OS: Ubuntu 18.04.1 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.13541 (Git)
Build type: Release
Branch: releases/FreeCAD-0-17
Hash: 9948ee4f1570df9216862a79705afb367b2c6ffb
Python version: 2.7.15rc1
Qt version: 5.9.5
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: Spanish/Spain (es_ES)
User avatar
bitacovir
Posts: 1156
Joined: Sat Apr 19, 2014 6:23 am
Contact:

Re: Compatibilidad con proyectos de versiones anteriores

Postby bitacovir » Thu Jan 24, 2019 12:16 pm

Puedes compartir los archivos que te dan problemas?
La verdad es que no entiendo bien tu problema. Dices que con archivos creados con la ultima version de freecad estos no tienen formato FCStd?
::bitacovir::
===================================
One must be absolutely modern.
Arthur Rimbaud (A Season in Hell -1873)

My personal web site
My GitHub repository
My old Blog
Mini Airflow Tunnel Project
toque22
Posts: 4
Joined: Thu Jan 17, 2019 7:53 am

Re: Compatibilidad con proyectos de versiones anteriores

Postby toque22 » Fri Jan 25, 2019 8:10 am

Hola bitacovir: Creo que lo he "solucionado". Hoy he hecho varias pruebas para explicarte lo que hacía el programa y la cosa iba a peor, hasta el punto de no poder unir dos piezas. He descargado la versión 0.18 y parece que se me han acabado los problemas. Imagino que algún fichero de configuración estaba corrupto. Si me vuelve a dar problemas volveré a comentarlo.
Muchas gracias por todo.