Help with CAM

Here's the place for discussion related to CAM/CNC and the development of the Path module.
osmanager
Posts: 8
Joined: Thu Oct 31, 2019 9:27 pm

Re: Help with CAM

Postby osmanager » Sun Feb 21, 2021 10:08 pm

My machine is a home built one with 3 Axis x,y z with a Katsu Router.
I use it mainly for hardwoods like oak. i.e. this model is of Dr Who's Tardis and is only just over 3 inches tall and will be milled from one solid block.

My machine is running GRBL 1.1 on Arduino and is controlled by UGS on a windows 10 pc.
GeneFC
Posts: 1917
Joined: Sat Mar 19, 2016 3:36 pm
Location: Punta Gorda, FL

Re: Help with CAM

Postby GeneFC » Sun Feb 21, 2021 10:40 pm

osmanager wrote:
Sun Feb 21, 2021 4:50 pm
According to the Wiki - from version 0.19 OCL is installed by default so no need to do that bit but I did need to enable the Experimental bit to see the 3D surface.
OK, that is why it is important to know the exact version you are using.

In your version it is only necessary to enable the experimental features.

In the latest version it is also necessary to ensure that the OCL features are enabled in Preferences. I am not sure just when this change occurred, but it is now in the new versions.

Capture.JPG
Capture.JPG (69.64 KiB) Viewed 141 times

Gene
osmanager
Posts: 8
Joined: Thu Oct 31, 2019 9:27 pm

Re: Help with CAM

Postby osmanager » Fri Feb 26, 2021 4:49 pm

Just an update - With all your help I have been able to get the CAM I was working on sorted on screen. I just have not had time to test it all works on my machine.
Will post when I have done the tests.