Tools, old Tool, new ToolBit and other fun stuff

Here's the place for discussion related to CAM/CNC and the development of the Path module.
chrisb
Posts: 22315
Joined: Tue Mar 17, 2015 9:14 am

Re: Tools, old Tool, new ToolBit and other fun stuff

Postby chrisb » Fri Jan 03, 2020 12:43 am

Walter, looking at your last screenshot: you can clear the Python console with the right mouse menu.
mlampert
Posts: 1460
Joined: Fri Sep 16, 2016 9:28 pm

Re: Tools, old Tool, new ToolBit and other fun stuff

Postby mlampert » Fri Jan 03, 2020 12:46 am

chrisb wrote:
Fri Jan 03, 2020 12:41 am
Do these additional icons depend on opencamlib?
No they don't, and neither does the ToolBit code - the only thing that should depend on OCL is the Surface op.
chrisb
Posts: 22315
Joined: Tue Mar 17, 2015 9:14 am

Re: Tools, old Tool, new ToolBit and other fun stuff

Postby chrisb » Fri Jan 03, 2020 12:46 am

You can try adding EnableExperimentalFeatures as mentioned above. You should, of course, backup your user.cfg.
User avatar
roerich_64
Posts: 901
Joined: Thu May 21, 2015 7:00 pm
Location: Ostfriesland

Re: Tools, old Tool, new ToolBit and other fun stuff

Postby roerich_64 » Fri Jan 03, 2020 12:48 am

@ChrisB,

opencamlib are the library for 3D-Surface or not... ?!?
mlampert
Posts: 1460
Joined: Fri Sep 16, 2016 9:28 pm

Re: Tools, old Tool, new ToolBit and other fun stuff

Postby mlampert » Fri Jan 03, 2020 12:50 am

It looks like you got everything enabled but it still isn't, very disturbing.
Walter, could you post your user.cfg and system.cfg please?
User avatar
roerich_64
Posts: 901
Joined: Thu May 21, 2015 7:00 pm
Location: Ostfriesland

Re: Tools, old Tool, new ToolBit and other fun stuff

Postby roerich_64 » Fri Jan 03, 2020 12:56 am

i gave them an extension *.txt to post them here:
user.txt
(45.59 KiB) Downloaded 9 times
system.txt
(922 Bytes) Downloaded 6 times
chrisb
Posts: 22315
Joined: Tue Mar 17, 2015 9:14 am

Re: Tools, old Tool, new ToolBit and other fun stuff

Postby chrisb » Fri Jan 03, 2020 1:00 am

You have a blank added to "EnableExperimentalFeatures".
mlampert
Posts: 1460
Joined: Fri Sep 16, 2016 9:28 pm

Re: Tools, old Tool, new ToolBit and other fun stuff

Postby mlampert » Fri Jan 03, 2020 1:05 am

chrisb wrote:
Fri Jan 03, 2020 1:00 am
You have a blank added to "EnableExperimentalFeatures".
Nobody beats chrisb 8-)
User avatar
roerich_64
Posts: 901
Joined: Thu May 21, 2015 7:00 pm
Location: Ostfriesland

Re: Tools, old Tool, new ToolBit and other fun stuff

Postby roerich_64 » Fri Jan 03, 2020 1:06 am

:shock: :shock: I think there is the Boolean at thrue:
bar_V.jpg
bar_V.jpg (319.4 KiB) Viewed 105 times
mlampert
Posts: 1460
Joined: Fri Sep 16, 2016 9:28 pm

Re: Tools, old Tool, new ToolBit and other fun stuff

Postby mlampert » Fri Jan 03, 2020 1:08 am

roerich_64 wrote:
Fri Jan 03, 2020 1:06 am
:shock: :shock: I think there is the Boolean at thrue:
It's the space at the end of "EnableExperimentalFeatures ", the space before the closing quotation mark which causes the problem.