Why does FEM meshing doesn't generate volume elements in some cases

About the development of the FEM module/workbench.

Moderator: bernd

vejmarie
Posts: 551
Joined: Mon Jan 04, 2016 4:52 pm
Location: Somewhere between France, USA and Taiwan
Contact:

Re: Why does FEM meshing doesn't generate volume elements in some cases

Postby vejmarie » Sun Apr 24, 2016 8:57 pm

Hi Bernd,

Thanks for the update. In fact this issue ended up to create a few others for me that I reported into the Mac Version of FreeCAD and OCCT v6.x which crashed pretty "easily". I requested for a move forward with OCCT 7.0.0 which is fixing the issue I meet on Mac with OCCT optimized but requires a lot of changes into FreeCAD code, as well as FEM wb due to OCCT dependency. The other things is that the SMESH and meshing interface used from Salome is crazy old so I have updated to latest version of Salome 7.7.1. I have been able to recompile everything but still face some challenges on the Hypthesis interface which has totally changed from 2008 (hey the FreeCAD code on this side is crazy old). I will stop for now my tests except if I find somebody with the wish to move forward with me on this long path.

I will move back to a more "traditionnal" version and check if I can run the math of my stair on the Mac machine.

vejmarie
User avatar
bernd
Posts: 8329
Joined: Sun Sep 08, 2013 8:07 pm
Location: Zürich, Switzerland

Re: Why does FEM meshing doesn't generate volume elements in some cases

Postby bernd » Mon Apr 25, 2016 11:49 am

vejmarie wrote:The other things is that the SMESH and meshing interface used from Salome is crazy old so I have updated to latest version of Salome 7.7.1. I have been able to recompile everything but still face some challenges on the Hypthesis interface which has totally changed from 2008 (hey the FreeCAD code on this side is crazy old). I will stop for now my tests except if I find somebody with the wish to move forward with me on this long path.
Does it mean you have been able to compile FreeCAD with uptodate SMESH code ??? That would be awesome if we could update this old code one day. There is a simple reason for this old code. All former developer of FEMwb have stoped contributing to FEMwb and my C++ is really poor.
vejmarie
Posts: 551
Joined: Mon Jan 04, 2016 4:52 pm
Location: Somewhere between France, USA and Taiwan
Contact:

Re: Why does FEM meshing doesn't generate volume elements in some cases

Postby vejmarie » Mon Apr 25, 2016 2:59 pm

Hi Bernd,

Yes this is what I have done, compiling FreeCAD with Salome 7.7.1 and OCCT 7.0.0. But the meshing side is not working yet, I just wanted to test first if I was able to make it work on the "root" elements and this is done on my Mac. The key things is that the FEM code needs a strong clean up to work properly with this port, but at least I can run an optimized OCCT on Mac with XCode 7.3, which I was looking for and validate what OCCT dev were claiming regarding one bug fix which was making crash FreeCAD on Mac. I also need to port Netgen.

The key thing now is that if I want to progress, I need to create a branch, re-run the process and update a lot of "things", and be sure not to complete the job for nothing and that we could merge one day, that is why I am trying to know who is the maintainer of all this stuff.

I am convinced we need to update this code, only because one day we will have to switch to OCCT 7 and this code is NOT compatible with it and it will break the Fem module for ever.

vejmarie
vejmarie
Posts: 551
Joined: Mon Jan 04, 2016 4:52 pm
Location: Somewhere between France, USA and Taiwan
Contact:

Re: Why does FEM meshing doesn't generate volume elements in some cases

Postby vejmarie » Mon Apr 25, 2016 5:14 pm

I just created a fork on github https://github.com/vejmarie/FreeCAD to try to move to OCCT 7.0.0 and others ... funny update like Salome 7.7.1 for the one who are willing to help just ping me I can provide you git access to the repo.
User avatar
bernd
Posts: 8329
Joined: Sun Sep 08, 2013 8:07 pm
Location: Zürich, Switzerland

Re: Why does FEM meshing doesn't generate volume elements in some cases

Postby bernd » Tue Apr 26, 2016 8:51 am

Wow great, I can only help with testing and I for sure will!

Related Thread, viewtopic.php?f=4&t=14570 This post says what you said and what I knew before but eliminated in my mind viewtopic.php?f=4&t=14570&start=10#p117701

We may should open a new thread in Install / compile or in FEM to get more people involved?
User avatar
bernd
Posts: 8329
Joined: Sun Sep 08, 2013 8:07 pm
Location: Zürich, Switzerland

Re: Why does FEM meshing doesn't generate volume elements in some cases

Postby bernd » Tue Apr 26, 2016 8:56 am

vejmarie wrote:I just created a fork on github https://github.com/vejmarie/FreeCAD to try to move to OCCT 7.0.0
Would you rebase this on top of at least following commit https://github.com/FreeCAD/FreeCAD/comm ... f8623abca8

There where three bigger commits in the regard of codeformating in FEM C++
vejmarie
Posts: 551
Joined: Mon Jan 04, 2016 4:52 pm
Location: Somewhere between France, USA and Taiwan
Contact:

Re: Why does FEM meshing doesn't generate volume elements in some cases

Postby vejmarie » Tue Apr 26, 2016 9:27 am

Hi Bernd,

Ok I will do that tonight. (I am mostly writing code during the night)

vejmarie
vejmarie
Posts: 551
Joined: Mon Jan 04, 2016 4:52 pm
Location: Somewhere between France, USA and Taiwan
Contact:

Re: Why does FEM meshing doesn't generate volume elements in some cases

Postby vejmarie » Tue Apr 26, 2016 12:01 pm

Done on my lunch time if you want check
vejmarie
Posts: 551
Joined: Mon Jan 04, 2016 4:52 pm
Location: Somewhere between France, USA and Taiwan
Contact:

Re: Why does FEM meshing doesn't generate volume elements in some cases

Postby vejmarie » Tue Apr 26, 2016 10:46 pm

I just have pushed to the branch a "compilable" version on MacOS. There are some issues please read Port_Modification.changlog ;)
User avatar
bernd
Posts: 8329
Joined: Sun Sep 08, 2013 8:07 pm
Location: Zürich, Switzerland

Re: Why does FEM meshing doesn't generate volume elements in some cases

Postby bernd » Wed Apr 27, 2016 10:35 am

I have never compiled occt and thus never compiled FreeCAD against my own occt. I'm on Debian Jessie and would like to give your repo a try. Just to get it done the right way. I need to:

- pull OCCT 7.0.0 from http://git.dev.opencascade.org/gitweb/
- did you use the latest branch or the tag 7.0.0 ?
- compile OCCT 7.0.0

- pull FreeCAC from your occt7 branch https://github.com/vejmarie/FreeCAD/tree/occt7
- compile FreeCAD against the fresh new compiled OCCT 7.0.0