[Fixed] 0.19pre, FEM fail to startup in Conda build

About the development of the FEM module/workbench.

Moderator: bernd

fc_tofu
Posts: 652
Joined: Sun Jan 05, 2020 4:56 pm

[Fixed] 0.19pre, FEM fail to startup in Conda build

Postby fc_tofu » Sun May 10, 2020 3:31 pm

With new installed FreeCAD 0.19.20943/Win10x64, switching to FEM workbench fail and prompt

Code: Select all

DLL load failed while importing Fem: 找不到指定的程序。
Traceback (most recent call last):
  File "<string>", line 41, in Initialize
fsc_2020-05-14_194847.jpg
fsc_2020-05-14_194847.jpg (87.72 KiB) Viewed 287 times
The question is, why the prompt msg in Report View use OS locale language (Chinese), whereas the language of FreeCAD is set as English.

ps.
“找不到指定的程序。” means, "Cannot find specific application."

OS: Windows 10 (10.0)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.20943 (Git)
Build type: Release
Branch: master
Hash: ceb23799c76df3ebfa7be4b9fe83bb62de60bc6c
Python version: 3.8.2
Qt version: 5.12.5
Coin version: 4.0.0
OCC version: 7.4.0
Locale: Chinese/China (zh_CN)
Last edited by fc_tofu on Tue May 19, 2020 10:46 am, edited 4 times in total.
ickby
Posts: 2970
Joined: Wed Oct 05, 2011 7:36 am

Re: 0.19pre, FEM fail to startup

Postby ickby » Fri May 15, 2020 5:30 am

I have the same problem, and cannot use FEM in 0.19 due to the startup-error. Does anyone have an idea howto fix this?
User avatar
bernd
Posts: 10523
Joined: Sun Sep 08, 2013 8:07 pm
Location: Zürich, Switzerland

Re: 0.19pre, FEM fail to startup

Postby bernd » Fri May 15, 2020 7:46 am

I have never had this on downloaded dev versions for Windows.

Did you guys downloaded a dev version, or did you compile yourself?
fc_tofu
Posts: 652
Joined: Sun Jan 05, 2020 4:56 pm

Re: 0.19pre, FEM fail to startup

Postby fc_tofu » Fri May 15, 2020 8:18 am

bernd wrote:
Fri May 15, 2020 7:46 am
I have never had this on downloaded dev versions for Windows.

Did you guys downloaded a dev version, or did you compile yourself?
From below,
https://github.com/FreeCAD/FreeCAD/releases

Code: Select all

OS: Windows 10 (10.0)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.21049 (Git)
Build type: Release
Branch: master
Hash: 9c27f1078e5ec516fe882aac1a27f5c6c6174554
Python version: 3.8.2
Qt version: 5.12.5
Coin version: 4.0.0
OCC version: 7.4.0
Locale: Chinese/China (zh_CN)
Last edited by fc_tofu on Fri May 15, 2020 9:16 am, edited 1 time in total.
User avatar
bernd
Posts: 10523
Joined: Sun Sep 08, 2013 8:07 pm
Location: Zürich, Switzerland

Re: 0.19pre, FEM fail to startup

Postby bernd » Fri May 15, 2020 9:14 am

fc_tofu wrote:
Fri May 15, 2020 8:18 am
bernd wrote:
Fri May 15, 2020 7:46 am
I have never had this on downloaded dev versions for Windows.

Did you guys downloaded a dev version, or did you compile yourself?
From below,
https://github.com/FreeCAD/FreeCAD/releases
this one from there runs fine for me ...

Code: Select all

OS: Windows 10 (10.0)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.20980 (Git)
Build type: Release
Branch: master
Hash: c2818d9159385d23b182dc7167af2d4bacbee94c
Python version: 3.6.8
Qt version: 5.12.1
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: German/Switzerland (de_CH)

just downloading the latest one ...
fc_tofu
Posts: 652
Joined: Sun Jan 05, 2020 4:56 pm

Re: 0.19pre, FEM fail to startup

Postby fc_tofu » Fri May 15, 2020 9:19 am

bernd wrote:
Fri May 15, 2020 9:14 am
this one from there runs fine for me ...

Code: Select all

OS: Windows 10 (10.0)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.20980 (Git)
Build type: Release
Branch: master
Hash: c2818d9159385d23b182dc7167af2d4bacbee94c
Python version: 3.6.8
Qt version: 5.12.1
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: German/Switzerland (de_CH)
just downloading the latest one ...
By comparing with your info, I feel a higher Python version "3.8.2" might be the culprit.
fc_tofu
Posts: 652
Joined: Sun Jan 05, 2020 4:56 pm

Re: 0.19pre, FEM fail to startup

Postby fc_tofu » Fri May 15, 2020 9:20 am

ickby wrote:
Fri May 15, 2020 5:30 am
I have the same problem, and cannot use FEM in 0.19 due to the startup-error. Does anyone have an idea howto fix this?
Give your info, please.
User avatar
bernd
Posts: 10523
Joined: Sun Sep 08, 2013 8:07 pm
Location: Zürich, Switzerland

Re: 0.19pre, FEM fail to startup

Postby bernd » Fri May 15, 2020 9:22 am

Code: Select all

OS: Windows 10 (10.0)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.21068 (Git)
Build type: Release
Branch: master
Hash: 92fe9adebbff910c5a10d6230785a6b58935b677
Python version: 3.6.8
Qt version: 5.12.1
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: German/Switzerland (de_CH)
works great
User avatar
bernd
Posts: 10523
Joined: Sun Sep 08, 2013 8:07 pm
Location: Zürich, Switzerland

Re: 0.19pre, FEM fail to startup

Postby bernd » Fri May 15, 2020 9:23 am

Did you use LibPack (LB) or Conda package? I only tested LibPack packages.
User avatar
bernd
Posts: 10523
Joined: Sun Sep 08, 2013 8:07 pm
Location: Zürich, Switzerland

Re: 0.19pre, FEM fail to startup

Postby bernd » Fri May 15, 2020 9:24 am

fc_tofu wrote:
Fri May 15, 2020 9:19 am
By comparing with your info, I feel a higher Python version "3.8.2" might be the culprit.
Ahh so you use the Conda ones? Just testing ...