Body clone inside body position properties dissapear after save

About the development of the Part Design module/workbench. PLEASE DO NOT POST HELP REQUESTS HERE!
abdullah
Posts: 3174
Joined: Sun May 04, 2014 3:16 pm

Re: Body clone inside body position properties dissapear after save

Postby abdullah » Tue Jun 25, 2019 11:53 am

tsadowski wrote:
Mon May 27, 2019 7:07 pm
This is exactly the point. The clone as the base feature has the position of the original body. The enclosing body of the clone has the position (0,0,0). After a save/load it is impossible to edit the position of the clone.

Either the position of the clone remains editable or the new body gets the position of the original body and the clone position is (0,0,0). What is better?

Cheers,
Torsten
It is very funny that just after using partdesign clone to create a clone, the base feature shows a placement property. However after save and reload the placement property is gone from the property editor.

I am not sure what is right. I do not know why this was decided or maybe it is unintended. It would make sense to ask ickby or Werner...
User avatar
DeepSOIC
Posts: 6694
Joined: Fri Aug 29, 2014 12:45 am
Location: Saint-Petersburg, Russia

Re: Body clone inside body position properties dissapear after save

Postby DeepSOIC » Tue Jun 25, 2019 12:53 pm

My suggestion would be: use Draft clone for just about everything. PartDesign clone, as far as I remember, was introduced to help with PartDesign Booleans.

I don't think there is anything fundamentally wrong with having a Placement property for some PartDesign features.

abdullah wrote:
Tue Jun 25, 2019 11:53 am
It is very funny that just after using partdesign clone to create a clone, the base feature shows a placement property. However after save and reload the placement property is gone from the property editor.
This is clearly a bug. The behavior must be consistent.