a2plus: Constraints inconsistent. Cannot solve System.

Discussion about the development of the Assembly workbench.
_cyclops_
Posts: 7
Joined: Mon Aug 08, 2016 6:49 pm

a2plus: Constraints inconsistent. Cannot solve System.

Postby _cyclops_ » Fri Nov 08, 2019 11:45 pm

Hi,

As i'm fairly new, i'm quite sure the above question has been asked before.
I've been assembling with a2plus and all goes well. Until i hit the Constraints inconsistent error message. It tells me to delete the last added constraint, but that doesn't make it go away.

Is there not a way to find out WHICH constraint is causing an issue or which part of the assembly is not ok?

I've got an wood working assembly with currently around 10 parts. It's a massive pain to start from the beginning again (albeit i seem to have no other option). The problem is, i don't know what causes this, so i'm not looking to just restart. I want to learn what i did wrong and how to resolve an error.
dan-miel
Posts: 84
Joined: Thu Sep 13, 2018 12:29 am
Location: Spokane WA. USA

Re: a2plus: Constraints inconsistent. Cannot solve System.

Postby dan-miel » Tue Nov 12, 2019 5:02 pm

Hi cyclops
I asked this question once and apparently the mates are solved as a group and does not output which one caused the problem.
Have you tried using the tool in A2+ that shows what surfaces a constraint is connected to?
It looks like a gray magnifying glass. I have used it to find problem mates although I cannot all ways find them.

Here is a demo.
phpBB [video]