@RealThunder: There's one thing I came across during the testing lately, it's the naming of the constraints. They're all grouped in 1 folder and have generic names (like PlaneCoincident1). Very soon one gets lost in the names, even with small assemblies, and all the time searches for the right constraint, when in need to modify it. I'd suggest to extend the generic name to something like
Code: Select all
The way you display the constraints in one folder has it's advantages (disadvantages too, of course), but it certainly increases the need for naming it after the constrained parts.
Or of course, there can be other was to handle it, i.e. mouse-over constraint event could select/highlight the parts in assembly, which is certainly more difficult to implement.