Our mediawiki translation extension is pretty outdated

Discussions about the wiki documentation of FreeCAD and its translation.
User avatar
Kunda1
Posts: 4282
Joined: Thu Jan 05, 2017 9:03 pm

Our mediawiki translation extension is pretty outdated

Postby Kunda1 » Sat May 18, 2019 11:23 am

Note: I'm aware that updating mediawiki is a PITA and on top of that there are limitations to our hosting account. This is just a Public Service Announcement, if you will.

Per https://www.freecadweb.org/wiki/Special:Version we're running Mediawiki 1.30 (as of this writing 1.32.1 is latest stable).

The translation extension that we run: (https://www.mediawiki.org/wiki/Extension:Translate) is MLEB 2017.10 According to https://www.mediawiki.org/wiki/MediaWik ... ion_Bundle the latest version MLEB 2019.04 but if we want to update (w/o updating mediawiki we can only upgrade to MLEB 2018.10
Want to contribute back to FC? Checkout:
#lowhangingfruit | Use the Source, Luke. | How to Help FreeCAD | How to report FC bugs and features
User avatar
yorik
Site Admin
Posts: 11157
Joined: Tue Feb 17, 2009 9:16 pm
Location: São Paulo, Brazil
Contact:

Re: Our mediawiki translation extension is pretty outdated

Postby yorik » Mon May 20, 2019 7:05 pm

Might be time for an upgrade indeed. @kremitzki, have you already tried a version above 1.30? I don't remember...
User avatar
kkremitzki
Posts: 1548
Joined: Thu Mar 03, 2016 9:52 pm
Location: Texas

Re: Our mediawiki translation extension is pretty outdated

Postby kkremitzki » Mon May 20, 2019 7:11 pm

No, I haven't touched it in a while. My plan was to update to the latest LTS (1.31) to keep maintenance requirements to a minimum, but I've been busy with other things.
Like my FreeCAD work? I'd appreciate any level of support via Patreon, Liberapay, or PayPal! Read more about what I do at my blog.
vocx
Posts: 661
Joined: Thu Oct 18, 2018 9:18 pm

Re: Our mediawiki translation extension is pretty outdated

Postby vocx » Mon May 20, 2019 10:01 pm

Kunda1 wrote:
Sat May 18, 2019 11:23 am
This is just a Public Service Announcement, if you will.
As a wiki editor, I think keeping the supporting infrastructure of FreeCAD running in optimal condition is very important to attract more users.

Please do whatever it takes to do the necessary upgrades, even if that means a temporary shutdown of the wiki.
User avatar
yorik
Site Admin
Posts: 11157
Joined: Tue Feb 17, 2009 9:16 pm
Location: São Paulo, Brazil
Contact:

Re: Our mediawiki translation extension is pretty outdated

Postby yorik » Tue May 21, 2019 3:33 pm

Cool, I'll look into updating the wiki to1.31 tonight, then the translation tools... Indeed let's stay with the LTS version.