Rename: Mouse_Model to Mouse_navigation

Discussions about the wiki documentation of FreeCAD and its translation.
vocx
Posts: 3348
Joined: Thu Oct 18, 2018 9:18 pm

Rename: Mouse_Model to Mouse_navigation

Postby vocx » Fri Dec 13, 2019 4:57 pm

I don't know why the page that describes the mouse navigation modes is called Mouse_Model.

Why Model? Model of what? Maybe it was an old error, and it was meant Mouse_Mode?

Anyway, I think we need a better page name, for example,
* Mouse_navigation
* Mouse_navigation_style
* Mouse_navigation_modes
* 3D_navigation
* 3D_navigation_style
* 3D_view_navigation

The source code itself seems to call it NavigationStyle, so maybe the page should be named the same, Navigation_style. Notice I only capitalize the first word, other words should be in lowercase.

https://github.com/FreeCAD/FreeCAD/blob ... ionStyle.h
Always add the important information to your posts if you need help.
To support the documentation effort, and code development, your donation is appreciated: paypal.
User avatar
DeepSOIC
Posts: 7484
Joined: Fri Aug 29, 2014 12:45 am
Location: Saint-Petersburg, Russia

Re: Rename: Mouse_Model to Mouse_navigation

Postby DeepSOIC » Fri Dec 13, 2019 4:58 pm

++
3D_view_navigation
or simply
Navigation Styles.
vocx
Posts: 3348
Joined: Thu Oct 18, 2018 9:18 pm

Re: Rename: Mouse_Model to Mouse_navigation

Postby vocx » Fri Dec 13, 2019 6:06 pm

DeepSOIC wrote:
Fri Dec 13, 2019 4:58 pm
...
Navigation Styles.
Preferably Navigation_style, in singular.
Always add the important information to your posts if you need help.
To support the documentation effort, and code development, your donation is appreciated: paypal.