Update "Compile_on_Linux"

Discussions about the wiki documentation of FreeCAD and its translation.
axkibe
Posts: 19
Joined: Mon Jan 20, 2020 2:07 pm

Update "Compile_on_Linux"

Postby axkibe » Mon Jan 20, 2020 2:17 pm

Okay the working list is a little out of order, first it tells you
"cmake ../freecad-source"
much later in the page (unnoticed by me) it says, you'll likely need "-DBUILD_QT5=ON -DPYTHON_EXECUTABLE=/usr/bin/python3".
This is not ideal instruction where later it says, what you should have done before.

Also took me some time to find this page, "Install" doesn't even mention that building from source is an option, please do that. An in case of debian possibly the only sane one, at least the default packaged version is (hopefully) out of date (I really hope it gets better). I tried much to get the ubuntu ppa (bionic on buster) working for me, but the dependencies just go to far apart.

PS: How about making QT5 and pyhton3 default nowadays?