Problem when deleting an empty group: objects seem linked

A forum dedicated to the Draft, Arch and BIM workbenches development.
User avatar
microelly2
Posts: 4409
Joined: Tue Nov 12, 2013 4:06 pm
Contact:

Re: Problem when deleting an empty group: objects seem linked

Postby microelly2 » Sun Apr 03, 2016 6:22 pm

NormandC wrote:If there is interest, I could create some mockups to better visualize it, possibly create a feature request on Mantis.
I have already worked on this last summer. It's still a prototype but not to far from a usable solution

https://youtu.be/5evyAtZLnEg
https://github.com/microelly2/freecad-objecttree
JLB85FR
Posts: 76
Joined: Fri Jan 15, 2016 7:08 pm
Location: Vendée - France

Re: Problem when deleting an empty group: objects seem linked

Postby JLB85FR » Sun Apr 03, 2016 6:33 pm

I will try this....
for the moment I simulate a parent rename to retrieve the children as subnodes of the parent. I think it's the only way ...
I have used this many times when I had to populate the group for moving or rotating my design...
User avatar
NormandC
Posts: 18534
Joined: Sat Feb 06, 2010 9:52 pm
Location: Québec, Canada

Re: Problem when deleting an empty group: objects seem linked

Postby NormandC » Sun Apr 03, 2016 7:00 pm

microelly2 wrote:I have already worked on this last summer. It's still a prototype but not to far from a usable solution
Interesting. It's more involved than what I was suggesting, but more useful too.

It kind of reminds me of gramps, a FOSS genealogy software. :)