problema con il comando "APRI documento"

Forum per le domande e le discussioni in Italiano
Forum rules
regole del forum e le informazioni utili

Importante: PRIMA di chiedere aiuto leggete qui!
Imer
Posts: 8
Joined: Fri Aug 05, 2022 2:43 pm

problema con il comando "APRI documento"

Post by Imer »

Code: Select all

OS: Ubuntu Core 20 (KDE/plasma)
Word size of FreeCAD: 64-bit
Version: 0.20.29177 (Git) Snap 161
Build type: Release
Branch: tag: 0.20
Hash: 68e337670e227889217652ddac593c93b5e8dc94
Python 3.8.10, Qt 5.15.3, Coin 4.0.0, Vtk 7.1.1, OCC 7.6.2
Locale: Italian/Italy (it_IT)
Installed mods: 
  * fcgear 1.0.0
  * AirPlaneDesign 0.4.0
  * A2plus 0.4.56a
Buonasera,
come da titolo ho un problema abbastanza strano e non trovo soluzione,
ho aggiornato il PC e la versione 0.19 non funzionava piu' path , leggendo ho scoperto che la versione 0.20 risolveva il problema ed effettivamente cosi è stato.
Ora pero se apro un file usando dolphin in qualsiasi punto della mia home si apre senza problemi , ma se apro freecad e vado dal comando "Apri documento" , mi permette dalla home di entrare in una cartella , ma non mi permette di uscire vedo le voci ma non mi permette la selezione, se sbaglio l'unica soluzione è chiudere il comando e ripetere il tutto , inoltre ho scoperto che non mi permette piu' di aprire i file che salvo in remoto in un collegamento nfs questo anche da dophin, se copio il file in locale invece funziona perfettamente.

Ho provato a disinstallare freecad con apt purge e ripetere l'installazione da snap ma c'è sempre questo problema.

Grazie a tutti quelli che mi vorranno aiutare.

Imer Isella
Imer
Posts: 8
Joined: Fri Aug 05, 2022 2:43 pm

Re: problema con il comando "APRI documento"

Post by Imer »

scusate mi sono accorto di un'altra cosa , mancano le icone a Dx della finestra "cerca in" se ci clikko sopra dove dovrebbero essere funziona!
User avatar
onekk
Veteran
Posts: 2779
Joined: Sat Jan 17, 2015 7:48 am
Contact:

Re: problema con il comando "APRI documento"

Post by onekk »

Imer wrote: Fri Aug 05, 2022 2:57 pm ...
Hai provato una AppImage, sembra essere un problema relativo alle versioni delle librerie.

Mi pare strano che Snap usi Python 3.8.10 che è oggettivamente datata.

Ad esempio la mia AppImage di 0.20 usa:

Code: Select all

OS: Artix Linux (openbox)
Word size of FreeCAD: 64-bit
Version: 0.20.29177 (Git) AppImage
Build type: Release
Branch: (HEAD detached at 0.20)
Hash: 68e337670e227889217652ddac593c93b5e8dc94
Python 3.9.13, Qt 5.12.9, Coin 4.0.0, Vtk 9.1.0, OCC 7.5.3
Locale: Italian/Italy (it_IT)
Installed mods: 
  * Curves 0.5.2
Le versione pacchettizzate dalle distribuzioni non sono supportate perché in genere obsolete, hai controllato:

https://forum.freecadweb.org/viewtopic.php?f=3&t=30573

O più in generale:

https://wiki.freecadweb.org/Installing_on_Linux

Saluti

Carlo D.
My English and Italian Scripting Guide https://github.com/onekk/freecad-doc.
My Blog: https://onekk-maker.blogspot.com/

To help development see on GitHub Page

For enquiry about customized FC Scripting job PM me.
Imer
Posts: 8
Joined: Fri Aug 05, 2022 2:43 pm

Re: problema con il comando "APRI documento"

Post by Imer »

Ciao,
grazie per la risposta ,
si ho provato con Appimage e funziona, ma la deb 0.20 ha questo problema.
Inoltre la Appimage apre i file che ho in rete , cosa che non fa la versione installata.
Se l'unica soluzione è Appimage mi adeguo , ma non la gradisco, mi tocca rifare tutte la personlizzazione.

Ciao
Imer
Imer
Posts: 8
Joined: Fri Aug 05, 2022 2:43 pm

Re: problema con il comando "APRI documento"

Post by Imer »

ma se do il comando :
python3 --version
mi risponde questo:
Python 3.10.4

non capisco

Ciao
Imer
User avatar
onekk
Veteran
Posts: 2779
Joined: Sat Jan 17, 2015 7:48 am
Contact:

Re: problema con il comando "APRI documento"

Post by onekk »

Imer wrote: Sat Aug 06, 2022 3:00 pm ma se do il comando :
python3 --version
mi risponde questo:
Python 3.10.4

non capisco

Ciao
Imer
Be ok, però se batti il comando in console:

Code: Select all

python3 --version
ottieni la versione di Python che hai nella distribuzione, lo "Snap package" ha la sua versione interna che è poi quella che usa FC quando viene eseguito dal file Snap che è una sorta di "Ambiente protetto" che utilizza solo le librerie base (in genere kernel e libc) del sistema ospite, permettendo di avere librerie differenti da quelle presenti nel sistema, in genere queste librerie sono più aggiornate di quell del sistema, ma non è garantito perché a volte sono quelle richieste dal programma per girare correttamente per cui "dipende".

Se posti del codice sorgente usa l'icona con </> presente nella barra di editing del post e il codice verrà correttamente formattato come "codice sorgente"

l'icona " serve per fare il "quoting" cioè:
Questo è un testo quotato
Se passi sopra le icone poi in genere c'è un testo che descrive cosa fanno (in Inglese) ma presumo che siamo le stesse dei normali editor di testo.

Saluti

Carlo D.
My English and Italian Scripting Guide https://github.com/onekk/freecad-doc.
My Blog: https://onekk-maker.blogspot.com/

To help development see on GitHub Page

For enquiry about customized FC Scripting job PM me.
User avatar
onekk
Veteran
Posts: 2779
Joined: Sat Jan 17, 2015 7:48 am
Contact:

Re: problema con il comando "APRI documento"

Post by onekk »

Imer wrote: Sat Aug 06, 2022 2:52 pm Ciao,
grazie per la risposta ,
si ho provato con Appimage e funziona, ma la deb 0.20 ha questo problema.
...
se per "deb 0.20" intendi la versione scaricabile dal PPA e secondo le utlime notizie (che trovi nel link che ti ho postato) il PPA non è aggiornato, per cui al momento non è una opzione funzionante.

se è una versione fornita da "terzi" probabilmente è una versione abbastanza vecchia perché sono state fatte alcune modifiche alla 0.20 prima del rilascio per usare directory utente secondo lo standard FreeDesktop.

La personalizzazione non dovrebbe essere necessario rifarla, a meno che la versione di "deb 0.20" sia "pre modifiche" quindi una prerelease vecchia.

ora dovresti trovare la configurazione in:

Code: Select all

~/.config/FreeCAD
ed altre in posizioni vedi:

https://wiki.freecadweb.org/Release_notes_0.20#Core

In teoria copiando il contenuto delle vecchie directory nelle nuove, dovrebbe andara tutto, se non va devi proprio concellare e ripartire da capo.

Saluti

Carlo D.
My English and Italian Scripting Guide https://github.com/onekk/freecad-doc.
My Blog: https://onekk-maker.blogspot.com/

To help development see on GitHub Page

For enquiry about customized FC Scripting job PM me.
Imer
Posts: 8
Joined: Fri Aug 05, 2022 2:43 pm

Re: problema con il comando "APRI documento"

Post by Imer »

Ho provato l'installazione sia la deb del sito ufficilae , che da snap ma il problema rimane, quindi l'unica soluzione per il momento è AppImage.
Il problema della personalizzazione è appunto che il file ~/.config/FreeCAD non lo trovo con la versione snap e non capisco
come si aggiunge a Appimage.
Il file nelle varie prove lo rinominato in modo che la versione nuova installata ne rifacesse uno nuovo , pensando che il problema poteva essere li,
ma con la versione deb lo ricostruisce, ma sia Snap che AppImage non trovo dove lo nasconde.


Ciao
Imer
User avatar
onekk
Veteran
Posts: 2779
Joined: Sat Jan 17, 2015 7:48 am
Contact:

Re: problema con il comando "APRI documento"

Post by onekk »

Allora avevo postato un link che indirizzava ad una pagina dove viene descritta la nuova posizione e la vecchia.

La vecchia posizione dovrebbe essere ~/.FreeCAD/ ma ora sono sullo smartphone e non posso controllare.

Saluti

Carlo D.
Last edited by onekk on Tue Aug 09, 2022 11:00 am, edited 1 time in total.
My English and Italian Scripting Guide https://github.com/onekk/freecad-doc.
My Blog: https://onekk-maker.blogspot.com/

To help development see on GitHub Page

For enquiry about customized FC Scripting job PM me.
Imer
Posts: 8
Joined: Fri Aug 05, 2022 2:43 pm

Re: problema con il comando "APRI documento"

Post by Imer »

la vecchia la conosco :D ,
la nuova introvabile ,
approfondisco la ricerca, grazie comunque.

Ciao
Imer
Post Reply