Esportazione STL difettosa

Forum per le domande e le discussioni in Italiano
Forum rules
regole del forum e le informazioni utili

Importante: PRIMA di chiedere aiuto leggete qui!
renatorivo
Posts: 2031
Joined: Tue Feb 21, 2012 8:07 pm
Location: Torino - Italy

Re: Esportazione STL difettosa

Postby renatorivo » Tue May 01, 2018 9:02 pm

Provato esportazione e importazione da stl
Body nessun errore
Head da errore di autointersezione con tolleranza standard 0,10 nella conversione da stl a solido. L'errore scompare impostando una tolleranza maggiore, es 0,50
Ti allego per verifica i risultati delle parti reimportate come stl, poi convertite in solidi e ripulite con lo strumento di Part
body-da-stl.FCStd
(989.39 KiB) Downloaded 15 times
head-da stl.FCStd
(337.25 KiB) Downloaded 13 times
Moebius
Posts: 36
Joined: Tue Feb 09, 2016 3:07 pm

Re: Esportazione STL difettosa

Postby Moebius » Wed May 02, 2018 7:20 am

Grazie Renato.
Hai alzato "CilPerDado di 1 mm. Che sia accettabile o meno, resta il dubbio sulla reale efficacia dell 'analisi forme o del Refine.
Finora, a prova-errore, variando la sequenza taglia/cuci e/o con minimi ritocchi, riesco a ottenere file corretti.
Ma non riesco a capire (o interpretare) dove sono le incongruenze e l'operazione che le ha generate.
L'unica procedura affidabile (spero) che mi funziona è quello di lavorare su oggetti affinati da Part, poi distrutti se corretti.
Ancora grazie
renatorivo
Posts: 2031
Joined: Tue Feb 21, 2012 8:07 pm
Location: Torino - Italy

Re: Esportazione STL difettosa

Postby renatorivo » Wed May 02, 2018 8:45 pm

Moebius wrote:
Wed May 02, 2018 7:20 am
Hai alzato "CilPerDado di 1 mm.
Esatto. Ho visto che l'errore si genera sulle facce e bordi indicati nella figura allegata, e che questi sono prodotti sottraendo CilPerPad", quindi ho provato a sollevarlo di 1mm per vedere se l'errore scompariva, e infatti è scomparso, ma scompare anche sollevandolo di soli 0,01mm.
Osservando e confrontando i due risultati direi che si crea un problema di superfici tangenti, o complanari, che sono due situazioni critiche da evitare.
Sollevando il cilindro si vede un piccolo scalino all'interno.
La cosa anomala che mi sorprende è che nella forma originale gli errori non appaiono, ma appaiono solo nell'oggetto ripulito.
errore-su-head.png
errore-su-head.png (34.92 KiB) Viewed 308 times
Moebius
Posts: 36
Joined: Tue Feb 09, 2016 3:07 pm

Re: Esportazione STL difettosa

Postby Moebius » Thu May 03, 2018 9:20 am

renatorivo wrote:
Wed May 02, 2018 8:45 pm
La cosa anomala che mi sorprende è che nella forma originale gli errori non appaiono, ma appaiono solo nell'oggetto ripulito.
All'apparenza sembra che questa anomalia, controllando gli oggetti rifiniti, possa essere (scomodamente) superata.
Invece qualcosa di anomalo rimane.
Nel file BknHlp.FCStd (post #32), in Head>Cut002024025056 (5° riga) è l'ultimo oggetto che esportato STL e reimportato, analizzato da Mesh non segnala errori.
Il passo successivo, Fusion003004022008 soddisfa il Refine, ma esportato STL e reimportato, all'analisi Mesh presenta errori.
Grazie Renato; che strategia suggerisci?

Edit: a me sembra un problema.
Procedura adottata: Part>Refine - MeshDesign>Crea mesh da solido - Analizza e ripara mesh.
Difettoso?
- si > ripeto con l'oggetto precedente
- no > sposto/modifico l'oggetto aggiunto/tolto nella successiva operazione e ripeto la procedura.
Senonché segnala errori in posizioni che nel gradino precedente (promosso) non esistevano, senza connessioni fra il nuovo oggetto e i punti errati.

OT: MeshDesign> Crea mesh ... "Tessellazione"
renatorivo
Posts: 2031
Joined: Tue Feb 21, 2012 8:07 pm
Location: Torino - Italy

Re: Esportazione STL difettosa

Postby renatorivo » Sat May 05, 2018 7:12 am

Confermo tutti gli errori che hai segnalato, ottengo gli stessi risultati.

Mi pare che gli errori abbiano inizio quando si crea la fusione tra NuovaHead+Extrude043+Corona.
La fusione sembra non avere errori, ma dopo la conversione in stl non è più un solido
mesh-non-solido.png
mesh-non-solido.png (31.11 KiB) Viewed 281 times
E anche la Parte ottenuta non ha errori, ma non è più un solido
parte-non-solida.png
parte-non-solida.png (20.06 KiB) Viewed 281 times
Per ora ho scoperto solo questo

Neppure Mesh->Crea mesh da forma restituisce un solido
Moebius
Posts: 36
Joined: Tue Feb 09, 2016 3:07 pm

Re: Esportazione STL difettosa

Postby Moebius » Sun May 06, 2018 9:03 am

Dunque, non riesco.
Rifatto da zero il progetto, curando di limitare tangenze etc. e "refinando" passo-passo, per la head ho tagliato via la parte difettosa con un cubetto, e mesh e STL non presentano errori.
Per il body ho cercato di agire nello stesso modo, però le criticità sono in una specie di gola che deve in qualche modo accogliere la head.
Succede che se l'asportazione è (relativamente) grande, con Mesh>Mesh_da_solido: Netgen>Fine, ottengo una mesh priva di errori. :P
E da questa posso esportare un STL corretto anche a successiva importazione. Risulta un file circa 10 volte più grande dell'STL ottenuto dal solido.
Ma se riduco il cubo di taglio fino ad avere una tolleranza accettabile (meccanicamente) si ripresentano le maledette "pieghe", che non so bene cosa siano ma le immagino come elementi triangolari con i vertici non coincidenti con i triangoli adiacenti.
A questo punto devo riprendere Head, che è corretto, e adattarlo alle misure accettabili dal body.
Non è una soluzione.

Il mio meglio: http://www.mediafire.com/file/2044tci8c ... n-14.FCStd

Edit: succede anche il contrario, cioè Part rileva errori, ma l'esportazione STL è corretta. E lo è anche la stampa 3D.
Dal numero di servizi che offrono la correzione dei file STL deduco che non è poi così banale :)
Il file Freecad http://www.mediafire.com/file/aam56d8t8 ... igen.FCStd
Image

Image
Moebius
Posts: 36
Joined: Tue Feb 09, 2016 3:07 pm

Re: Esportazione STL difettosa

Postby Moebius » Fri Nov 09, 2018 11:42 am

Aggiorno per segnale una possibile anomalia.
In breve, partendo da un solido senza errori, poi esportato in un file STL e poi reimportato e analizzato nell'ambiente Mesh, presenta errori.
'"Analizza" e "ripara", eseguiti dall'alto al basso o automaticamente, creano zone nere non coerenti.
Però, eseguendo le varie analisi e riparazioni partendo dal basso, le riparazioni funzionano, verificabili con una nuova esportazione e reimportazione.
Mi è chiaro che dipende dal tipo di errore e che questa procedura non funzionerà su un differente progetto.
Grazie a tutti
Il file di base, da esportare e reimportare
Esp71-06.stl
(405.6 KiB) Downloaded 5 times
onekk
Posts: 57
Joined: Sat Jan 17, 2015 7:48 am

Re: Esportazione STL difettosa

Postby onekk » Thu Nov 15, 2018 5:23 pm

Nel testo parlate di OpenSCAD, non è che il problema risiede in quello?

Avendo usato OpenSCAD a volte in file complessi, praticamente a caso, il motore di rendering interno non gestiva correttamente le operazioni di unione o di differenza.

Il problema era abbastanza subdolo, a volte cambiando l'ordine delle operazioni di rotazione o translazione oppure costruendo tutto attorno a 0,0,0 e poi translando solo il risultato finale si ottenevano diversi esiti di solidi uno corretto e l'altro errato.

Saluti

Carlo D.