Is there a way to disable the auto-rotate?

Post here for help on using FreeCAD's graphical user interface (GUI).
Forum rules
and Helpful information
IMPORTANT: Please click here and read this first, before asking for help

Also, be nice to others! Read the FreeCAD code of conduct!
bhs67
Posts: 29
Joined: Wed Jan 28, 2015 9:55 pm

Is there a way to disable the auto-rotate?

Postby bhs67 » Tue Mar 24, 2015 4:57 pm

Sometimes the display starts to rotate on its own (don't know what sequence causes that). Is there a way to disable the auto-rotate?
User avatar
NormandC
Posts: 18534
Joined: Sat Feb 06, 2010 9:52 pm
Location: Québec, Canada

Re: Is there a way to disable the auto-rotate?

Postby NormandC » Tue Mar 24, 2015 5:05 pm

The only way this can happen is when you were just rotating the view and release the mouse button.

Go to Edit --> Preferences / Display / 3D View and uncheck "Enable animation". I believe it should fix it.
bhs67
Posts: 29
Joined: Wed Jan 28, 2015 9:55 pm

Re: Is there a way to disable the auto-rotate?

Postby bhs67 » Tue Mar 24, 2015 6:54 pm

Thanks.
User avatar
flachyjoe
Posts: 631
Joined: Sat Mar 31, 2012 12:00 pm
Location: Limoges, France

Re: Is there a way to disable the auto-rotate?

Postby flachyjoe » Tue Mar 24, 2015 8:57 pm

Thanks too, I nightmared about this feature...
- Flachy Joe -
alias FFW @ irc.freenode.net #freecad et #freecad-fr
"Puisqu’on ne peut changer la direction du vent, il faut apprendre à orienter les voiles." Anonyme
User avatar
OakLD
Posts: 99
Joined: Fri Jan 12, 2018 7:38 pm
Location: Brno

Re: Is there a way to disable the auto-rotate?

Postby OakLD » Tue Jan 30, 2018 11:01 am

Thanks for solution. If our heros developing FreeCAD made a reliable way to stop the auto-rotation, the feature could be OK. But it often times resist any attempts to stop it... So at the moment it's a bit of headache.
Regards,

Oak
chrisb
Posts: 19594
Joined: Tue Mar 17, 2015 9:14 am

Re: Is there a way to disable the auto-rotate?

Postby chrisb » Tue Jan 30, 2018 11:08 am

OakLD wrote:
Tue Jan 30, 2018 11:01 am
at the moment it's a bit of headache.
Which version are you talking about? I hope it's not 0.15 as the necrobumped thread might suggest.
User avatar
OakLD
Posts: 99
Joined: Fri Jan 12, 2018 7:38 pm
Location: Brno

Re: Is there a way to disable the auto-rotate?

Postby OakLD » Tue Jan 30, 2018 1:22 pm

It's 0.16 / 6712. The Pan and Zoom do sometimes the same: Looks like you cannot end the command, but it also may be that in some circumstances it takes a lot of time to quit it... This happens on 2 different computers I used on Windows7 and 10. I had no chance to test it with OpenSUSE Linux I have on my other PC yet.
Regards,

Oak
User avatar
bejant
Posts: 5950
Joined: Thu Jul 11, 2013 3:06 pm

Re: Is there a way to disable the auto-rotate?

Postby bejant » Wed Jan 31, 2018 8:35 pm

OakLD wrote:
Tue Jan 30, 2018 1:22 pm
It's 0.16 / 6712. The Pan and Zoom do sometimes the same: Looks like you cannot end the command,
I use CAD navigation Style, and for me a right-click anywhere in the 3D view terminates Spinning.

OS: Ubuntu 16.04.3 LTS
Word size of OS: 32-bit
Word size of FreeCAD: 32-bit
Version: 0.16.6712 (Git)
Build type: None
Branch: releases/FreeCAD-0-16
Hash: da2d364457257a7a8c6fb2137cea12c45becd71a
Python version: 2.7.12
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17