FreeCAD fail to run after upgrade to 0.17

Post here for help on using FreeCAD's graphical user interface (GUI).
Forum rules
and Helpful information
IMPORTANT: Please click here and read this first, before asking for help

Also, be nice to others! Read the FreeCAD code of conduct!
Taufeeq2
Posts: 18
Joined: Fri Mar 30, 2018 12:39 pm

FreeCAD fail to run after upgrade to 0.17

Postby Taufeeq2 » Fri Jul 20, 2018 2:44 pm

During initialization the error /usr/lib/freecad/lib/libSMESH.so: undefined symbol: _ZN23TCollection_AsciiString4SwapERS_ occurred in /home/nsamba/.FreeCAD/Mod/Cfd/InitGui.py
Please look into the log file for further information
During initialization the error /usr/lib/freecad/lib/libSMESH.so: undefined symbol: _ZN23TCollection_AsciiString4SwapERS_ occurred in /home/nsamba/.FreeCAD/Mod/assembly2/InitGui.py
Please look into the log file for further information
Program received signal SIGSEGV, Segmentation fault.
Segmentation fault
chrisb
Posts: 19476
Joined: Tue Mar 17, 2015 9:14 am

Re: FreeCAD fail to run after upgrade to 0.17

Postby chrisb » Fri Jul 20, 2018 4:32 pm

Please add your FreeCAD info as explained in the IMPORTANT link above. Does the log file give any additional information?

(I moved the topic to the help forum)
chrisb
Posts: 19476
Joined: Tue Mar 17, 2015 9:14 am

Re: FreeCAD fail to run after upgrade to 0.17

Postby chrisb » Fri Jul 20, 2018 4:37 pm

Please avoid double postings. This forum is very active so there is need for additional noise. Find the right forum and post it there.
User avatar
NormandC
Posts: 18534
Joined: Sat Feb 06, 2010 9:52 pm
Location: Québec, Canada

Re: FreeCAD fail to run after upgrade to 0.17

Postby NormandC » Fri Jul 20, 2018 7:19 pm

I think this post is missing context implied in the topic "[0.17 release/0.18 daily/0.16 legacy] Ubuntu PPA users please read this" where it was also posted:

https://forum.freecadweb.org/viewtopic. ... 20#p245573