Sketcher in Edit Mode didn't respect Properties

Post here for help on using FreeCAD's graphical user interface (GUI).
Forum rules
and Helpful information
IMPORTANT: Please click here and read this first, before asking for help

Also, be nice to others! Read the FreeCAD code of conduct!
UR_
Posts: 996
Joined: Tue Jan 03, 2017 8:42 pm

Sketcher in Edit Mode didn't respect Properties

Postby UR_ » Mon Nov 12, 2018 7:45 pm

If one changes one of these properties of a existing sketch:
FreeCAD 0.18-000104.png
FreeCAD 0.18-000104.png (5.69 KiB) Viewed 275 times

Sketcher in Edit mode didn't care about:
FreeCAD 0.18-000105.png
FreeCAD 0.18-000105.png (8.28 KiB) Viewed 275 times

A little bit confusing, especially because "grid snapping" gets active while checkbox shows opposite :?


tested with:
OS: Windows 10
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.15188 (Git)
Build type: Release
Branch: master
Hash: de074ec4f37ee8baf4c268a3bc528f4bddf8ac15
Python version: 3.6.6
Qt version: 5.6.2
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: German/Germany (de_DE)
ulrich1a
Posts: 1883
Joined: Sun Jul 07, 2013 12:08 pm

Re: Sketcher in Edit Mode didn't respect Properties

Postby ulrich1a » Mon Nov 12, 2018 9:24 pm

There is an issue. At testing this, I had a document with two sketches. After activating Grid Snap in both sketches and deactivating it in the second one I got the following situation:
Grid Snap was not checked in both sketches in the edit widget.
Snapping was active in the first sketch.
Snapping was inactive in the second sketch.

So it looks like, that the snapping option is stored per sketch, but the edit mode widget shows something like the preference setting.

Ulrich

OS: Debian GNU/Linux 9.6 (stretch)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.15191 (Git)
Build type: Release
Branch: Rueck6
Hash: 5e3001ae83a4c2e9d6ccb5cf655d53fbd1dcbea8
Python version: 2.7.13
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.2.0
Locale: German/Germany (de_DE)
UR_
Posts: 996
Joined: Tue Jan 03, 2017 8:42 pm

Re: Sketcher in Edit Mode didn't respect Properties

Postby UR_ » Tue Nov 13, 2018 7:40 pm

abdullah wrote:ping
@abdullah
Can you please leave a comment?
abdullah
Posts: 3174
Joined: Sun May 04, 2014 3:16 pm

Re: Sketcher in Edit Mode didn't respect Properties

Postby abdullah » Wed Nov 14, 2018 3:33 am

Changing the property always works and WYSIWYG. The problem is with the edit widget, that the checkbox does not get updated.

It is a very old bug, as I can reproduce it in my vintage version:

OS: Ubuntu 18.04.1 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.6698 (Git)
Build type: Debug
Branch: (no branch, bisect at 4c7a0a140)
Hash: ca7c5d31a4d61f32a25b71025b14641a6e378328
Python version: 2.7.15rc1
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 6.9.1.oce-0.18

I will take a look...
abdullah
Posts: 3174
Joined: Sun May 04, 2014 3:16 pm

Re: Sketcher in Edit Mode didn't respect Properties

Postby abdullah » Wed Nov 14, 2018 3:35 am

wmayer
Site Admin
Posts: 14899
Joined: Thu Feb 19, 2009 10:32 am

Re: Sketcher in Edit Mode didn't respect Properties

Postby wmayer » Wed Nov 14, 2018 10:39 am

The Edit Control panel is the same widget as used in the preferences and its original intention was to restore/save the settings when editing a sketch. But this behaviour is indeed somewhat confusing and also makes it unnecessarily hard to have different settings per-sketch.
wmayer
Site Admin
Posts: 14899
Joined: Thu Feb 19, 2009 10:32 am

Re: Sketcher in Edit Mode didn't respect Properties

Postby wmayer » Wed Nov 14, 2018 11:42 am