[SOLVED] pyrate Installed but Does Not Show up as WB Option

Post here for help on using FreeCAD's graphical user interface (GUI).
Forum rules
and Helpful information
IMPORTANT: Please click here and read this first, before asking for help

Also, be nice to others! Read the FreeCAD code of conduct!
User avatar
NormandC
Posts: 18534
Joined: Sat Feb 06, 2010 9:52 pm
Location: Québec, Canada

Re: [SOLVED] pyrate Installed but Does Not Show up as WB Option

Postby NormandC » Fri Apr 19, 2019 2:39 am

cflin wrote:
Wed Apr 17, 2019 5:27 am
FreeCAD18 (and 17, I guess) is, unfortunately, still based on Python2
That's incorrect. All 0.18.1 binaries provided by the FreeCAD project on Github are now based on Python 3. Only binaries/installers provided by third-party packagers may still be based on Python 2, such as the snap and flatpak packages.

The freecad-stable PPA for Ubuntu provides a dual Python2/3 metapackage; the Python version can easily be switched from a terminal using

Code: Select all

sudo update-alternatives --config freecad
provided you have both freecad-python2 and freecad-python3 packages installed.
cflin
Posts: 50
Joined: Sun May 14, 2017 10:21 pm

Re: [SOLVED] pyrate Installed but Does Not Show up as WB Option

Postby cflin » Fri Apr 19, 2019 3:33 pm

@NormandC: Thank you for all this information!
The freecad-stable PPA for Ubuntu provides a dual Python2/3 metapackage
I don't have the freecad-python3 package installed. apt-get cannot find it, although 'apt-cache policy | grep freecad' lists several repos with 'freecad-stable' in them.
User avatar
NormandC
Posts: 18534
Joined: Sat Feb 06, 2010 9:52 pm
Location: Québec, Canada

Re: [SOLVED] pyrate Installed but Does Not Show up as WB Option

Postby NormandC » Fri Apr 19, 2019 4:55 pm

Deleted irrelevant reply due to ignoring previous information provided in the topic! :oops:
Last edited by NormandC on Fri Apr 19, 2019 7:06 pm, edited 1 time in total.
User avatar
NormandC
Posts: 18534
Joined: Sat Feb 06, 2010 9:52 pm
Location: Québec, Canada

Re: [SOLVED] pyrate Installed but Does Not Show up as WB Option

Postby NormandC » Fri Apr 19, 2019 5:05 pm

I'm sorry, I forgot that you are using Ubuntu 16.04 LTS. It contains a version of Qt5 that's too old to support Pyside2 required to work with Python 3. The Python 2/3 metapackage is only available on Ubuntu 18.04 and onward. The freecad package for 16.04 will remain stuck with Qt4 and Python 2.
cflin
Posts: 50
Joined: Sun May 14, 2017 10:21 pm

Re: [SOLVED] pyrate Installed but Does Not Show up as WB Option

Postby cflin » Fri Apr 19, 2019 6:19 pm

@NormandC:
I'm sorry, I forgot that you are using Ubuntu 16.04 LTS. It contains a version of Qt5 that's too old to support Pyside2 required to work with Python 3.
Thank you again! It seems that anaconda includes Freecad. My anaconda is up to date. So, if I install FreeCAD in the anaconda environment, it should take care of Python 3, since I don't have Python2 installed anywhere under anaconda? Otherwise, I may have to bite the bullet and upgrade to 18.04LTS.
looo
Posts: 2950
Joined: Mon Nov 11, 2013 5:29 pm

Re: [SOLVED] pyrate Installed but Does Not Show up as WB Option

Postby looo » Sat Apr 20, 2019 3:20 am

cflin wrote:
Fri Apr 19, 2019 6:19 pm
So, if I install FreeCAD in the anaconda environment, it should take care of Python 3, since I don't have Python2 installed anywhere under anaconda?
All freecad packages on anaconda are build with python3 and qt5.
please help with my conda-packaging efforts: https://liberapay.com/looooo/