Problem caused by changing workspaces in Ubuntu

Post here for help on using FreeCAD's graphical user interface (GUI).
Forum rules
and Helpful information
IMPORTANT: Please click here and read this first, before asking for help

Also, be nice to others! Read the FreeCAD code of conduct!
scopaev
Posts: 19
Joined: Fri Jun 24, 2011 7:37 pm

Re: Problem caused by changing workspaces in Ubuntu

Postby scopaev » Mon Dec 24, 2012 1:04 am

You guys are brilliant, I tried for 2 weeks to make this thing consistant on multiple pc's and narrow down what was causing this, you guys got it in a few posts! I never realized I had blender nav turned on for all my pc's.

I have confirmed as well that if workscreen is changed using CTRL+ALT+Arrows or ALT+TAB:
When in CAD navigation->No problem.
When in Blender navigation->Main screen locks up.

I have just verified this occurs:
Ubuntu 10.04 x64 (my first PC)
Ubuntu 12.04 x64 (my second PC):
Gnome
Gnome Classic
Gnome Classic (no effects)
Unity
Unity 2D

Anyone else can make this happen?

So exciting!
triplus
Posts: 8676
Joined: Mon Dec 12, 2011 4:45 pm

Re: Problem caused by changing workspaces in Ubuntu

Postby triplus » Mon Dec 24, 2012 3:02 am

This bug report should probably be reopened now that we know this affects only Blender navigation style:

https://sourceforge.net/apps/mantisbt/f ... php?id=911
reprappermc
Posts: 8
Joined: Sun Jan 22, 2012 3:46 am

Re: Problem caused by changing workspaces in Ubuntu

Postby reprappermc » Wed Dec 26, 2012 3:12 am

Woohoo! So, has every one else being using the CAD nav rather than the Blender nav? The Blender nav always seemed quicker to me.
User avatar
NormandC
Posts: 18534
Joined: Sat Feb 06, 2010 9:52 pm
Location: Québec, Canada

Re: Problem caused by changing workspaces in Ubuntu

Postby NormandC » Wed Dec 26, 2012 6:08 am

What do you mean by quicker? I have not noticed a difference.

I use CAD navigation exclusively. 3 years ago Blender navigation did not exist, and Inventor navigation was an impediment to modeling (using Ctrl+click to select disabled multiple selection - this is fixed now). I complained a lot about the difficulty of using middle button + left button to rotate the model in 3D space but I had no choice to get used to it because Inventor nav sucked so much. When they introduced Blender navigation, it was too late for me. :D
wmayer
Site Admin
Posts: 14776
Joined: Thu Feb 19, 2009 10:32 am

Re: Problem caused by changing workspaces in Ubuntu

Postby wmayer » Wed Dec 26, 2012 9:33 am

Thanks for finding this issue. I can confirm this even on my Ubuntu Lucid system. I remember from time to time I had this issue too but was never able to reproduce it. However, it must be caused by something else because I never use CTRL+ALT+Arrow to switch between the work places.
And btw. the CAD navigation style is also affected by this. Though it's still possible to select elements but clicking on an already selected elements toggles the selection instead of selecting the whole part.
wieszak
Posts: 41
Joined: Mon Jun 11, 2012 2:36 pm

Re: Problem caused by changing workspaces in Ubuntu

Postby wieszak » Wed Dec 26, 2012 11:56 am

If it helps: Slackware linux here, switching workspaces with CTRL+Arrow, and sometimes FreeCad then is kinda stuck - for eg. if i just rotatetd view, then switch workspace then if i come back to freecad then view is rotating with mouse move without any key pressed. It sometimes even happen without switching workspaces, but when using sketcher, mostly when leaving sketcher.
jmaustpc
Posts: 9566
Joined: Tue Jul 26, 2011 6:28 am
Location: Australia

Re: Problem caused by changing workspaces in Ubuntu

Postby jmaustpc » Wed Dec 26, 2012 12:37 pm

I can not get it to do anything wrong with CAD or Blender style navigation, but I am using Kubuntu, hence KDE. To shift work spaces my default keyboard short cuts are ctrl F1 and ctrl F2.

Would it be a good idea to get FreeCAD Help About to report the desktop environment being used if on Linux?


OS: Ubuntu 12.04.1 LTS
Platform: 64-bit
Version: 0.13.1797 (Git)
Branch: master
Hash: 6fe43f96265c363bafa049c97806505009e16a86
Python version: 2.7.3
Qt version: 4.8.2
Coin version: 3.1.3
SoQt version: 1.5.0
OCC version: 6.5.0


Jim
triplus
Posts: 8676
Joined: Mon Dec 12, 2011 4:45 pm

Re: Problem caused by changing workspaces in Ubuntu

Postby triplus » Wed Dec 26, 2012 2:38 pm

To shift work spaces my default keyboard short cuts are ctrl F1 and ctrl F2.
Yes but if you would use modifier keys (CTRL + ALT + arrow keys) you would probably have the same problem. I tested KDE and it had the same problem but when i temporary changed keyboard shortcut to something else i didn't have the problem anymore. You probably still have the problem or if u just use arrow keys to move the part and blender navigation is enabled then you can reproduce this problem?

P.S. I use blender navigation because it just feels right and that middle+left click to rotate in CAD navigation is just off.
scopaev
Posts: 19
Joined: Fri Jun 24, 2011 7:37 pm

Re: Problem caused by changing workspaces in Ubuntu

Postby scopaev » Wed Dec 26, 2012 5:40 pm

triplus wrote:This bug report should probably be reopened now that we know this affects only Blender navigation style:

https://sourceforge.net/apps/mantisbt/f ... php?id=911
Reopened :)
jmaustpc
Posts: 9566
Joined: Tue Jul 26, 2011 6:28 am
Location: Australia

Re: Problem caused by changing workspaces in Ubuntu

Postby jmaustpc » Thu Dec 27, 2012 7:13 am

I have two monitors and I almost never use different work spaces. When I have, I have used the mouse to switch between them, So I followed the key combinations stated here, they had no effect on FreeCAD or KDE, so I looked up my system settings to see what my keyboard short cuts are, I have never changed them, they are just the Kubuntu defaults. You may be correct in that if I changed the key combinations then perhaps the problem would come up. I suppose it may be possible that my dual monitor set up may be effecting this, or maybe not.