Getting cfdof to run in 0.18

Post here for help on using FreeCAD's graphical user interface (GUI).
Forum rules
and Helpful information
IMPORTANT: Please click here and read this first, before asking for help

Also, be nice to others! Read the FreeCAD code of conduct!
jgegas
Posts: 1
Joined: Sat Apr 27, 2019 6:54 am

Getting cfdof to run in 0.18

Postby jgegas » Sat Apr 27, 2019 7:16 am

Hello. I'm having some problems to get cfdof workbench running in 0.18 version. Just installed Ubuntu 18.04 and FreeCAD 0.18 from the synaptic software manager. I also installed gmsh and openfoam5 from the same package manager. Installed the workbench from the add-on manager. My FreeCAD is:

OS: Linux
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.16093 (Git)
Build type: Unknown
Branch: master
Hash: 690774c0effe4fd7b8d2b5e2fb2b8c8d145e21ce
Python version: 2.7.12
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.0.0
Locale: English/UnitedStates (en_US)

When I "Run dependency checker" from the Edit->Preferences->CFD menu, I get:

Checking dependencies...
Could not find OpenFOAM installation: The directory /opt/openfoam5 is not a valid OpenFOAM installation
gmsh is not installed

I'm pretty sure gmsh is installed, and also very sure /opt/openfoam5 is the correct openfoam installation folder.

When I execute the 0.19 version, and Run dependency checker, It says that the Plot workbench could not be loaded, but does not complain about gmsh or openfoam.

Anny idea will be much appreciated.

Regards.