Python error, cannot load Addon Manager

Post here for help on using FreeCAD's graphical user interface (GUI).
Forum rules
and Helpful information
IMPORTANT: Please click here and read this first, before asking for help

Also, be nice to others! Read the FreeCAD code of conduct!
Will2
Posts: 26
Joined: Thu Apr 28, 2016 3:19 pm

Python error, cannot load Addon Manager

Postby Will2 » Sat Apr 27, 2019 4:22 pm

I found a solution from someone who is having the same problem and I am but I'm not sure how to implement the solution and really don't want to break things. The thread was found here: https://forum.freecadweb.org/viewtopic.php?t=33429

The solution involves deleting some local python packages but I'm not sure which ones and how I should go about it (apt remove?)

This is what I get when I start FreeCAD:

Code: Select all

© Juergen Riegel, Werner Mayer, Yorik van Havre 2001-2019
  #####                 ####  ###   ####  
  #                    #      # #   #   # 
  #     ##  #### ####  #     #   #  #   # 
  ####  # # #  # #  #  #     #####  #   # 
  #     #   #### ####  #    #     # #   # 
  #     #   #    #     #    #     # #   #  ##  ##  ##
  #     #   #### ####   ### #     # ####   ##  ##  ##

During initialization the error /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.11' not found (required by /home/will/.local/lib/python2.7/site-packages/PySide2/QtCore.so) occurred in /usr/share/freecad/Mod/Ship/InitGui.py
Please look into the log file for further information
During initialization the error /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.11' not found (required by /home/will/.local/lib/python2.7/site-packages/PySide2/QtCore.so) occurred in /usr/share/freecad/Mod/Plot/InitGui.py
Please look into the log file for further information
During initialization the error /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.11' not found (required by /home/will/.local/lib/python2.7/site-packages/PySide2/QtGui.so) occurred in /home/will/.FreeCAD/Mod/Manipulator/InitGui.py
Please look into the log file for further information
During initialization the error /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.11' not found (required by /home/will/.local/lib/python2.7/site-packages/PySide2/QtCore.so) occurred in /usr/share/freecad/Mod/Draft/InitGui.py
Please look into the log file for further information
During initialization the error /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.11' not found (required by /home/will/.local/lib/python2.7/site-packages/PySide2/QtCore.so) occurred in /usr/share/freecad/Mod/Tux/InitGui.py
Please look into the log file for further information
During initialization the error /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.11' not found (required by /home/will/.local/lib/python2.7/site-packages/PySide2/QtCore.so) occurred in /usr/share/freecad/Mod/Arch/InitGui.py
Please look into the log file for further information
And this is what I get when I try and run the addon manager:

Code: Select all

Running the Python command 'Std_AddonMgr' failed:
Traceback (most recent call last):
  File "/usr/share/freecad/Mod/AddonManager/AddonManagerGui.py", line 10, in Activated
    import AddonManager
  File "/usr/share/freecad/Mod/AddonManager/AddonManager.py", line 46, in <module>
    from PySide import QtCore, QtGui
  File "/usr/share/freecad/Ext/PySide/QtCore.py", line 1, in <module>
    from PySide2.QtCore import *

/usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.11' not found (required by /home/will/.local/lib/python2.7/site-packages/PySide2/QtCore.so)
OS: Ubuntu 18.04.2 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.1.
Build type: Release
Python version: 2.7.15rc1
Qt version: 5.9.5
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/Canada (en_CA)