Hiding body axes/planes by default.

Post here for help on using FreeCAD's graphical user interface (GUI).
Forum rules
and Helpful information
IMPORTANT: Please click here and read this first, before asking for help

Also, be nice to others! Read the FreeCAD code of conduct!
jruiz
Posts: 95
Joined: Tue Oct 28, 2014 1:07 pm

Hiding body axes/planes by default.

Postby jruiz » Thu Aug 29, 2019 12:03 pm

When sketching, what have to be done for the body axes/planes be hidden by default?
User avatar
papyblaise
Posts: 659
Joined: Thu Jun 13, 2019 4:28 pm
Location: France

Re: Hiding body axes/planes by default.

Postby papyblaise » Thu Aug 29, 2019 12:12 pm

Hello
:?: :?: X, Y ,Z they are hide by default :!:
If you said about the red ligne and the green ligne on the midle of the screen , ho do you do and where your sketch , and constraint it :?: :?:
jruiz
Posts: 95
Joined: Tue Oct 28, 2014 1:07 pm

Re: Hiding body axes/planes by default.

Postby jruiz » Thu Aug 29, 2019 12:18 pm

I am talking about the blue lines/letters shown in the attached image.
Attachments
planeAndAxis.png
planeAndAxis.png (138.5 KiB) Viewed 852 times
User avatar
papyblaise
Posts: 659
Joined: Thu Jun 13, 2019 4:28 pm
Location: France

Re: Hiding body axes/planes by default.

Postby papyblaise » Thu Aug 29, 2019 12:25 pm

Ha Ok , Sorry
Just clik on Origin , and Space barr
if you need hiden XYZ clik "affichage /Axes de coordonnées (word in french) I don't know in englich
Edit
I see on your captur the word is "View
Attachments
axes.PNG
axes.PNG (69.91 KiB) Viewed 850 times
jruiz
Posts: 95
Joined: Tue Oct 28, 2014 1:07 pm

Re: Hiding body axes/planes by default.

Postby jruiz » Thu Aug 29, 2019 12:45 pm

Well, what I want is to have the option for planes/axes to be hidden (or shown) by default when entering into sketching.
Maybe it could be a Feature request...
jruiz
Posts: 95
Joined: Tue Oct 28, 2014 1:07 pm

Re: Hiding body axes/planes by default.

Postby jruiz » Thu Aug 29, 2019 12:56 pm

kisolre
Posts: 1360
Joined: Wed Nov 21, 2018 1:13 pm

Re: Hiding body axes/planes by default.

Postby kisolre » Thu Aug 29, 2019 1:54 pm

They are hidden by default and only show when a new sketch is created to select on which plane to map it. Then when sketch editing mode is entered they are hidden again. They stay visible only if YOU make them. Since you showed them how should FreeCAD know when you want them hidden and when not?
freedman
Posts: 996
Joined: Thu Mar 22, 2018 3:02 am
Location: Washington State, USA

Re: Hiding body axes/planes by default.

Postby freedman » Thu Aug 29, 2019 5:05 pm

Maybe this answers it; go to the tree and select the individual origins and hit spacebar. All the origins can be controlled if the Origin header is hidden or shown.