Part->Chamfer does not work

Post here for help on using FreeCAD's graphical user interface (GUI).
Forum rules
and Helpful information
IMPORTANT: Please click here and read this first, before asking for help

Also, be nice to others! Read the FreeCAD code of conduct!
koluna
Posts: 259
Joined: Thu Sep 20, 2018 12:36 pm

Re: Part->Chamfer does not work

Postby koluna » Thu Oct 10, 2019 7:49 pm

I took your SVG. The Sweep tool works. But the result is wrong...
What Sketch did you use to form a shape for Sweep using?
Attachments
raty.FCStd
(261.31 KiB) Downloaded 8 times
koluna
Posts: 259
Joined: Thu Sep 20, 2018 12:36 pm

Re: Part->Chamfer does not work

Postby koluna » Fri Oct 11, 2019 7:54 am

pl7i92LCNC wrote:
Thu Oct 10, 2019 5:44 pm
if yes it is your svg generation on inkscape
use normal svg and 96DPI
What did you mean?
Where are these settings?

It is awful, terrible and horrible... :(
Anybody, please, try a Sweep tool in my file: path3384 (or Sketch) and Sketch001.
I simplified my path and it does not work again... :(((((((((((((((((((((((((((((((((((((((((((
I use Inkscape 0.91.
Attachments
1-0.png
1-0.png (50.9 KiB) Viewed 226 times
koluna
Posts: 259
Joined: Thu Sep 20, 2018 12:36 pm

Re: Part->Chamfer does not work

Postby koluna » Fri Oct 11, 2019 8:18 am

FreeCAD_0.19-18403-Linux-Conda_Py3Qt5_glibc2.12-x86_64.AppImage also crashes...
chrisb
Posts: 19749
Joined: Tue Mar 17, 2015 9:14 am

Re: Part->Chamfer does not work

Postby chrisb » Fri Oct 11, 2019 8:46 am

koluna wrote:
Fri Oct 11, 2019 7:54 am
I simplified my path and it does not work again... :(((((((((((((((((((((((((((((((((((((((((((
If you have simplified the path please upload the file again.
koluna
Posts: 259
Joined: Thu Sep 20, 2018 12:36 pm

Re: Part->Chamfer does not work

Postby koluna » Fri Oct 11, 2019 9:00 am

chrisb wrote:
Fri Oct 11, 2019 8:46 am
If you have simplified the path please upload the file again.
Sure...
I am sorry, my brain is burnt...
Attachments
3.FCStd
(294.7 KiB) Downloaded 7 times
chrisb
Posts: 19749
Joined: Tue Mar 17, 2015 9:14 am

Re: Part->Chamfer does not work

Postby chrisb » Fri Oct 11, 2019 4:29 pm

The crash happens on the first sharp right bend if going from the section to the left. My guess is, that the path segments are very slightly non tangential and that this causes problems. Have you tried converting the path into a sketch?
koluna
Posts: 259
Joined: Thu Sep 20, 2018 12:36 pm

Re: Part->Chamfer does not work

Postby koluna » Fri Oct 11, 2019 6:20 pm

chrisb wrote:
Fri Oct 11, 2019 4:29 pm
The crash hapens on the first sharp right bend if going from the section to the left. My guess is, that the path segments are very slightly non tangential and that this causes problems.
Did you mean a selected segment of the path (path3384 or Sketch) on an attached screenshot?
Have you tried converting the path into a sketch?
Yes, I have. It is "Sketch" in my file. I used it with a Sweep tool. I had a same result...
Attachments
drawing.svg
(8.66 KiB) Downloaded 4 times
User avatar
pl7i92LCNC
Posts: 209
Joined: Tue Mar 12, 2019 3:03 pm
Location: RLP DE

Re: Part->Chamfer does not work

Postby pl7i92LCNC » Fri Oct 11, 2019 6:36 pm

i will make you a video
it is 10min to the print in Blender FROM WWW image grap
no problem with path sweep or .....

this kind of work is not on FreeCAD

thats why we got multiple systems for CAD/Nurb/svg/png/dxf
0_dino_color.png
0_dino_color.png (58.88 KiB) Viewed 178 times
Bildschirmfoto von 2019-10-11 20-34-47.png
Bildschirmfoto von 2019-10-11 20-34-47.png (504.38 KiB) Viewed 178 times
koluna
Posts: 259
Joined: Thu Sep 20, 2018 12:36 pm

Re: Part->Chamfer does not work

Postby koluna » Fri Oct 11, 2019 6:55 pm

I will be very glad for your manual, thanks :)
It seems, it will need to study Blender or something like one...
I wanted to use only FC, but I already use Inkscape :lol:
User avatar
pl7i92LCNC
Posts: 209
Joined: Tue Mar 12, 2019 3:03 pm
Location: RLP DE

Re: Part->Chamfer does not work

Postby pl7i92LCNC » Fri Oct 11, 2019 7:37 pm

the importent one is gimp
to offset the shape
in inkscape
you need to tweaken also the settings on Bitmap Vectorising
there are options on the Reiter
as pixel limits from 2->4
the shape precision to be svg from 0,6 to 1or even 1,2
there is another option that gives you the toleranz from 0,2 set it to 0,6

i guss you already did get the selection on png load to get smooth corners

there is lots to do bevor Fc or Blender that makes live very easy
0_ink.jpg
0_ink.jpg (35.34 KiB) Viewed 168 times
i atached all files for tutorial A
the blend file is to big to be atached
dino_tutorial_A.zip
(196.6 KiB) Downloaded 8 times