Part->Chamfer does not work

Post here for help on using FreeCAD's graphical user interface (GUI).
Forum rules
and Helpful information
IMPORTANT: Please click here and read this first, before asking for help

Also, be nice to others! Read the FreeCAD code of conduct!
koluna
Posts: 273
Joined: Thu Sep 20, 2018 12:36 pm

Re: Part->Chamfer does not work

Postby koluna » Wed Oct 09, 2019 7:58 pm

kisolre wrote:
Wed Oct 09, 2019 6:34 pm
See the selfintersection here:
Check this thread for some explanation https://forum.freecadweb.org/viewtopic.php?f=3&t=39874
Thanks. I will study your link.
I converted my contour to Sketch (with a tool of Draft) and deleted some self-intersection (they were!).
Further, I tried to use Part Sweep with this edited Sketch. FC crashed...
Further, I tried to convert Sketch to Draft (Sketch002) and tried to use Part Sweep with this path. FC crashed...
I checked my paths and did not find out any intersection, but FC crashes...
Attachments
3.FCStd
(309.99 KiB) Downloaded 11 times
kisolre
Posts: 2257
Joined: Wed Nov 21, 2018 1:13 pm

Re: Part->Chamfer does not work

Postby kisolre » Wed Oct 09, 2019 8:50 pm

You missed the point. Selfintersection is not inside the sketch but in the resulting sweep geometry. This happens with tight internal arcs and long internal sections of the sweep profile.
koluna
Posts: 273
Joined: Thu Sep 20, 2018 12:36 pm

Re: Part->Chamfer does not work

Postby koluna » Wed Oct 09, 2019 10:08 pm

kisolre wrote:
Wed Oct 09, 2019 8:50 pm
You missed the point. Selfintersection is not inside the sketch but in the resulting sweep geometry. This happens with tight internal arcs and long internal sections of the sweep profile.
I reduce the bottom edge in Sketch001. FC crashes...
I deleted sharp corners at feet and tried again. FC crashes...
Where are they?
I cannot find out they.

I loaded an 0.19 appimage, but it does not run...
koluna
Posts: 273
Joined: Thu Sep 20, 2018 12:36 pm

Re: Part->Chamfer does not work

Postby koluna » Wed Oct 09, 2019 10:10 pm

pl7i92LCNC wrote:
Wed Oct 09, 2019 7:21 pm
the path has lots of intersection
jo can see it on the GREEN lines that are very tight at this intersections
need manuell tweeking
I did not understand how I can see them...
koluna
Posts: 273
Joined: Thu Sep 20, 2018 12:36 pm

Re: Part->Chamfer does not work

Postby koluna » Wed Oct 09, 2019 10:15 pm

pl7i92LCNC wrote:
Wed Oct 09, 2019 3:58 pm
no it is FreeCAD
i added the Cutter File
FC_cutter.jpg
FC_cuter.FCStd
Does Sweep have a wrong geometry?
It has some self-intersection.
Why does it work for you and it does not work for me?
Attachments
1-0.png
1-0.png (30.6 KiB) Viewed 340 times
User avatar
pl7i92LCNC
Posts: 209
Joined: Tue Mar 12, 2019 3:03 pm
Location: RLP DE

Re: Part->Chamfer does not work

Postby pl7i92LCNC » Thu Oct 10, 2019 9:14 am

its all about the SVG
you need to get better path from inkscape
or even a higher reulutionfrom GIMP
i do(DID till im Fierd) lots of stuff every day on this and the image is the GOAL to get best parts
http://schwedenfeuer.de/feuersauelen.htm SCROLL DOWN all from a image to CUTTER
rat_FC_cutter.jpg
rat_FC_cutter.jpg (46.73 KiB) Viewed 315 times
a "cleaner" path use import to get it hooked up
the FC file is to large to be uploaded
mouce_sockel_curve.svg
(3.42 KiB) Downloaded 13 times
koluna
Posts: 273
Joined: Thu Sep 20, 2018 12:36 pm

Re: Part->Chamfer does not work

Postby koluna » Thu Oct 10, 2019 12:44 pm

Ok. Let's guess that Sweep worked out. It is ok.
What should I do with self-intersections after Sweep working?
User avatar
pl7i92LCNC
Posts: 209
Joined: Tue Mar 12, 2019 3:03 pm
Location: RLP DE

Re: Part->Chamfer does not work

Postby pl7i92LCNC » Thu Oct 10, 2019 1:07 pm

tweek the path
first make it a Sketch with DRAFT BLUE/RED icon
then in sketcher see the problem the RIGHT massiv green there are 2 points move them outwards
bspline_prob.jpg
bspline_prob.jpg (133.52 KiB) Viewed 300 times
BUT you will not see this at all as the MAIN Image is right look here Video at 1:50 cleaning the Image for Path
phpBB [video]
koluna
Posts: 273
Joined: Thu Sep 20, 2018 12:36 pm

Re: Part->Chamfer does not work

Postby koluna » Thu Oct 10, 2019 1:54 pm

You speak about a self-intersection in Path (Sketch). Am I right? I corrected it.
I asked about a self-intersection in a result geometry that is got after the Sweep tool.
I am sorry if I did not understand you...
Attachments
1-0.svg
(44.46 KiB) Downloaded 8 times
User avatar
pl7i92LCNC
Posts: 209
Joined: Tue Mar 12, 2019 3:03 pm
Location: RLP DE

Re: Part->Chamfer does not work

Postby pl7i92LCNC » Thu Oct 10, 2019 5:44 pm

did you try my last uploaded svg and got a sweep out of it
if yes it is your svg generation on inkscape
use normal svg and 96DPI

if you cand got a sweep it may be a problem on FC version