GUI font size

Post here for help on using FreeCAD's graphical user interface (GUI).
Forum rules
and Helpful information
IMPORTANT: Please click here and read this first, before asking for help

Also, be nice to others! Read the FreeCAD code of conduct!
JohannAFannberg
Posts: 2
Joined: Fri Dec 13, 2019 3:34 pm

GUI font size

Postby JohannAFannberg » Fri Dec 13, 2019 3:48 pm

OS: Windows 10 (10.0)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.18944 (Git)
Build type: Release
Branch: master
Hash: 2c0daad48f090ea003b0ef627765f09b6424e94d
Python version: 3.7.3
Qt version: 5.12.5
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: Icelandic/Iceland (is_IS)

Hello, I have been using development versions for a while, but I think this is an issue that has a history beyond that.
My situation is that I am running FreeCAD on a 15" laptop with a 4k display. Fair enough, but now I added a 3k 27" display. Looks very promising, but some fonts are just so small that they are unreadable. This is true for menu items like the panels in "edit Preferences" and workbench names in the workbench drop-down menu. Items in the tree-view panels are small but well readable, good, as they don't squander valuable real estate, but the tab-names in the same panel (model/tasks) are just unreadable.
please inform, where can I change these font sizes?

Johann A. Fannberg.
JohannAFannberg
Posts: 2
Joined: Fri Dec 13, 2019 3:34 pm

Re: GUI font size

Postby JohannAFannberg » Mon Dec 16, 2019 2:56 pm

Hello, luckily the issue resolved by itself. May have been restarting Freecad that solved the issue, anyhow, now the GUI is all readable - and display-area is used efficiently.

It was really frustrating while it lasted. Being able to resize GUI fonts would be valuable, but then there are some complications: screen dpi may vary on different displays in the same setup, as in my case.

I sometimes have two or more Freecad instances running concurrently for reference. Sure you could argue that this w+should be unnecessary as you can open more models in one instance, but this becomes problematic when the sidebar becomes over-crowded.

The displays might be at different dpi-density (as in my case). One way might be if the font-size would be an item in the style-sheet, then one could change style-sheets for the instance depending on the display dpi-density.

Anyhow, this is not a big issue right now for me - however long that lasts. Thank you for a great - and improving project,

Johann.
openBrain
Posts: 4473
Joined: Fri Nov 09, 2018 5:38 pm

Re: GUI font size

Postby openBrain » Mon Dec 16, 2019 3:07 pm

The problem here is that FreeCAD relies on Qt for the GUI low-level management. ;)
Thus there is nothing much to be done at FC level.
chrisb
Posts: 25799
Joined: Tue Mar 17, 2015 9:14 am

Re: GUI font size

Postby chrisb » Mon Dec 16, 2019 4:12 pm

FreeCAD uses the system font. You may try changing that.
castamos
Posts: 1
Joined: Tue Feb 04, 2020 1:34 am

Re: GUI font size

Postby castamos » Tue Feb 04, 2020 1:41 am

Hi I had this problem on Windows 10 with FreeCAD 0.18.

These steps fixed the problem for me:

1. Close FreeCAD
2. Right click on the desktop shortcut for FreeCAD
3. Properties
4. Go to "Compatibility" tab
5. "Change high DPI settings"
6. Enable the option "Use this setting to fix scaling problems for this program instead of the one in Settings"
7. Click OK to close dialogs
8. Launch FreeCAD again (from the shortcut)
chrisb
Posts: 25799
Joined: Tue Mar 17, 2015 9:14 am

Re: GUI font size

Postby chrisb » Tue Feb 04, 2020 8:04 am

I added this to the Known OS specific issues in the Windows section.
Mercury23
Posts: 3
Joined: Sun Mar 29, 2020 3:42 am

Re: GUI font size

Postby Mercury23 » Fri Apr 17, 2020 4:20 am

I had the same problem with both FreeCAD 0.18.4 and pre-release 0.19.20209. This, I think followed an upgrade to Win10 version 1909. I fixed it by adjusting the "Advanced scaling settings" to turn off "Let Windows try to fix apps so they're not blurry" in the Display part of Windows settings.
Reference https://support.microsoft.com/en-us/hel ... lurry-apps, "If you have Windows 10 (version 1903) installed, the setting to fix blurry apps is turned on by default. However, you can turn it off at any time. The notification to fix blurry apps depends on the app and might still appear."

OS: Windows 10
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.4 (GitTag)
Build type: Release
Branch: releases/FreeCAD-0-18
Hash: 980bf9060e28555fecd9e3462f68ca74007b70f8
Python version: 3.6.6
Qt version: 5.6.2
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/UnitedKingdom (en_GB)
User avatar
iplayfast
Posts: 119
Joined: Sat Sep 07, 2019 6:55 am

Re: GUI font size

Postby iplayfast » Tue Apr 28, 2020 6:30 am

The menu fonts on my screen are tiny. (4k tv). It does not follow the system fonts, as those have been adjusted and are not tiny. I've got my editor text size to 17, which is acceptable, but all the dialog text and menu text does not change. My system settings have a font scaling factor of 1.2 which works well for most programs.

If I change the font scaling to 1.5 the menu fonts change. 1.0 to 1.4 makes no change, so it appears that the menu fonts made qt with can be scaled, just grossly, and not in sync with other programs, and also some fonts end up being to big for the dialog. ("close without saving?" dialog for example).

My fix is to turn off auto scaling (since qt seems to be crap) and set the scale manually.
I have a script called freecad which sets the variables and calls freecad_ which points to the appimage I'm currently using.

Code: Select all

exec=/usr/bin/env QT_AUTO_SCREEN_SCALE_FACTOR=0 QT_SCALE_FACTOR=1.7 ~/bin/freecad_
Seems to work for me
OS: Linux Mint 19.3 (X-Cinnamon/cinnamon)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.20802 (Git) AppImage
Build type: Release
Branch: master
Hash: f4279f1bea8377a7ef63f7f4c69b67159d498965
Python version: 3.8.2
Qt version: 5.12.5
Coin version: 4.0.0
OCC version: 7.4.0
Locale: English/Canada (en_CA)
User avatar
vanuan
Posts: 179
Joined: Wed Oct 24, 2018 9:49 pm

Re: GUI font size

Postby vanuan » Sun Jul 19, 2020 11:36 am

iplayfast wrote:
Tue Apr 28, 2020 6:30 am
My fix is to turn off auto scaling (since qt seems to be crap) and set the scale manually.
I have a script called freecad which sets the variables and calls freecad_ which points to the appimage I'm currently using.

Code: Select all

exec=/usr/bin/env QT_AUTO_SCREEN_SCALE_FACTOR=0 QT_SCALE_FACTOR=1.7 ~/bin/freecad_
What you're essentially doing is ignoring your OS settings and using Qt's "scale" functionality. This would mean that graphics would be blurry/pixelized.

Try increasing your scale factor in Cinnamon. Check results with xrdb -query. A rule of the thumb is cursor size of 24px means 100% scaling (i.e. everything is small).
User avatar
vanuan
Posts: 179
Joined: Wed Oct 24, 2018 9:49 pm

Re: GUI font size

Postby vanuan » Sun Jul 19, 2020 11:44 am

Let's create a wiki page describing the basics of HiDPI.