Errors on startup

Post here for help on using FreeCAD's graphical user interface (GUI).
Forum rules
and Helpful information
IMPORTANT: Please click here and read this first, before asking for help

Also, be nice to others! Read the FreeCAD code of conduct!
realthunder
Posts: 1759
Joined: Tue Jan 03, 2017 10:55 am

Re: Errors on startup

Postby realthunder » Fri Jan 31, 2020 9:27 am

looo wrote:
Wed Jan 29, 2020 2:53 pm
PMac wrote:
Tue Jan 28, 2020 7:35 pm
From GUI and also from terminal - both start ups reach splash screen, appearing to be a normal process and then spend 3-4 mins doing a memory swap with RAM and the HDD till FC crashes.
Can you provide more feedback? Maybe @realthunder can join this discussion. Is there a known problem with asm3 and current master?
Just tried 19405 conda image on my computer. Similar warning, but not the crash. I am not aware of this problem. How many people having this problem?
Try Assembly3 (latest version 0.11) along with my custom build of FreeCAD at here.
And if you'd like to show your support, you can donate through patreon, liberapay, or paypal
nic
Posts: 79
Joined: Thu Apr 18, 2019 1:14 pm
Location: France

Re: Errors on startup

Postby nic » Fri Jan 31, 2020 10:12 am

Just tried 19405, same warnings, no crash

edit: version

FreeCAD_0.19-19405-Linux-Conda_Py3Qt5_glibc2.12-x86_64.AppImage

Code: Select all

OS: Ubuntu 19.10 (GNOME-Flashback:GNOME/regolith)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.19405 (Git) AppImage
Build type: Release
Branch: master
Hash: d2b943e8b7d8fe2673a4e20671b6cb0f8180fdbd
Python version: 3.8.1
Qt version: 5.12.5
Coin version: 4.0.0
OCC version: 7.4.0
Locale: French/France (fr_FR)
PMac
Posts: 76
Joined: Sat Sep 02, 2017 10:44 pm

Re: Errors on startup

Postby PMac » Fri Jan 31, 2020 9:32 pm

realthunder wrote:
Fri Jan 31, 2020 9:27 am
looo wrote:
Wed Jan 29, 2020 2:53 pm
PMac wrote:
Tue Jan 28, 2020 7:35 pm
From GUI and also from terminal - both start ups reach splash screen, appearing to be a normal process and then spend 3-4 mins doing a memory swap with RAM and the HDD till FC crashes.
Can you provide more feedback? Maybe @realthunder can join this discussion. Is there a known problem with asm3 and current master?
Just tried 19405 conda image on my computer. Similar warning, but not the crash. I am not aware of this problem. How many people having this problem?
Have been further investigating this 0.19-19405 start-up issue.
As I live on a knife edge with monthly data download allowances, all my downloaded v0.19 updates to date have been incremental updates via AppImage / Zsync updates.
However today with a new month and a brand new data allowance, I've downloaded the full 423MB AppImage.
Now this full version of 19405 does startup to full GUI but with the same errors most submitters are reporting in this thread. Have not tested further.

However the incrementally updated version via zsync (I've even done it multiple times from v19371 to confirm) does continue to crash at start-up reported by me. (and Genues in the related Install/Compile thread)

There seems to be a difference between the resultant image from an incremental update from 371 vs a full 0.19-19405 AppImage. That's why I've not been getting the specified errors but like Genues crashing through screen freeze / memory swap instead.

As an aside I did note from logging a 19405 console start that asm3 reports it does not have an init module whatever that means




Hope this helps.
adrianinsaval
Posts: 344
Joined: Thu Apr 05, 2018 5:15 pm

Re: Errors on startup

Postby adrianinsaval » Sat Feb 01, 2020 10:52 pm

I get this and then it crashes:
/tmp/.mount_FreeCA0tIVs3/AppRun: línea 19: 11376 Instrucción ilegal (`core' generado) ${HERE}/usr/bin/freecad "$@"
the log stops after:
Log: Init: Initializing freecad.asm3
Running 19405 appimage in manjaro kde. No incremental update done, I just downloaded the whole thing and it crashes all the same. Where can I download the previous appimage?
triplus
Posts: 9475
Joined: Mon Dec 12, 2011 4:45 pm

Re: Errors on startup

Postby triplus » Sat Feb 01, 2020 11:09 pm

Hi @adrianinsaval

We had a similar discussion in this thread:

https://forum.freecadweb.org/viewtopic.php?f=4&t=42860

And are now trying to determine, on why is the inclusion of Assembly 3 module is causing issues for some people. Could you make sure and download the AppImage again:

https://github.com/FreeCAD/FreeCAD/rele ... g/0.19_pre

As the name could be the same, but the downloaded version might not include the latest changes. If the issue will persist, can you extract the AppImage by issuing:

Code: Select all

./FreeCAD.AppImage --appimage-extract
./squashfs-root/AppRun
Any changes?
adrianinsaval
Posts: 344
Joined: Thu Apr 05, 2018 5:15 pm

Re: Errors on startup

Postby adrianinsaval » Tue Feb 04, 2020 12:09 am

triplus wrote:
Sat Feb 01, 2020 11:09 pm
Any changes?
Well, not 19405 anymore but the new appimage works!
triplus
Posts: 9475
Joined: Mon Dec 12, 2011 4:45 pm

Re: Errors on startup

Postby triplus » Tue Feb 04, 2020 12:16 am

Thanks for the feedback and good to hear that.
reox
Posts: 882
Joined: Sat Aug 13, 2016 10:06 am
Contact:

Re: Errors on startup

Postby reox » Sun Apr 05, 2020 11:42 am

There are much more of the SyntaxWarnings.
But I have not found a good way to find them statically in the code. Does anyone know a method for that? I tried it with pylint but it looks like you can not find them that way.
With a static code analyzer it would probably be very easy to find all those warnings and resolve them.
PMac
Posts: 76
Joined: Sat Sep 02, 2017 10:44 pm

Re: Errors on startup

Postby PMac » Tue Apr 07, 2020 4:54 pm

reox wrote:
Sun Apr 05, 2020 11:42 am
There are much more of the SyntaxWarnings.
But I have not found a good way to find them statically in the code. Does anyone know a method for that? I tried it with pylint but it looks like you can not find them that way.
With a static code analyzer it would probably be very easy to find all those warnings and resolve them.
Hi Reox, Not sure if your post was meant for this thread. Way beyond my initial reported fault as I'm not compiling locally. Maybe someone else could help?
fc_tofu
Posts: 654
Joined: Sun Jan 05, 2020 4:56 pm

Re: Errors on startup

Postby fc_tofu » Tue Apr 07, 2020 5:15 pm

chrisb wrote:
Tue Jan 28, 2020 6:45 pm
Just installed a new 0.19. On startup I get the following error message in report view:
On latest downloaded build with default config, error msg shows on every startup.
Assembly 3 WB doesnot show on Workbench menu as former build.
This error ms tells something about Asm3, but I donnot understand.

Code: Select all

During initialization the error "

IMPORTANT: PLEASE READ THIS FOR ADVICE ON HOW TO SOLVE THIS ISSUE!

Importing the numpy c-extensions failed.
- Try uninstalling and reinstalling numpy.
- If you have already done that, then:
  1. Check that you expected to use Python3.8 from "e:\WINAPP_B\FreeCAD_0.19.20415-Win-Conda_vc14.x-x86_64\bin\freecad.exe",
     and that you have no directories in your PATH or PYTHONPATH that can
     interfere with the Python and numpy version "1.18.1" you're trying to use.
  2. If (1) looks fine, you can open a new issue at
     https://github.com/numpy/numpy/issues.  Please include details on:
     - how you installed Python
     - how you installed numpy
     - your operating system
     - whether or not you have multiple versions of Python installed
     - if you built from source, your compiler versions and ideally a build log

- If you're working with a numpy git repository, try `git clean -xdf`
  (removes all files not under version control) and rebuild numpy.

Note: this error has many possible causes, so please don't comment on
an existing issue about this - open a new one instead.

Original error was: DLL load failed while importing _multiarray_umath: 找不到指定的模块。
" occurred in freecad.asm3
--------------------------------------------------------------------------------
Traceback (most recent call last):
  File "e:\WINAPP_B\FreeCAD_0.19.20415-Win-Conda_vc14.x-x86_64\bin\lib\site-packages\numpy\core\__init__.py", line 24, in <module>
    from . import multiarray
  File "e:\WINAPP_B\FreeCAD_0.19.20415-Win-Conda_vc14.x-x86_64\bin\lib\site-packages\numpy\core\multiarray.py", line 14, in <module>
    from . import overrides
  File "e:\WINAPP_B\FreeCAD_0.19.20415-Win-Conda_vc14.x-x86_64\bin\lib\site-packages\numpy\core\overrides.py", line 7, in <module>
    from numpy.core._multiarray_umath import (
ImportError: DLL load failed while importing _multiarray_umath: 找不到指定的模块。

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "<string>", line 150, in InitApplications
  File "e:\WINAPP_B\FreeCAD_0.19.20415-Win-Conda_vc14.x-x86_64\bin\lib\importlib\__init__.py", line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1014, in _gcd_import
  File "<frozen importlib._bootstrap>", line 991, in _find_and_load
  File "<frozen importlib._bootstrap>", line 975, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 671, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 783, in exec_module
  File "<frozen importlib._bootstrap>", line 219, in _call_with_frames_removed
  File "e:\WINAPP_B\FreeCAD_0.19.20415-Win-Conda_vc14.x-x86_64\bin\lib\site-packages\freecad\asm3\init_gui.py", line 3, in <module>
    from .utils import mainlogger as logger
  File "e:\WINAPP_B\FreeCAD_0.19.20415-Win-Conda_vc14.x-x86_64\bin\lib\site-packages\freecad\asm3\utils.py", line 11, in <module>
    import numpy as np
  File "e:\WINAPP_B\FreeCAD_0.19.20415-Win-Conda_vc14.x-x86_64\bin\lib\site-packages\numpy\__init__.py", line 142, in <module>
    from . import core
  File "e:\WINAPP_B\FreeCAD_0.19.20415-Win-Conda_vc14.x-x86_64\bin\lib\site-packages\numpy\core\__init__.py", line 54, in <module>
    raise ImportError(msg)
ImportError: 

IMPORTANT: PLEASE READ THIS FOR ADVICE ON HOW TO SOLVE THIS ISSUE!

Importing the numpy c-extensions failed.
- Try uninstalling and reinstalling numpy.
- If you have already done that, then:
  1. Check that you expected to use Python3.8 from "e:\WINAPP_B\FreeCAD_0.19.20415-Win-Conda_vc14.x-x86_64\bin\freecad.exe",
     and that you have no directories in your PATH or PYTHONPATH that can
     interfere with the Python and numpy version "1.18.1" you're trying to use.
  2. If (1) looks fine, you can open a new issue at
     https://github.com/numpy/numpy/issues.  Please include details on:
     - how you installed Python
     - how you installed numpy
     - your operating system
     - whether or not you have multiple versions of Python installed
     - if you built from source, your compiler versions and ideally a build log

- If you're working with a numpy git repository, try `git clean -xdf`
  (removes all files not under version control) and rebuild numpy.

Note: this error has many possible causes, so please don't comment on
an existing issue about this - open a new one instead.

Original error was: DLL load failed while importing _multiarray_umath: 找不到指定的模块。

--------------------------------------------------------------------------------
OS: Windows 10 (10.0)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.20415 (Git)
Build type: Release
Branch: master
Hash: 7a0606715045a255ef0774e835b0091eef300ac9
Python version: 3.8.2
Qt version: 5.12.5
Coin version: 4.0.0
OCC version: 7.4.0
Locale: Chinese/China (zh_CN)