Unable to disable mouse zoom function- magic mouse on osx

Post here for help on using FreeCAD's graphical user interface (GUI).
Forum rules
and Helpful information
IMPORTANT: Please click here and read this first, before asking for help

Also, be nice to others! Read the FreeCAD code of conduct!
FunnyUshouldSayThat
Posts: 1
Joined: Thu Feb 13, 2020 5:10 pm

Unable to disable mouse zoom function- magic mouse on osx

Postby FunnyUshouldSayThat » Thu Feb 13, 2020 5:19 pm

Hi,
I'm running the current version 0.17 on OSX High Sierra with a magic mouse.
All the mouse options are allowing me to zoom as I move the mouse about which is all over the place.
I have changed prefs to the smallest zoom step size and it is manageable, however looking at the options 'Touch Pad' should block the mouse from zooming all together but I see no difference between any of them.

Is this a known issue or am I doing something wrong?
openBrain
Posts: 3441
Joined: Fri Nov 09, 2018 5:38 pm

Re: Unable to disable mouse zoom function- magic mouse on osx

Postby openBrain » Thu Feb 20, 2020 11:55 am

I'm not a MacOS user but I know there are known troubles with Magic Mouse. You can find other threads on the forum.

What you can do is using the Parameter editor (Tools -> Edit Parameters) and set Preferences/View/ZoomStep to 0 (which isn't possible from the preferences).