Multi transform pattern of a feature does not look right

Post here for help on using FreeCAD's graphical user interface (GUI).
Forum rules
and Helpful information
IMPORTANT: Please click here and read this first, before asking for help

Also, be nice to others! Read the FreeCAD code of conduct!
leoheck
Posts: 375
Joined: Tue Mar 13, 2018 5:56 pm

Multi transform pattern of a feature does not look right

Postby leoheck » Sun May 31, 2020 1:48 pm

I am making a multi transform of a feature and one of them does not look right.

This multi transform has
- Polar Pattern (adds 4 ribs around of a boss)
- Linear Pattern (replicates this in one axis)
- Linear Pattern (replicates this in the other axis)

Thre features were generated fine, top-right, bottom-right, bottom-left

Considering the top-left boss. Its top-left rib (X in the picture) was not well-formed. There, is a wall (mostly formed with BSPline). This wall can be related to why this rib is not being generated touching the boss like in the other places.

Screenshot-20200531104149-808x480.png
Screenshot-20200531104149-808x480.png (130.56 KiB) Viewed 156 times

Is this a bug or something am I doing is not good?
Last edited by leoheck on Sun May 31, 2020 3:09 pm, edited 1 time in total.
chrisb
Posts: 25206
Joined: Tue Mar 17, 2015 9:14 am

Re: Multi transform pattern of a feature does not look right

Postby chrisb » Sun May 31, 2020 2:25 pm

I have the strong feeling that I have seen the same question quite recently. Someone having the link?
kisolre
Posts: 2253
Joined: Wed Nov 21, 2018 1:13 pm

Re: Multi transform pattern of a feature does not look right

Postby kisolre » Sun May 31, 2020 5:41 pm

Hard to say just from the screenshot, without the file, but it looks ok to me. that top-left rib for the top-left boss is just generated inside the wall. What is so strange here?
leoheck
Posts: 375
Joined: Tue Mar 13, 2018 5:56 pm

Re: Multi transform pattern of a feature does not look right

Postby leoheck » Sun May 31, 2020 9:20 pm

kisolre wrote:
Sun May 31, 2020 5:41 pm
Hard to say just from the screenshot, without the file, but it looks ok to me. that top-left rib for the top-left boss is just generated inside the wall. What is so strange here?
I think for this it is fine, but it is not what I was expecting.
The top-left rib is not being generated between the wall and the boss.
But it is being generated (most of its mass) outside of the wall (hidden in this view)

If I could choose here, I prefer to avoid the external part, being able to have the internal part. haha

This is a better picture with the 0 transparency.

Screenshot-20200531181652-921x911.png
Screenshot-20200531181652-921x911.png (79.46 KiB) Viewed 105 times
openBrain
Posts: 4214
Joined: Fri Nov 09, 2018 5:38 pm

Re: Multi transform pattern of a feature does not look right

Postby openBrain » Sun May 31, 2020 9:25 pm

I agree that everything seems correct. What you see is just the interference with the 'bowl' shape.
openBrain
Posts: 4214
Joined: Fri Nov 09, 2018 5:38 pm

Re: Multi transform pattern of a feature does not look right

Postby openBrain » Sun May 31, 2020 9:31 pm

chrisb wrote:
Sun May 31, 2020 2:25 pm
I have the strong feeling that I have seen the same question quite recently. Someone having the link?
https://forum.freecadweb.org/viewtopic. ... 66#p387722 :?:
leoheck
Posts: 375
Joined: Tue Mar 13, 2018 5:56 pm

Re: Multi transform pattern of a feature does not look right

Postby leoheck » Sun May 31, 2020 9:58 pm

That time I was asking suggestions to implement that.

Now, I am just giving the feedback that this was not what I was expecting.
And I would like to hear from someone that this is the default behavior.
Otherwise, a bug report would be a good idea.
openBrain
Posts: 4214
Joined: Fri Nov 09, 2018 5:38 pm

Re: Multi transform pattern of a feature does not look right

Postby openBrain » Sun May 31, 2020 10:01 pm

As asked in the big red banner on top of the page, you should provide the file so we can vet the issue.
From the screenshots everything's right.
leoheck
Posts: 375
Joined: Tue Mar 13, 2018 5:56 pm

Re: Multi transform pattern of a feature does not look right

Postby leoheck » Sun May 31, 2020 10:09 pm

Sure openBrain I agree. You are right. But sometimes it is not possible.
Sometimes users just need to discuss a little bit to understand their issues.
You don't have to fix the world. Some words and ideas and directions can help users to figure out their own issues. Don't you agree?
openBrain
Posts: 4214
Joined: Fri Nov 09, 2018 5:38 pm

Re: Multi transform pattern of a feature does not look right

Postby openBrain » Sun May 31, 2020 10:25 pm

Once again, from the screenshots, everything looks as expected. Can't see any issue or even artifact.