[Solved] Many occurrences of error message '(call stack is not deep enough)'

Post here for help on using FreeCAD's graphical user interface (GUI).
Forum rules
and Helpful information
IMPORTANT: Please click here and read this first, before asking for help

Also, be nice to others! Read the FreeCAD code of conduct!
guiv
Posts: 6
Joined: Mon Apr 26, 2021 7:48 pm

[Solved] Many occurrences of error message '(call stack is not deep enough)'

Post by guiv »

I get a lot of error messages '(call stack is not deep enough)' while using FreeCAD 0.19
This looks like a bug to me, but according to bug reporting rules I first post in Help forum before creating an issue in bug tracker.

Configuration (copy-paste from 'About' window):
OS: openSUSE Tumbleweed (KDE//usr/share/xsessions/plasma5)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.Unknown
Build type: Release
Python version: 3.8.8
Qt version: 5.15.2
Coin version: 3.1.3
OCC version: 7.5.1
Locale: French/France (fr_FR)

Version of package as displayed by package manager:
FreeCAD 0.19.1-1.2 - x86_64

It is very probable my problem is linked to this one: https://forum.freecadweb.org/viewtopic.php?t=56148, however I can't be 100% sure.

One trivial way to reproduce issue:
- create one file xxx.FCStd, with one basic part (e.g. a simple cube, with all default values)
- save file, close FreeCAD
- open file from file manager, or from console: nothing is show on screen, and one occurrence of error message is displayed for each item in file. Example with a file containing only a simple cube: "Cannot create object 'Box': (call stack is not deep enough)"
Notes:
- close file, re-open it from FreeCAD file menu: part is shown correctly, without this error message
- I did not have the problem while I was using FreeCAD 0.18

This error message is also quite often displayed while manipulating parts, and is really annoying. Several times during part creation I had to abort some design steps, cancel and restart. However those occurrences seem more random to me. I am not (yet) able to provide a detailed description of another scenario which leads systematically to the error. If I can find any I will update this post.

As openSUSE Tumbleweed is a rolling release, FreeCAD's dependencies may be updated quite often. If it has any impact I will update this post.
I understand that the problem may be related to some specific versions of dependencies. However I am a beginner in FreeCAD, and I do not know which ones could be interesting to ease bug's analysis... Please do ask if any additional information could help.
Last edited by guiv on Wed Aug 25, 2021 10:05 pm, edited 3 times in total.
chrisb
Posts: 37807
Joined: Tue Mar 17, 2015 9:14 am

Re: Many occurrences of error message '(call stack is not deep enough)'

Post by chrisb »

Hi and welcome to the forum!

Please retry with the latest AppImage from here: https://github.com/FreeCAD/FreeCAD-Bund ... kly-builds and report back.
A Sketcher Lecture with in-depth information is available in English, auf Deutsch, en français, en español.
guiv
Posts: 6
Joined: Mon Apr 26, 2021 7:48 pm

Re: Many occurrences of error message '(call stack is not deep enough)'

Post by guiv »

Hi, and thanks for your reply
Just tested with the latest AppImage, problem is solved (at least when opening a file from console), thanks !

Tested in the following configuration:
OS: openSUSE Tumbleweed (KDE//usr/share/xsessions/plasma5)
Word size of FreeCAD: 64-bit
Version: 0.20.24789 (Git) AppImage
Build type: Release
Branch: master
Hash: 31b0f25b6df1d1707fdf74135093831eec4f0281
Python version: 3.9.2
Qt version: 5.12.9
Coin version: 4.0.0
OCC version: 7.5.1
Locale: French/France (fr_FR)

Note: openSUSE tumbleweed is working with a more recent version of Qt (5.15.2), this could be a possible explanation
chrisb
Posts: 37807
Joined: Tue Mar 17, 2015 9:14 am

Re: Many occurrences of error message '(call stack is not deep enough)'

Post by chrisb »

Thanks for the feedback. You may prepend "[Solved]" to the subject of the first post.
A Sketcher Lecture with in-depth information is available in English, auf Deutsch, en français, en español.
rolfKuck
Posts: 3
Joined: Thu Mar 01, 2018 3:42 pm

Re: [Solved] Many occurrences of error message '(call stack is not deep enough)'

Post by rolfKuck »

i experienced the same problem on openSUSE Tumbleweed
.
we should let openSUSE know about this
so that they can either fix the problem or withdraw FreeCAD from their repositories entirely
.
does anybody know where/how to report the issue
to the openSUSE team
?
StefanBruens
Posts: 2
Joined: Sun Nov 29, 2020 5:30 am

Re: [Solved] Many occurrences of error message '(call stack is not deep enough)'

Post by StefanBruens »

The AppImage is not a solution, it is a workaround.

If the problem is caused by Qt 5.12, the AppImage will be screwed soon as well (Qt 5.12 EOL: 2021-12-05).

If this is a problem which is solved in Git, bug not 0.19.1, then anybody used the latest stable release is screwed as well.
guiv
Posts: 6
Joined: Mon Apr 26, 2021 7:48 pm

Re: [Solved] Many occurrences of error message '(call stack is not deep enough)'

Post by guiv »

StefanBruens wrote: Thu May 06, 2021 11:06 am The AppImage is not a solution, it is a workaround.

If the problem is caused by Qt 5.12, the AppImage will be screwed soon as well (Qt 5.12 EOL: 2021-12-05).
I agree about the workaround. At least it makes it usable, until a better solution is found.
Regarding Qt version, opensuse tumbleweed uses a more recent version (Qt version: 5.15.2) than the AppImage I have tested (5.12.9)

It also means the problem could come back when the AppImage integrates an updated Qt...
rolfKuck
Posts: 3
Joined: Thu Mar 01, 2018 3:42 pm

Re: [Solved] Many occurrences of error message '(call stack is not deep enough)'

Post by rolfKuck »

the existence of a workaround
does not solve the issue
(i agree with Stefan)

hence i suggest changing the [SOLVED] status

an investigating into the issue
by knowledgable people (FreeCAD / Dolphin / openSUSE)
might lead to an actual solution

only this will avoid further frustration
especially to users giving FreeCAD
a first try by means of installing from the openSUSE repos
Syres
Posts: 1254
Joined: Thu Aug 09, 2018 11:14 am

Re: [Solved] Many occurrences of error message '(call stack is not deep enough)'

Post by Syres »

guiv wrote: Mon Apr 26, 2021 8:25 pm Coin version: 3.1.3
If you type the following in the Python Console, what do you get?

Code: Select all

import pivy
pivy.__version__
There have been similar error messages where python-pivy (for Python 3) was missing but could it be that there's an old version on your system?
guiv
Posts: 6
Joined: Mon Apr 26, 2021 7:48 pm

Re: [Solved] Many occurrences of error message '(call stack is not deep enough)'

Post by guiv »

Code: Select all

>>> import pivy
>>> pivy.__version__
'0.6.5'
Post Reply