Path Vcarve GUI Difficulty

Post here for help on using FreeCAD's graphical user interface (GUI).
Forum rules
and Helpful information
IMPORTANT: Please click here and read this first, before asking for help

Also, be nice to others! Read the FreeCAD code of conduct!
freecader2
Posts: 36
Joined: Thu Oct 22, 2020 11:19 pm

Path Vcarve GUI Difficulty

Postby freecader2 » Sun May 02, 2021 11:11 pm

Hi,

I'm having difficulty creating a Vcarve path. I can't figure out how to get the Path Workbench to create a vcarve operation. I've tried using the toolbar and menu buttons for a vcarve. But each time no new object (operation) is created, and no dialog/GUI shows up for me to do anything. I've tried clicking vcarve with several times with different selections: the shapestring, faces, compound, the job, the job stock, the job's model of the shapestring/faces/etc, and nothing at all.

The log below looks like it's receiving the command, and there aren't any errors, so I can't tell why nothing else happens. Does anyone know what's happening here or what I should try differently?

Thanks!

>>> ### Begin command Std_Workbench
>>> Gui.activateWorkbench("PathWorkbench")
>>> ### End command Std_Workbench
>>> ### Begin command Path_Job
>>> PathScripts.PathJobGui.Create(['Box', 'ShapeString'], None)
>>> ### End command Path_Job
>>> # Gui.Selection.addSelection('Unnamed','Clone2D')
>>> Gui.runCommand('Path_Vcarve',0)
>>> Gui.runCommand('Path_Vcarve',0)
>>> # Gui.Selection.clearSelection()
>>> # Gui.Selection.addSelection('Unnamed','Job')
>>> Gui.runCommand('Path_Vcarve',0)
>>> # Gui.Selection.clearSelection()
>>> # Gui.Selection.addSelection('Unnamed','ShapeString')
>>> Gui.runCommand('Path_Vcarve',0)

OS: Ubuntu 20.04.2 LTS (ubuntu:GNOME/ubuntu)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.24267 (Git) AppImage
Build type: Release
Branch: master
Hash: b2ca86d8d72b636011a73394bf9bcdedb3b109b7
Python version: 3.8.6
Qt version: 5.12.5
Coin version: 4.0.0
OCC version: 7.4.0
Locale: English/United States (en_US)
freecader2
Posts: 36
Joined: Thu Oct 22, 2020 11:19 pm

Re: Path Vcarve GUI Difficulty

Postby freecader2 » Wed May 05, 2021 3:01 pm

I found that this happens when the job doesn't contain an acceptable tool. Specifically, it needs to have a pointed/vbit type tool. Otherwise nothing at all occurs when you click the vcarve button (no error message, no GUI response, etc.).

I'm trying to find where in the code it checks for an acceptable tool so I could add some user feedback if it's missing. But haven't found the right spot yet...