Installation problems

A subforum specific to the development of the OpenFoam-based workbenches ( Cfd https://github.com/qingfengxia/Cfd and CfdOF https://github.com/jaheyns/CfdOF )

Moderator: oliveroxtoby

TestRig
Posts: 1
Joined: Sat Feb 06, 2021 9:39 am

Re: Installation problems

Postby TestRig » Sat Feb 06, 2021 10:12 am

I have had the same struggle. So far to me it seems:
The virtual box that comes with the openfoam v2006.exe file is out-dated and no longer supported by windows. I downloaded an up-to-date from:
https://www.virtualbox.org/wiki/Downloads

To get rid of the Set-ExecutionPolicy error you need to set the powershell to allow running scripts from Win+R, gpedit.msc.
-Navigate to Computer Configuration/Administrative Templates/Windows Components/Windows PowerShell. Double-click Turn on Script execution.
-Select RadioButton to Enabled and under Options: Execution Policy from the dropdown select Allow all scripts

I had quite some trial and error. But as always you need to start from the bottom. First thing is that you make sure that you can initialize the default docker-machine properly with power shell commands: "docker-machine rm -f default" to shutdown existing default machine and: "docker-machine create -d virtualbox --virtualbox-memory 2048 default" to start, back and forth and troubleshoot the problems.

If docker doesn't work everything else is broken also. There might be something else you need to do along the way so here is a list of links that helped me to get there.
https://stackoverflow.com/questions/400 ... -windows10
https://docs.microsoft.com/en-us/powers ... rshell-7.1
https://vladtalkstech.com/2014/03/chang ... 012r2.html

After installing current virtual box version I unticked the virtual box install when reinstalling the openfoam package.
Some of the steps listed might be unnecessary, but I finally made it. The dependency checker only complains about gmsh.