Installation problems

A subforum specific to the development of the OpenFoam-based workbenches ( Cfd https://github.com/qingfengxia/Cfd and CfdOF https://github.com/jaheyns/CfdOF )

Moderator: oliveroxtoby

tony271
Posts: 6
Joined: Fri Jun 22, 2018 6:32 am

Re: Installation problems

Postby tony271 » Sat Jun 23, 2018 7:31 pm

Problem update.

I tried same installation on a stand alone PC and got same problem.
I was able to install cfMesh only restarting windows in safe mode.
User avatar
oliveroxtoby
Posts: 219
Joined: Fri Dec 23, 2016 9:43 am

Re: Installation problems

Postby oliveroxtoby » Sun Jun 24, 2018 1:07 pm

tony271 wrote:
Sat Jun 23, 2018 7:31 pm
Problem update.

I tried same installation on a stand alone PC and got same problem.
I was able to install cfMesh only restarting windows in safe mode.
Thanks a lot for the information.

I tried an installation on my wife's Windows 10 machine but was unable to reproduce the problem there :(
I'm not able to come up with any ideas as to what could be at fault.

Are you able to reproduce this problem easily, or does it no longer occur now that you have got it installed in safe mode? If you can reproduce, I could try adding some debugging information and ask you to run it on your system to give us some hints.
tony271
Posts: 6
Joined: Fri Jun 22, 2018 6:32 am

Re: Installation problems

Postby tony271 » Tue Jun 26, 2018 6:18 am

oliveroxtoby wrote:
Sun Jun 24, 2018 1:07 pm
Are you able to reproduce this problem easily, or does it no longer occur now that you have got it installed in safe mode? If you can reproduce, I could try adding some debugging information and ask you to run it on your system to give us some hints.
I ' ll try it and post here any update.
tony271
Posts: 6
Joined: Fri Jun 22, 2018 6:32 am

Re: Installation problems

Postby tony271 » Fri Jun 29, 2018 4:16 pm

I tried a new installation.

- hard disk reformatted
- installed last Windows release (Windows 10 Pro 64 bit, version 1803).
- installed FeeeCAD 0.17 revision 13522
- installed CFD

no problems detected.
User avatar
oliveroxtoby
Posts: 219
Joined: Fri Dec 23, 2016 9:43 am

Re: Installation problems

Postby oliveroxtoby » Sun Jul 01, 2018 8:33 am

tony271 wrote:
Fri Jun 29, 2018 4:16 pm
I tried a new installation.

- hard disk reformatted
- installed last Windows release (Windows 10 Pro 64 bit, version 1803).
- installed FeeeCAD 0.17 revision 13522
- installed CFD

no problems detected.
Thank you very much for going to all that effort! I guess we'll have to see if anyone else reports the problem, and see if we can gather any more info from them...
thschrader
Posts: 1366
Joined: Sat May 20, 2017 12:06 pm
Location: Germany

Re: Installation problems

Postby thschrader » Sat Jul 21, 2018 10:40 am

Hi,
just updated the cfd-of-wb with addon-manager.
When activating the wb, I get an error.
system:
OS: Windows 10
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.14098 (Git)
Build type: Release
Branch: master
Hash: 0c33d00bfdf8270e7e5b33d792bf0ad9bbbfc819
Python version: 2.7.14
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.2.0
Locale: German/Germany (de_DE)
cfd_of_wb_update.JPG
cfd_of_wb_update.JPG (73.18 KiB) Viewed 173 times
thschrader
Posts: 1366
Joined: Sat May 20, 2017 12:06 pm
Location: Germany

Re: Installation problems

Postby thschrader » Sun Jul 22, 2018 10:14 am

deleted line 65 in initGui.py:
cfd-of-wb starts.
meshing with cfmesh/shm works.
gmsh does not (which wonder...)
solver runs.
initGui.JPG
initGui.JPG (115.04 KiB) Viewed 155 times
gmsh.JPG
gmsh.JPG (120.54 KiB) Viewed 155 times
cfmesh.JPG
cfmesh.JPG (129.26 KiB) Viewed 155 times
shmesh.JPG
shmesh.JPG (124.98 KiB) Viewed 155 times
run.JPG
run.JPG (165.77 KiB) Viewed 155 times
User avatar
oliveroxtoby
Posts: 219
Joined: Fri Dec 23, 2016 9:43 am

Re: Installation problems

Postby oliveroxtoby » Sun Jul 22, 2018 4:42 pm

thschrader wrote:
Sun Jul 22, 2018 10:14 am
deleted line 65 in initGui.py:
cfd-of-wb starts.
meshing with cfmesh/shm works.
gmsh does not (which wonder...)
solver runs.
Ah, sorry. That was an old import that should not be there. Not sure how that slipped through.

We've done quite a big refactoring of the meshing, allowing 2D meshes to be created now, but there are probably a few glitches. Unfortunately we have had to break backward file compatibility, so the mesh objects in saved files will have to be recreated. Don't think that's the problem here though.

Can you paste more text from the report view showing how the gmsh error begins? One can't conclude much from what is shown.

Thanks for the report.
Oliver
thschrader
Posts: 1366
Joined: Sat May 20, 2017 12:06 pm
Location: Germany

Re: Installation problems

Postby thschrader » Sun Jul 22, 2018 5:08 pm

oliveroxtoby wrote:
Sun Jul 22, 2018 4:42 pm
Can you paste more text from the report view showing how the gmsh error begins? One can't conclude much from what is shown.
Voila.
gmsh_report.txt
(3.86 KiB) Downloaded 5 times
cfdtest.FCStd
(20.83 KiB) Downloaded 4 times
User avatar
oliveroxtoby
Posts: 219
Joined: Fri Dec 23, 2016 9:43 am

Re: Installation problems

Postby oliveroxtoby » Sun Jul 22, 2018 8:40 pm

thschrader wrote:
Sun Jul 22, 2018 5:08 pm
oliveroxtoby wrote:
Sun Jul 22, 2018 4:42 pm
Can you paste more text from the report view showing how the gmsh error begins? One can't conclude much from what is shown.
Voila.
gmsh_report.txt
cfdtest.FCStd
Thanks. Should be sorted now.