Ubuntu install - installed paraview not found by Cfdof

A subforum specific to the development of the OpenFoam-based workbenches ( Cfd https://github.com/qingfengxia/Cfd and CfdOF https://github.com/jaheyns/CfdOF )

Moderator: oliveroxtoby

Kailee71
Posts: 13
Joined: Thu Mar 12, 2020 1:21 am

Ubuntu install - installed paraview not found by Cfdof

Postby Kailee71 » Tue Mar 17, 2020 2:04 am

Hi all,

I've just installed the following on my Ubuntu 19.10 box:

- freecad 0.18.4 from the -stable ppa via https://wiki.freecadweb.org/Install_on_Unix
- openfoam7 installed via https://openfoam.org/download/7-ubuntu/
- latest cfdof installed via addon manager, cfmesh and HiSA installed from cfd pref panel.

Meshing seems to works fine, only the paraview that comes with openfoam7 (installed in /opt/paraviewopenfoam56) won't start from the cfd meshing panel, like mentioned before in this thread. I'm getting this in console:

Code: Select all

Traceback (most recent call last):
  File "/home/kai/.FreeCAD/Mod/CfdOF/_TaskPanelCfdMesh.py", line 289, in openParaview
    self.open_paraview = CfdTools.startParaview(case_path, script_name, self.consoleMessage)
  File "/home/kai/.FreeCAD/Mod/CfdOF/CfdTools.py", line 874, in startParaview
    import distutils.spawn
ModuleNotFoundError: No module named 'distutils.spawn'
What can I do to fix this?


Many thanks,


Kai.
Last edited by Kailee71 on Tue Mar 17, 2020 1:04 pm, edited 1 time in total.
chrisb
Posts: 29035
Joined: Tue Mar 17, 2015 9:14 am

Re: [Solved] (Bug) Problem running the dependency checker

Postby chrisb » Tue Mar 17, 2020 6:05 am

Kailee71 wrote:
Tue Mar 17, 2020 2:04 am
What can I do to fix this?
This is marked as solved - what is it, how did you solve it??
A Sketcher Lecture with in-depth information is available in English, auf deutsch, en français, en español.
Kailee71
Posts: 13
Joined: Thu Mar 12, 2020 1:21 am

Re: [Solved] (Bug) Problem running the dependency checker

Postby Kailee71 » Tue Mar 17, 2020 9:56 am

Hi Chris,

it's not solved for me - standard install on Ubuntu as outlined by me above results in paraview not being found.

Does anyone have a workaround?

Tia,

Kai.
chrisb
Posts: 29035
Joined: Tue Mar 17, 2015 9:14 am

Re: Problem running the dependency checker

Postby chrisb » Tue Mar 17, 2020 10:59 am

I have split this from https://forum.freecadweb.org/viewtopic. ... 2&start=10, because it was added after the other topic was solved.
OP: feel free to change the subject of the first post of this topic, if possible to something less generic.
A Sketcher Lecture with in-depth information is available in English, auf deutsch, en français, en español.
Kailee71
Posts: 13
Joined: Thu Mar 12, 2020 1:21 am

Re: Ubuntu install - installed paraview not found by Cfdof

Postby Kailee71 » Tue Mar 17, 2020 1:05 pm

Ok thanks - done.
User avatar
oliveroxtoby
Posts: 437
Joined: Fri Dec 23, 2016 9:43 am
Location: South Africa

Re: Ubuntu install - installed paraview not found by Cfdof

Postby oliveroxtoby » Tue Mar 17, 2020 8:48 pm

Kailee71 wrote:
Tue Mar 17, 2020 2:04 am
Hi all,

I've just installed the following on my Ubuntu 19.10 box:

- freecad 0.18.4 from the -stable ppa via https://wiki.freecadweb.org/Install_on_Unix
- openfoam7 installed via https://openfoam.org/download/7-ubuntu/
- latest cfdof installed via addon manager, cfmesh and HiSA installed from cfd pref panel.

Meshing seems to works fine, only the paraview that comes with openfoam7 (installed in /opt/paraviewopenfoam56) won't start from the cfd meshing panel, like mentioned before in this thread. I'm getting this in console:

Code: Select all

Traceback (most recent call last):
  File "/home/kai/.FreeCAD/Mod/CfdOF/_TaskPanelCfdMesh.py", line 289, in openParaview
    self.open_paraview = CfdTools.startParaview(case_path, script_name, self.consoleMessage)
  File "/home/kai/.FreeCAD/Mod/CfdOF/CfdTools.py", line 874, in startParaview
    import distutils.spawn
ModuleNotFoundError: No module named 'distutils.spawn'
What can I do to fix this?


Many thanks,


Kai.
Should be solved - please update the workbench.
Kailee71
Posts: 13
Joined: Thu Mar 12, 2020 1:21 am

Re: Ubuntu install - installed paraview not found by Cfdof

Postby Kailee71 » Wed Mar 18, 2020 7:26 pm

Perfect - thank you very much!

I must say, as a long Alias/Catia user but only recent Freecad user, I'm very very impressed with it and it's extensibilty, especially cfdof. Never expected it to be so good, and that coupled with such a great community. Excellent!


Kai.
User avatar
oliveroxtoby
Posts: 437
Joined: Fri Dec 23, 2016 9:43 am
Location: South Africa

Re: Ubuntu install - installed paraview not found by Cfdof

Postby oliveroxtoby » Thu Mar 19, 2020 6:12 am

Kailee71 wrote:
Wed Mar 18, 2020 7:26 pm
Perfect - thank you very much!

I must say, as a long Alias/Catia user but only recent Freecad user, I'm very very impressed with it and it's extensibilty, especially cfdof. Never expected it to be so good, and that coupled with such a great community. Excellent!


Kai.
Thank you!
j2l
Posts: 18
Joined: Thu Apr 23, 2020 3:14 pm

Re: Ubuntu install - installed paraview not found by Cfdof

Postby j2l » Thu Apr 23, 2020 3:30 pm

I have the same bug with today's version.
I installed the workbench for the first time today, using Ubuntu 19.10, FreeCAD 0.19, OpenFoam 7, paraview 5.4.1 (using synaptic).
paraview can be launched via terminal (paraview) and using Ubuntu launcher (Super, paraview) and is working fine.

It just says

Code: Select all

0.0: Running paraview --script=pvScriptMesh.py
0.0: Paraview started
but nothing is started at all and no error in the report view.

EDIT: But it works with FreeCAD 0.18 so I guess something changed.
User avatar
oliveroxtoby
Posts: 437
Joined: Fri Dec 23, 2016 9:43 am
Location: South Africa

Re: Ubuntu install - installed paraview not found by Cfdof

Postby oliveroxtoby » Sat Apr 25, 2020 8:24 am

j2l wrote:
Thu Apr 23, 2020 3:30 pm
I have the same bug with today's version.
I installed the workbench for the first time today, using Ubuntu 19.10, FreeCAD 0.19, OpenFoam 7, paraview 5.4.1 (using synaptic).
paraview can be launched via terminal (paraview) and using Ubuntu launcher (Super, paraview) and is working fine.

It just says

Code: Select all

0.0: Running paraview --script=pvScriptMesh.py
0.0: Paraview started
but nothing is started at all and no error in the report view.

EDIT: But it works with FreeCAD 0.18 so I guess something changed.
Are you using the ubutu package for FreeCAD or the AppImage? Please paste your full system information
Please provide all the information requested in this post before reporting problems with CfdOF.