Model exit with error

A subforum specific to the development of the OpenFoam-based workbenches ( Cfd https://github.com/qingfengxia/Cfd and CfdOF https://github.com/jaheyns/CfdOF )

Moderator: oliveroxtoby

Sidemountyucatan
Posts: 71
Joined: Wed Apr 17, 2019 2:08 pm

Model exit with error

Postby Sidemountyucatan » Tue Feb 16, 2021 11:52 am

OS: Windows 10
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.4 (GitTag)
Build type: Release
Branch: releases/FreeCAD-0-18
Hash: 980bf9060e28555fecd9e3462f68ca74007b70f8
Python version: 3.6.6
Qt version: 5.6.2
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: German/Switzerland (de_CH)


Hi,

the model (box in a water flow -> try to figure out Karman's Vortex) attached exit always with error. I tried several inital conditions but always the same result.

What am I doing wrong ?
Attachments
Box in water flow.FCStd
(19.64 KiB) Downloaded 24 times
User avatar
oliveroxtoby
Posts: 500
Joined: Fri Dec 23, 2016 9:43 am
Location: South Africa

Re: Model exit with error

Postby oliveroxtoby » Tue Feb 16, 2021 8:35 pm

Sidemountyucatan wrote: Tue Feb 16, 2021 11:52 am

Hi,

the model (box in a water flow -> try to figure out Karman's Vortex) attached exit always with error. I tried several inital conditions but always the same result.

What am I doing wrong ?
Runs fine for me.
Please provide all the information requested in this post before reporting problems with CfdOF.
Sidemountyucatan
Posts: 71
Joined: Wed Apr 17, 2019 2:08 pm

Re: Model exit with error

Postby Sidemountyucatan » Wed Feb 17, 2021 7:31 am

OK, well now I'am speechless. Because in my case the following error message appears:

Generating stack trace...
08:35:52

Backtrace:
ZN10StackTraceC1Ev [0x705c1465+0x25]
module: C:\PROGRA~1\BLUECF~1\ThirdParty-5.x\platforms\mingw_w64GccDPInt32\lib\libstack_trace.dll
ZN4Foam5error10printStackERNS_7OstreamE [0xfc1c88+0x218]
module: C:\PROGRA~1\BLUECF~1\OpenFOAM-5.x\platforms\mingw_w64GccDPInt32Opt\lib\libOpenFOAM.dll
ZN4Foam6sigFpe13sigFpeHandlerEi [0xfc2af3+0x33]
module: C:\PROGRA~1\BLUECF~1\OpenFOAM-5.x\platforms\mingw_w64GccDPInt32Opt\lib\libOpenFOAM.dll
(No symbol) [0x403ccd]
module: C:\PROGRA~1\BLUECF~1\OpenFOAM-5.x\platforms\mingw_w64GccDPInt32Opt\bin\potentialFoam.exe
_C_specific_handler [0x7ffad5e58048+0x98]
module: C:\Windows\System32\msvcrt.dll
0_chkstk [0x7ffad6e01eef+0x11f]
module: C:\Windows\SYSTEM32\ntdll.dll
RtlRaiseException [0x7ffad6dcaad9+0x399]
module: C:\Windows\SYSTEM32\ntdll.dll
KiUserExceptionDispatcher [0x7ffad6e00b5e+0x2e]
module: C:\Windows\SYSTEM32\ntdll.dll
(No symbol) [0x439323]
08:35:52 module: C:\PROGRA~1\BLUECF~1\OpenFOAM-5.x\platforms\mingw_w64GccDPInt32Opt\bin\potentialFoam.exe
(No symbol) [0x44146e]
module: C:\PROGRA~1\BLUECF~1\OpenFOAM-5.x\platforms\mingw_w64GccDPInt32Opt\bin\potentialFoam.exe
(No symbol) [0x461313]
module: C:\PROGRA~1\BLUECF~1\OpenFOAM-5.x\platforms\mingw_w64GccDPInt32Opt\bin\potentialFoam.exe
(No symbol) [0x4013f7]
module: C:\PROGRA~1\BLUECF~1\OpenFOAM-5.x\platforms\mingw_w64GccDPInt32Opt\bin\potentialFoam.exe
(No symbol) [0x40152b]
module: C:\PROGRA~1\BLUECF~1\OpenFOAM-5.x\platforms\mingw_w64GccDPInt32Opt\bin\potentialFoam.exe
BaseThreadInitThunk [0x7ffad5967c24+0x14]
module: C:\Windows\System32\KERNEL32.DLL
RtlUserThreadStart [0x7ffad6dcd721+0x21]
module: C:\Windows\SYSTEM32\ntdll.dll
Sidemountyucatan
Posts: 71
Joined: Wed Apr 17, 2019 2:08 pm

Re: Model exit with error

Postby Sidemountyucatan » Wed Feb 17, 2021 7:36 am

I tried to run older simulation to see if there is any problem with the system (Windows-update or something else) causing this issue.
They work fine. Just this one doesn't work. :?: :?: :?:
thschrader
Posts: 2146
Joined: Sat May 20, 2017 12:06 pm
Location: Germany

Re: Model exit with error

Postby thschrader » Wed Feb 17, 2021 10:37 am

For me it works.
bluecfd 2017-2 and
OS: Windows 10 (10.0)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.24054 (Git)
Build type: Release
Branch: master
Hash: ed873038025277f220dfaa058599a0dfbb435835
Python version: 3.6.8
Qt version: 5.12.1
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: German/Germany (de_DE)
cube.JPG
cube.JPG (29.44 KiB) Viewed 623 times
Sidemountyucatan
Posts: 71
Joined: Wed Apr 17, 2019 2:08 pm

Re: Model exit with error

Postby Sidemountyucatan » Wed Feb 17, 2021 11:06 am

I dont get it. What the heck is going on ???
Sidemountyucatan
Posts: 71
Joined: Wed Apr 17, 2019 2:08 pm

Re: Model exit with error

Postby Sidemountyucatan » Wed Feb 17, 2021 11:18 am

I did a dependencies check and everything was OK. What I realized is that when opening the case in Freecad the "PhysicsModel" -"FluidProperties" and "InitioalizeFields" - objects have this marking and the solver object is greyed out. (see attached pciture)

Is it the hint that something does not work properly ?
Attachments
Model problem.jpg
Model problem.jpg (35.04 KiB) Viewed 606 times
User avatar
oliveroxtoby
Posts: 500
Joined: Fri Dec 23, 2016 9:43 am
Location: South Africa

Re: Model exit with error

Postby oliveroxtoby » Wed Feb 17, 2021 11:56 am

Sidemountyucatan wrote: Wed Feb 17, 2021 11:06 am I dont get it. What the heck is going on ???
See if you can run the case in series (set Parallel to false in the CfdSolver properties). If that works, it's probably a problem with the MPI installation. Unfortunately it is impossible to tell from the stack trace you posted. We need all the output to give it context.

If it works in series, try uninstalling and re-installing BlueCFD or try installing the Mingw OpenFOAM package from the preferences page.
Sidemountyucatan
Posts: 71
Joined: Wed Apr 17, 2019 2:08 pm

Re: Model exit with error

Postby Sidemountyucatan » Wed Feb 17, 2021 1:41 pm

I appreciate your input very much ! I tried the series run but there was no success either.

I attached the whole message which was posted by the system when start the simulation (but in parallel case) until error happened. see attached file. (is that what you meant ? Or is there any more detailed error protocoll somewhere in the system ?)

Meanwhile I'll try to uninstall and reinstall BlueCFD.
Attachments
Error_message_Simulation.txt
(18.2 KiB) Downloaded 19 times
Sidemountyucatan
Posts: 71
Joined: Wed Apr 17, 2019 2:08 pm

Re: Model exit with error

Postby Sidemountyucatan » Wed Feb 17, 2021 1:58 pm

Meanwhile I also tried to unsinstall and reinstall BlueCFD core. Doesn't work better. During reinstallation window popped up that MPI or newer version is already installed. Should I uninstall MPI also and do the reinstallation again ?